Skip navigation

Raul Cocias [AM] Benefits of What If Depreciation Functionality  

 

PeopleSoft Asset Management provides you with the ability to perform what if depreciation simulation modeling and to load the net book value results into a spreadsheet program for analysis  

 

Another useful benefit of the What If Depreciation feature is to project the depreciation if you add an asset and run the actual depreciation program. For example, you can create an asset and run the What If Depreciation program rather than running the actual depreciation program. You can then see what the depreciation amount for the asset would be, go back and modify the depreciation parameters accordingly, and then perform the actual depreciation.

 

The What If Depreciation page uses the AM_DEPR_COMP application engine program to run simulated depreciation instead of the actual depreciation program (AM_DEPR_CALC).Path: Asset Management, Depreciation, What If Scenarios, Request, What If Depreciation

Upgrade Task.png

In FSCM 9.2 database the EOAW_COMMENT Application Engine can be used to migrate the approval comments in the XREF tables delivered with the Comment Redesign feature into the new tables EOAW_COMMENTS and EOAW_HIS_COMM.  To migrate the comments follow the instructions in Document 2060222.1.


Further FSCM upgrade documentation can be found the “Upgrade Start Here Information Center” (Document 1587686.2).

Mohit Jain          RSS Feed Using PS Query 

 

RSS (Rich Site Summary) feeds which are commonly used to publish frequently updated information removes the need for the user to manually check the website for new content. Feeds provide rapidly changing content available to users. These Web feeds are also available in PeopleSoft and are configured via PeopleTools Feed Publishing Framework. RSS Feeds Using PS Query can be useful in scenarios where business administrators review Query Data by logging into the system and running the query. PeopleSoft applications offer feeds in Atom 1.0 format only.

 

The Feed Publishing Framework provides a simplified guide for content owners and administrative users to create, configure, and maintain feed definitions and feed templates of various types. You Integration Broker should be properly configured and running for using feeds.

We created a PS Query which fetched details of all the Expense Reports that are in pending status. For our use case, we used this query to publish feed which can be used by BU Expense Admin to monitor the Expense Reports.

 

For details on this use case setup, please refer the attached document.

 

PS Query feeds can be published in two ways:

 

     1.    Publishing Using the Publish as Feed Pages-

            Navigation - Reporting Tools > Query > Query Manager, Select the query that you want to publish as a feed and click the Edit link.

     2.    Publishing Using the Feed Publishing Wizard-

            Navigation - PeopleTools, Feeds, Feed Publishing Wizard

 

Published feeds can be directly subscribed using tools like MS Outlook.

For more detailed information on this feature, please read the following PeopleBooks Chapter: Feed Publishing Framework Overview and Understanding Query Feeds.  

Mohit Jain CI Based Web Service 

 

Integration of PeopleSoft based systems with tools/legacy systems has always been an industry need. CI Based Web Service enables developers to provide an interface to expose the existing PeopleSoft System’s capabilities to third party systems without compromising on the security implemented in the Business Layer.

 

PeopleSoft Integration Broker enables you to take an existing component interface and create a service that can be used to invoke the component interface. Further, it creates service operations, including request messages and response messages (if appropriate). The system creates an inbound any-to-local routing for the service operation version, as well as handlers for each method you choose to include in the service. All service operations you generate from component interfaces are synchronous service operations.

 

We tested this by creating a CI for the Expense Report Entry component and then utilizing it for creating a Web Service that can search for existing Expense Reports. For details, please refer the attached document.

 

For creating Service Operation for Component Interface, use the following navigation:
•     PeopleTools > Integration Broker > Web Services > CI-Based Services
For generating Web Service from Service Operation, navigate as follows:
•    PeopleTools > Integration Broker > Web Services > Provide Web Service

 

For more detailed information on this feature, please read the following PeopleBooks Chapter: Understanding Creating Component Interface-Based Services

Raul Cocias Asset Management Methods of Recalculation 

 

How the system recalculates depreciation is in part dependent on the calculation type that you specify in the  Depreciation Attributes section of the Asset Book - Definition page.

The two methods of recalculation are:

  1. Remaining Value.
  2. Life-to-Date.

1. Remaining Value Calculation

AM_RECALC_01.png

2. Life-to-Date Calculation 

AM_RECALC_02.png

  • Original Cost+ Additional Cost =  New Cost
  • New cost delivered by number of periods to date =  What accumulated depreciation should have been
  • New accumulated depreciation – old accumulated depreciation = Adjustment to current period

 

Use the following examples to explain the difference between remaining value and life-to-date calculations: You purchased a piece of machinery 24 months ago: Cost 50,000,Life 60,Method Straight Line, Convention Actual Month, Depr/Period 833.33, Depreciation to date 20,000; NBV 30,000; At this point, remaining value /LtD does not matter. You increase the cost by 5,000 in Month 25 as an Adjustment.

 

Next, you need to recalculate depreciation. The recalculation method that you selected now applies:

Remaining Value
30,000 (RV) + 5,000 (adj) = 35,000/36 remaining months = 972.22/month for remaining months.


Life-to-Date
Two calculations required (Per FASB - if you change depreciation method - must recalculate LtD)

  • Depreciation for 50,000 (original) +5,000 (adj) = 916.67/mo for 60 months
  • Depreciation for 24 months = 22,000
  • Depreciation taken so far = 20,000
  • Difference to date: 2,000

The system will make the adjusting entry (PDP) in the current period and the new depreciation amount will continue for the remainder of the asset's life

The Affordable Care Act Position Paper has recently been updated.  We are getting ready to release additional functionality to support the IRS employer reporting requirements.  We have updated the PeopleSoft Position Statement to include additional information on what is being delivered, target dates for delivery, as well as links to our upcoming Advisor Webcasts to review the new functionality. 


Please log on to My Oracle Support Document 1080659.1 to view the most recent PeopleSoft Position on the Affordable Care Act. The updated information can be located on pages 30 and 31 in the document. 


Please also note that in the Position Paper is a statement that PeopleSoft is no longer considering using the XML Framework as part of the design to support the 1095-C forms. Therefore the XML Framework functionality delivered in Release 9.1 (Bundle 15 and 16) is no longer a prerequisite. Regardless of this change, PeopleSoft always recommends you stay up-to-date with all Bundle Maintenance.

Are you wondering where to begin with preparations for the Campus Solutions 9.2 and the selective adoption process?


Campus Solutions 9.2 will enable new methods for managing the Continuous Delivery Model with PeopleSoft Update Manager (PUM).  PUM is a new, innovative way to manage system updates, fixes, and new feature functionality as they are released. Customers can tailor their maintenance to the needs of their campus, taking only the items that meet their needs while also reducing the time, effort, and cost required to maintain Campus Solutions.

 

A white paper, 'Preparing for Selective Adoption in Campus Solutions 9.2', has been published and is available on knowledge article 'Information on PeopleSoft Enterprise Campus Solutions 9.2 (Doc ID 1683816.1)The white paper contains links to many valuable resources  on the Selective Adoption Process and PeopleSoft Update Manager (PUM).  Included in the white paper is a link to the PUM Home page and some reference to training videos.


In addition to the training available on the PUM Home Page, knowledge article 'PeopleSoft Applications 9.2: Upgrade Strategy and Best Practices (Doc ID 1930037.1)' provides in depth information on preparing for your upgrade, including a training video.

Mohit Jain Tracing in PeopleSoft Applications


The FMS EX team's Mohit Jain has consolidated some of the most frequently used tracing methods that are used within PeopleSoft Applications, covering Application Engine , PeopleCode , Integration Broker , nVision , Cobol & SQR tracing.

 

Application Engine Trace

For Application Engine programs, Open the Process Definition under PeopleTools, Process Scheduler.  Go to the Override tab, and on the Parameter list line select Append from the dropdown, and in the edit box next to it, enter the desired combination of traces, they all are -

Parameter List    Append    -TRACE 7 -TOOLSTRACEPC 4044  -TOOLSTRACESQL 31

 

Save the Definition and this program will be traced each time it is run, until this is removed.  Using both the -TOOLSTRACEPC & -TOOLSTRACESQL together should only be done when required, as the output from both go into the same file, making it very large and difficult to read.  For normal program tracing use-

 

-TRACE 7 -TOOLSTRACEPC 4044

 

Give the Application Engine Trace, which traces the SQL in an Application Engine program, and the PeopleSoft Trace, which is the people code trace.

 

The above settings have equivalent settings in psprcs.cfg, they are-

 

TraceAE=    -TRACE  output goes into Application Engine Trace (.AET)

TracePC=    -TOOLSTRACEPC  output goes into the PeopleTools trace file (.trc)

TraceSQL=  -TOOLSTRACESQL output ALSO goes into the PeopleTools trace file (.trc)

 

With the AE traces done like this, every time any program that runs  on that process scheduler will be traced.  You need  to undo all of this setting back to None in Process Definitions will turn it off.

 

PeopleCode Online Trace

For tracing PeopleCode/SQL, debug values can be setup in the PIA while performing the transactions. You can use this before performing the actual transaction to ensure only useful trace information is fetched for analysis.  Open Trace PeopleCode/SQL under PeopleTools, Utilities, Debug.  When you want to take online trace for a transaction, follow these steps-

  a) Go to folder of the component or stop before doing a suspected transaction

    b) Open a new window and go to PeopleTools > Utilities > Debug > Trace PeopleCode

201509_PCodeTrace01.png

    c) Apply PC parameters, for ex. PC= 4044 (4+8+64+128+256+512+1024+2048) and save.

    d) Open one more new window, go to PeopleTools > Utilities > Debug > Trace SQL

201509_PCodeTrace02.png

    e) Apply SQL trace parameters, for ex. SQL = 7 (1+2+4)

    f) Go back to the transaction/launch the component and perform your desired action.

    g) As soon as you get the error press ok and signout.

    h) Pull the trace file from appserver logs and attach it to the SR.

The generated trace files can be located under PS_HOME/appserv/<DBNAME>/Logs/ directory of the application with a file extension of tracesql.

 

SQR Trace

SQR Report traces are a bit different than the Application Engine traces, Cobol traces, and online traces.

You can enable tracing for any particular Application Engine process or Cobol process, or trace any online user action. Development doesn't have to do anything specific when creating that Application Engine process, or Cobol process, or wrote the PeopleCode for a particular functionality.

This is not the case with SQR Reports. A SQR Report must have been explicitly written by the developers to include trace code. If the SQR Report does not have trace code, no information will be provided in the trace file.

1. Search for the file of the SQR you want to trace in your ‘%PS_HOME%\sqr’ directory.

2. Open the copy of the SQR file with a text editor such as Notepad.

3. Search for the keyword 'debug' or 'DEBUG' from top to bottom and write down the letters (the case is important) that are after the word 'debug' or 'DEBUG' (in the example below, there are a 'DEBUGA and a' 'DEBUGB' a so write down A and B). Again, this is not available in all SQR Report. The SQR Report must have been explicitly written by the developers to include trace code. If the SQR Report does not have trace code, the ‘–debug’ flag will not provide any tracing information.

201509_SQRTrace01.png

4. Sign in the PIA.

5. Navigate to the ‘Processes’ component and select the SQR Report that you would like to get a trace on. Be careful because there’s also a Process Type called ‘SQR Process’. What you need is the ‘SQR Report’ Process Type.

6. Go to the ‘Override Options’ tab, set the ‘Parameter List’ option to ‘Append’, add the SQR flags in the text box, and save.  -debugXYZ -S

201509_SQRTrace02.png

    • XYZ should be replaced by the letters you found at step 3. (the letter case is important).

    • Each SQR flag is separated by a blank space.

    • -S shows SQL cursors.

    The letter F is often used for program flows, D for data, and T for timing information. Other letters such A or B are used for additional information.

7. Go ahead and run the SQR that you would like to get a trace on. Get the trace file in the ‘Process Requests’ component, click on the ‘Details’ hyperlink for your Process Instance.

8. Do not forget to turn tracing off by setting the ‘Parameter List’ option to ‘None’ in the ‘Process Definitions’ component – ‘Override Options’ tab and saving.

 

Integration Broker - Subscription Trace

 

This type of trace is used in conjunction with PC and SQL trace to debug the handlers written for service operation. This may require help of your technical team as there are few code lines that need to be added to the handler App Package.  Code lines marked in red are added to the method of the Application Class for setting up trace values.

201509_IBTrace01.png

The generated trace files can be located under PS_HOME/appserv/<DBNAME>/Logs/ directory of the application.

 

Note :  At the end of trace generation, turn off the App Package trace setting (by removing the 4 lines Marked in Red.)

 

COBOL Trace


1) If the COBOL process is going to be run on a Windows scheduler:

    a) Open the appropriate  Process Type Definition, for example;

 

          Process Type: COBOL SQL

          Operating System: Windows

          Database Type: Oracle

 

    b) Copy the whole parameter list line into your clipboard.

          %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    c) Open the Process Definition for the particular COBOL Process that needs to be traced e.g PTPDBTST, go to the Override Options Tab, and on the Parameter List line, select          Override from the drop down.

    d) In the Parameters edit box, paste the whole parameter list from the Process Type Definition retrieved earlier.

          %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    e) Notice at the end of the line after the %%INSTANCE%% and before the %%DBFLAGS%% there are 2 forward slashes //

        Insert the desired bit map number inbetween the slashes.  Choose the bitmap number desired ( e.g 255 ) for the trace, and put it between the slashes per the following.

        %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%/255/%%DBFLAG%%

    f) Save the Process Definition. Launch the COBOL program through a PSNT scheduler.

    g) Navigate to the Process Monitor, Details, Parameter List, and you should see the expanded command line with the trace value inserted.

          Command Line:

          C:\BLD\G\H910\ORA\H910GXBU\CBLBINU\PTPDBTST.EXE ORACLE/H910GXBU/PS/OPRPSWD/1/5057/255/0

          Working Dir:

          C:\apps\db\ora\64bit\BIN

 

2) If the COBOL process is going to be run on a UNIX/Linux scheduler:

    a) Open the appropriate Process Type Definition, for example;

 

          Process Type: COBOL SQL

          Operating System: Unix

          Database Type: Oracle

 

    b) Copy the whole parameter list line into your clipboard.

          %%PRCSNAME%% %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    c) Open the Process Definition for the particular COBOL Process that needs to be traced e.g PTPDBTST, go to the Override Options Tab, and on the Parameter List line, select          Override from the drop down.

    d) In the Parameters edit box, paste the whole parameter list from the Process Type Definition retrieved earlier.

          %%PRCSNAME%% %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    e) Notice at the end of the line after the %%INSTANCE%% and before the %%DBFLAGS%% there are 2 forward slashes //

          Insert the desired bit map number inbetween the slashes.  Choose the bitmap number desired ( e.g 255 ) for the trace, and put it between the slashes per the following.

          %%PRCSNAME%% %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%/255/%%DBFLAG%%

    f) Save the Process Definition. Launch the COBOL program through a PSUNX scheduler.

    g) Navigate to the Process Monitor, Details, Parameter List, and you should see the expanded command line with the trace value inserted.

          Command Line:

          PSRUN PTPDBTST ORACLE/E91DMO/VP1/%OPRPSWD%/1/475/255/%DBFLAG%

          Every time the program runs, it will be traced.

 

PS/nVision Trace

 

By default, PS/nVision does not generate trace files because extensive tracing can affect system performance. You can enable tracing and determine the tracing level when you need debugging. You configure PS/nVision tracing on the web using the Trace Level setting in the PeopleSoft Process Scheduler configuration file's nVision section. The default value is 0.

 

PS/nVision supports five tracing levels: 0, 1, 2, 3, and 4. The following table shows the level of tracing for each value.

201509_NVisionTrace01Y.png

Viewing the Trace Files for PS/nVision on Windows-

In Microsoft Windows PS/nVision, the trace file is generated in your system temporary directory; for example c:\temp\psnvs_123.nvt.

 

Viewing the Trace Files on the Web-

On the web, because PeopleSoft Process Scheduler initiates all PS/nVision processes, it is also responsible for displaying PS/nVision trace information in the Process Monitor after PS/nVision reports are run to completion. The PS/nVision trace files are independent of the Process Scheduler's status of the report running, and are always posted regardless of your output types or formats. Trace files are secured by the same user list as the report, so only the same set of users can view them.

PS/nVision trace files are automatically purged when the reports are purged in the time frame that you have set from the Process Scheduler System Purge Option. You can view trace files from the View Trace/Log page in Process Monitor for your completed process instance.

To view a trace file:

1. Select select PeopleTools, then select Process Scheduler, then select Process Monitor.

2. Find the process instance that runs your nVision report, and then click the Details link to access the Process Details page.

3. Click the View/Trace Log link to access the Message Log page.

4. Click the nVision Trace link to view the trace file.

If Process Scheduler has restarted your nVision report running process, this procedure generates multiple nVision trace files (one for each retry).

Did you know that you can click on the “Help” link within your application pages and have it open PeopleBooks topics related to the specific page you have open?  As an example, in the screen shot below the Schedule page under Maintain Requisition component in the Purchasing application is open, by clicking on the “Help” link the system will open a new page and display all related PeopleBooks topics for the page. You can then click on the PeopleBooks link for the area of interest and learn more about the features provided in this page/area. This is a great feature to have as it allows you to quickly access product information within PeopleBooks and saving you time searching for your answers!
Help PeopleBooks.bmp

The PeopleBooks Help link is not only available for PeopleSoft applications, you can also use it in Application Designer. Setting up PeopleBooks Context-Sensitive Help is easy and only takes a few minutes. More information about this feature and how to set it up is in Document 1390571.1 (Information on Oracle Hosted PeopleSoft Enterprise PeopleBooks).

Welcome to the My Oracle Support Community! We highly encourage you to personalize your community display name to make your activity more memorable. Please see https://community.oracle.com/docs/DOC-1022508 for instructions.