Skip navigation

As many customers are aware, the PeopleSoft HCM Team delivered PUM Image #20 earlier this month (December 9, 2016). 

 

The video highlights can for the image release be seen here:

http://www.youtube.com/watch?v=5lgO3Sk3qIk&feature=youtu.be

 

One of the key enhancements delivered in Image #20 is the Fluid Approvals functionality.

 

Per prior announcements in the Community, customers should be aware of following key changes:

  • PeopleSoft is replacing Fluid Approvals using Mobile Application Platform technology with new Fluid Approvals using Enterprise Components – Fluid Approvals technology. 
  • Software modifications were done to enable Fluid Approval for existing approval transactions in HR product.
  • As each of these new Fluid Approvals is released, it will replace the current Fluid Approval.
  • PeopleTools 8.54.27 and higher OR PeopleTools 8.55.10 and higher is the minimum tools requirement.
  • By June 2017, the Fluid Approvals using MAP technology will no longer be supported by Oracle.
    • MAP technology from PeopleTools is still supported, only Fluid Approvals using MAP technology will no longer be supported.

 

Customers can review the following Knowledge Articles for more information:

  • PeopleSoft Fluid Approvals Installation Documentation (Doc ID 2166359.1)
  • Fluid (HCM): Frequently Asked Questions on New Fluid Approvals (Doc ID 2201476.1)
  • EOPC: Frequently Asked Questions on New Page Composer Fluid Approvals (Doc ID 2197974.1)
  • E-AWE: After Implementing FSCM PUM 020 on PT 8.53, Getting Error Opening Approval Process (Doc ID 2192968.1)

 

An Advisor Webcast is scheduled to discuss this topic: 

 

  • Tuesday , January 24, 2017 01:00 PM (US Pacific Time)
  • Tuesday , January 24, 2017 04:00 PM (US Eastern Time)
  • Tuesday , January 24, 2017 10:00 PM (Central European Time)
  • Wednesday, January 25, 2017 02:30 AM (India Standard Time)

 

To Register for this Advisor Webcast: https://oracleaw.webex.com/oracleaw/onstage/g.php?d=593968916&t=a

Talking about Upgrades IV:  Upgrade Source Images

 

What is it:  A PUM Image, delivered in DPK format, that will install a complete environment* to be used in an upgrade.

The *indicates that the PsHome codeline is not included.  The codeline can be obtained from the virtual CDs posted to the Oracle Support Delivery Cloud (previously called e-delivery). 

 

Used for:   To quickly install an upgrade source environment to be used in an upgrade.

Not used to search for and obtain required-for-upgrade fixes.

 

Where to find:   Links to the DPKs and installation instructions are posted to the PeopleSoft Upgrade Source Images Home Page (Doc ID 1552580.1).

 

Need to install the Source in the classic manner

However, there are some instances where you need to install the upgrade source environment in the 'classic' manner.  This is where you download the virtual CDs from the Oracle Support Delivery Cloud (previously called e-delivery).  This would include situations where:

 

--Can't find the upgrade source for my product

At the time of this writing, there is no upgrade source created for the Interaction Hub 9.1 product (previously called Enterprise Portal). If there is not an upgrade source available, you will need to install the new source environment in the classic manner, from the VCDs found on the Oracle Support Cloud (previously called e-delivery).  Install instructions are attached to the PeopleTools Installation Home Page for your release, and the Applications' Installation or Documentation Home Page. 

 

--Unicode vs. non-unicode

The upgrade source images are delivered in unicode format.  If your environments are in non-unicode format, then use of the upgrade source images is not for you.  Instead, install your new source environment in the classic manner, from the VCDs found on the Oracle Support Cloud (previously called e-delivery).

 

--Multi Language considerations

At this time, the delivered upgrade source images are English-only.

 

On the PeopleSoft Upgrade Source Images Home Page (Doc ID 1552580.1), in the Comments box in the chart, there is text that says:

... This upgrade source image is for ENGLISH-ONLY customers.If you use or require multi-lingual functionality,

then you must install the Demo Database using the classic installation method. See the installation home page for your application for more information.

 

However, there are other upgrades, where the comment box text says:

You can use this upgrade source image for ALL platforms and languages currently certified for the <specific upgrade>.  If you use or require multi-lingual functionality, review Getting Started on Your PeopleSoft Upgrade (Doc ID: 739129.1) for additional instructions that need to be performed on the upgrade source image.

 

...which are...

 

If your Upgrade Source Image is listed as being supported for multilingual upgrades and you are a multilanguage customer, you will need to perform the following instructions to complete your source image for use in the upgrade:

 

1. Install a complete codeline from the CDs, including all of your licensed languages, after installing the delivered upgrade source image.

 

2. Load your non-English licensed languages into the Upgrade Source Image. The delivered upgrade source image is English-only.

The delivered translations are on the same PeopleTools patch and application maintenance level as the source

image, so you will want to load the translations into your database prior to applying any PeopleTools maintenance.

 

--Not using the Oracle database platform 

You can use the upgrade source image, but will also need to download the virtual CD from Oracle Software Delivery Cloud and then install the full codeline for use with your upgrade.

 

Alternatives to Using an Upgrade Source

Can the regular Pum Image (PI) also called PeopleSoft Image, be used for the Upgrade Source?

  1. See E-PUM: Can the PUM Image be Used as SOURCE Database During Upgrade? (Doc ID 1581790.1).

 

Platforms

For the latest upgrades, the images are delivered in formats:

--VirtualBox

--NativeOS - for Windows or Linux

    The  NativeOS downloads are for Linux and Windows sites. 

[The text in doc 1552580.1 says "Advanced Windows" but this was to have been edited to be "Windows".]  This download allows you to apply your PeopleSoft Update Image directly to your OS or a virtualization platform without having to use VirtualBox.

 

Required for Upgrade Patches

Why do the upgrade source images not contain all the required-for-upgrade patches?

Most likely there is a PUM Image (PI) or two released after the upgrade source image's GA date.

The PIA will contain the very latest required-for-upgrade patches created after the upgrade source image was released. 

 

The upgrade source images do not contain the upgrade template; these are delivered in the PI.

 

As of PeopleSoft PeopleTools 8.55, the application upgrade template is delivered within the most current Update Image. You will need to generate the template out of the most current update image since the upgrade template can only be downloaded via the upgrade package. You will need to define the required-for--upgrade packages and create the upgrade template before performing your application upgrade in Change Assistant.

 

Don't see the exact upgrade source image for the upgrade you want to do...?

 

Application differences

--Upgrade source is delivered on (example) PI 9, and you want to go to PI 10.  You can use the Upgrade source, perform the upgrade to PI 9, and then apply patches from PI 10.

 

A poor choice would be to apply PI 10 to the Upgrade Source, and then do the upgrade. The upgrade

was written to go to PI 9, not 10, and scripts or conversion programs might not be successful if you modify the upgrade path.

 

See Upgrade Certification Path on each upgrade home page:    E-UPG Understanding the Upgrade Certification Path section of an Upgrade Home Page (Doc ID 1970917.1).

  

PeopleTools release differences

 

--The minor Tools patches can be applied to an upgrade source.  Use the upgrade source just like

it had been installed in the classic manner.  The instructions are the Tools patch readme.

 

--Full Tools release   

**If your upgrade is certified** on a later PeopleTools release level than the Upgrade Source Image and you want to use the later PeopleTools release to upgrade, then you must upgrade the Upgrade Source Image to that certified PeopleTools release before beginning your upgrade.

 

To find if you upgrade is certified on the later PeopleTools release, locate the Upgrade Home Page for the upgrade desired, then the sub-section Upgrade Certification Path.

 

Can't find anything on MyOracle Support

 

A good place to start is the document Upgrading PeopleSoft? Start Here. (Doc ID 1587686.2), a tabbed document that contains links to all things Upgrade.  To locate the upgrade source images page from this document, navigate to tab PeopleSoft Upgrade >  General PeopleSoft Upgrade Resources,  section PeopleSoft Update Manager.   

 

To find your upgrade's Upgrade Home Page, start from Doc ID 1587686.2, then navigate to your application or PeopleTools > Upgrade Resources, section Upgrade Home Pages.

 

Have a question, want to be sure

 

Visit the Lifecycle Management PSFT Community.   We are glad to field your upgrade questions.

Welcome to the My Oracle Support Community! We highly encourage you to personalize your community display name to make your activity more memorable. Please see https://community.oracle.com/docs/DOC-1022508 for instructions.