Skip navigation

Mohit Jain Create Express Expense Report 

 

Express Expense Report enables you to import all unassigned My Wallet transactions available for the employee into an expense report without requiring the user to do it manually. This feature was released in FSCM 9.2 Image 13.  

 

It introduces the ability to create Expense Reports having their lines pre-populated with unassigned My Wallet entries for the employee associated to the report.   In other words, when the page opens up, expense lines are displayed already filled up with the available My Wallet transactions for that particular employee without requiring the user to do it manually.

 

Navigation for this feature

  • Employee Self-Service > Travel and Expenses > Expense Reports > Create Express
  • Travel and Expenses > Express Expense Report  > Create Express

 

For more detailed information on this feature, please read the following PeopleBooks Chapter: Creating Express Expense Reports

 

  201510_EX_EXPRESS.png

Emil Dragan Billing InterUnit/BIGNAP01 Accounting 

 

Below in Case A, B and C several pages are referenced – putting their navigation here:

 

  • Set Up Financials/Supply Chain > Install > Installation Options > Overall page;
  • Set Up Financials/Supply Chain > Business Unit Related > General Ledger > General Ledger Definition, the Inter/Intra Unit tab;
  • Suppliers > Supplier Information > Add/Update > Supplier for the supplier used on the GL Definition page, the Identifying Information tab;
  • Customers > Customer Information > General Information for the used Customer in the transaction, the Bill To Options tab;
  • Set Up Financials/Supply Chain > Common Definitions > Inter/IntraUnit > System Transaction Map, the Transaction Options page for the BIIVC transaction;
  • Set Up Financials/Supply Chain > Common Definitions > Inter/Intra Unit > InterUnit Template page for the BIIVC transaction code.


Case A:

  • Installation Options page – the Use Legal Entity for InterUnit checkbox is selected;
  • General Ledger Definitions between the Units share the same Legal Entity Unit;
  • The InterEntity and IntraEntity entries on the InterUnit Template page will become Active, which InterUnit ones will become Inactive;
  • The system will use the IntraEntity accounts setted-up on the InterUnit Template page ( IntraEntity Receivable for the AR Offset account, IntraEntity Revenue for the Revenue account, IntraEntity Expense for the Exp/Inv account and assign the “AP will generate Voucher, distribution is defined in AP” option on the InterUnit Payables );
  • The PS_BI_ACCT_ENTRY record will be populated with the Receivables and Revenue accounts;
  • The PS_PENDING_DST record will be populated with the Receivables account;
  • The PS_VCHR_DIST_STG record will be populated with the Payables account from the IU Template page.


Case B:

  • Installation Options page – the Use Legal Entity for InterUnit checkbox is selected;
  • General Ledger Definitions between the Units DO NOT share the same Legal Entity Unit;
  • The InterEntity and IntraEntity entries on the InterUnit Template page will become Active, while InterUnit ones will become Inactive;
  • In this case, the system will use the InterEntity entries from the InterUnit Template page instead of the IntraEntity ones;
  • All the other details will remain as above.


Case C: 

  • Installation Options page – the Use Legal Entity for InterUnit checkbox is DESELECTED;
  • The InterEntity and IntraEntity entries on the InterUnit Template page will become Inactive, while InterUnit ones will become Active – the exact opposite from the above 2 scenarios;
  • The system will use the InterUnit accounts, just as in the above scenarios with the same comment that the InterUnit accounts will be used, neither InterEntity, nor IntraEntity ones.


One other comment: 

Assuming that Installation is set to Use Legal Entity, both Units share the same Legal Entity, therefore the system will use the IntraEntity accounts, BUT on the System Transaction Map, the Transactions Options page for the BIIVC process, the “Generate AP Voucher” is not checked, then when adding the Billing invoice, on the InterUnit Payables page, the system will not assign the “AP will generate Voucher, distribution is defined in AP” option, but it will retrieve the IntraEntity Payables account found on the InterUnit Template page. One further note – if the Generate AP Voucher is un-checked, the system will not process anything within BIGNAP01, therefore noting will be written in PS_VCHR_HDR_STG, PS_VCHR_LINE_STG or PS_VCHR_DIST_STG.

Raul Cocias Asset Management Project Costing Integration

 

A key component in managing the capitalization of a self-constructed asset is properly measuring the costs of creating the asset. 

Asset Management integrates with PeopleSoft Project Costing by sharing information about assets associated with ongoing projects. Assets that originate in Project Costing are typically the result of construction projects. They can accumulate cost information associated with salvage and removal costs, proceeds for a sale, and so on.

 

201510_AM PC Integration.png

After you transfer data from Project Costing, you can preview asset information in the loader tables before running Transaction Loader.

Costing fields :

  • Project Costing Business Unit business_unit_pc
  • Project ID project_id
  • Activity ID activity_id
  • Source Type resource_type
  • Category resource_category
  • Subcategory resource_sub_cat
  • Analysis type analysis_type

Main bundles that have impacted/added 9.1 projects chartfields are : B#s 9, 16, 18, 26

Raul Cocias [AM] Benefits of What If Depreciation Functionality  

 

PeopleSoft Asset Management provides you with the ability to perform what if depreciation simulation modeling and to load the net book value results into a spreadsheet program for analysis  

 

Another useful benefit of the What If Depreciation feature is to project the depreciation if you add an asset and run the actual depreciation program. For example, you can create an asset and run the What If Depreciation program rather than running the actual depreciation program. You can then see what the depreciation amount for the asset would be, go back and modify the depreciation parameters accordingly, and then perform the actual depreciation.

 

The What If Depreciation page uses the AM_DEPR_COMP application engine program to run simulated depreciation instead of the actual depreciation program (AM_DEPR_CALC).Path: Asset Management, Depreciation, What If Scenarios, Request, What If Depreciation

Mohit Jain          RSS Feed Using PS Query 

 

RSS (Rich Site Summary) feeds which are commonly used to publish frequently updated information removes the need for the user to manually check the website for new content. Feeds provide rapidly changing content available to users. These Web feeds are also available in PeopleSoft and are configured via PeopleTools Feed Publishing Framework. RSS Feeds Using PS Query can be useful in scenarios where business administrators review Query Data by logging into the system and running the query. PeopleSoft applications offer feeds in Atom 1.0 format only.

 

The Feed Publishing Framework provides a simplified guide for content owners and administrative users to create, configure, and maintain feed definitions and feed templates of various types. You Integration Broker should be properly configured and running for using feeds.

We created a PS Query which fetched details of all the Expense Reports that are in pending status. For our use case, we used this query to publish feed which can be used by BU Expense Admin to monitor the Expense Reports.

 

For details on this use case setup, please refer the attached document.

 

PS Query feeds can be published in two ways:

 

     1.    Publishing Using the Publish as Feed Pages-

            Navigation - Reporting Tools > Query > Query Manager, Select the query that you want to publish as a feed and click the Edit link.

     2.    Publishing Using the Feed Publishing Wizard-

            Navigation - PeopleTools, Feeds, Feed Publishing Wizard

 

Published feeds can be directly subscribed using tools like MS Outlook.

For more detailed information on this feature, please read the following PeopleBooks Chapter: Feed Publishing Framework Overview and Understanding Query Feeds.  

Mohit Jain CI Based Web Service 

 

Integration of PeopleSoft based systems with tools/legacy systems has always been an industry need. CI Based Web Service enables developers to provide an interface to expose the existing PeopleSoft System’s capabilities to third party systems without compromising on the security implemented in the Business Layer.

 

PeopleSoft Integration Broker enables you to take an existing component interface and create a service that can be used to invoke the component interface. Further, it creates service operations, including request messages and response messages (if appropriate). The system creates an inbound any-to-local routing for the service operation version, as well as handlers for each method you choose to include in the service. All service operations you generate from component interfaces are synchronous service operations.

 

We tested this by creating a CI for the Expense Report Entry component and then utilizing it for creating a Web Service that can search for existing Expense Reports. For details, please refer the attached document.

 

For creating Service Operation for Component Interface, use the following navigation:
•     PeopleTools > Integration Broker > Web Services > CI-Based Services
For generating Web Service from Service Operation, navigate as follows:
•    PeopleTools > Integration Broker > Web Services > Provide Web Service

 

For more detailed information on this feature, please read the following PeopleBooks Chapter: Understanding Creating Component Interface-Based Services

Raul Cocias Asset Management Methods of Recalculation 

 

How the system recalculates depreciation is in part dependent on the calculation type that you specify in the  Depreciation Attributes section of the Asset Book - Definition page.

The two methods of recalculation are:

  1. Remaining Value.
  2. Life-to-Date.

1. Remaining Value Calculation

AM_RECALC_01.png

2. Life-to-Date Calculation 

AM_RECALC_02.png

  • Original Cost+ Additional Cost =  New Cost
  • New cost delivered by number of periods to date =  What accumulated depreciation should have been
  • New accumulated depreciation – old accumulated depreciation = Adjustment to current period

 

Use the following examples to explain the difference between remaining value and life-to-date calculations: You purchased a piece of machinery 24 months ago: Cost 50,000,Life 60,Method Straight Line, Convention Actual Month, Depr/Period 833.33, Depreciation to date 20,000; NBV 30,000; At this point, remaining value /LtD does not matter. You increase the cost by 5,000 in Month 25 as an Adjustment.

 

Next, you need to recalculate depreciation. The recalculation method that you selected now applies:

Remaining Value
30,000 (RV) + 5,000 (adj) = 35,000/36 remaining months = 972.22/month for remaining months.


Life-to-Date
Two calculations required (Per FASB - if you change depreciation method - must recalculate LtD)

  • Depreciation for 50,000 (original) +5,000 (adj) = 916.67/mo for 60 months
  • Depreciation for 24 months = 22,000
  • Depreciation taken so far = 20,000
  • Difference to date: 2,000

The system will make the adjusting entry (PDP) in the current period and the new depreciation amount will continue for the remainder of the asset's life

Mohit Jain Tracing in PeopleSoft Applications


The FMS EX team's Mohit Jain has consolidated some of the most frequently used tracing methods that are used within PeopleSoft Applications, covering Application Engine , PeopleCode , Integration Broker , nVision , Cobol & SQR tracing.

 

Application Engine Trace

For Application Engine programs, Open the Process Definition under PeopleTools, Process Scheduler.  Go to the Override tab, and on the Parameter list line select Append from the dropdown, and in the edit box next to it, enter the desired combination of traces, they all are -

Parameter List    Append    -TRACE 7 -TOOLSTRACEPC 4044  -TOOLSTRACESQL 31

 

Save the Definition and this program will be traced each time it is run, until this is removed.  Using both the -TOOLSTRACEPC & -TOOLSTRACESQL together should only be done when required, as the output from both go into the same file, making it very large and difficult to read.  For normal program tracing use-

 

-TRACE 7 -TOOLSTRACEPC 4044

 

Give the Application Engine Trace, which traces the SQL in an Application Engine program, and the PeopleSoft Trace, which is the people code trace.

 

The above settings have equivalent settings in psprcs.cfg, they are-

 

TraceAE=    -TRACE  output goes into Application Engine Trace (.AET)

TracePC=    -TOOLSTRACEPC  output goes into the PeopleTools trace file (.trc)

TraceSQL=  -TOOLSTRACESQL output ALSO goes into the PeopleTools trace file (.trc)

 

With the AE traces done like this, every time any program that runs  on that process scheduler will be traced.  You need  to undo all of this setting back to None in Process Definitions will turn it off.

 

PeopleCode Online Trace

For tracing PeopleCode/SQL, debug values can be setup in the PIA while performing the transactions. You can use this before performing the actual transaction to ensure only useful trace information is fetched for analysis.  Open Trace PeopleCode/SQL under PeopleTools, Utilities, Debug.  When you want to take online trace for a transaction, follow these steps-

  a) Go to folder of the component or stop before doing a suspected transaction

    b) Open a new window and go to PeopleTools > Utilities > Debug > Trace PeopleCode

201509_PCodeTrace01.png

    c) Apply PC parameters, for ex. PC= 4044 (4+8+64+128+256+512+1024+2048) and save.

    d) Open one more new window, go to PeopleTools > Utilities > Debug > Trace SQL

201509_PCodeTrace02.png

    e) Apply SQL trace parameters, for ex. SQL = 7 (1+2+4)

    f) Go back to the transaction/launch the component and perform your desired action.

    g) As soon as you get the error press ok and signout.

    h) Pull the trace file from appserver logs and attach it to the SR.

The generated trace files can be located under PS_HOME/appserv/<DBNAME>/Logs/ directory of the application with a file extension of tracesql.

 

SQR Trace

SQR Report traces are a bit different than the Application Engine traces, Cobol traces, and online traces.

You can enable tracing for any particular Application Engine process or Cobol process, or trace any online user action. Development doesn't have to do anything specific when creating that Application Engine process, or Cobol process, or wrote the PeopleCode for a particular functionality.

This is not the case with SQR Reports. A SQR Report must have been explicitly written by the developers to include trace code. If the SQR Report does not have trace code, no information will be provided in the trace file.

1. Search for the file of the SQR you want to trace in your ‘%PS_HOME%\sqr’ directory.

2. Open the copy of the SQR file with a text editor such as Notepad.

3. Search for the keyword 'debug' or 'DEBUG' from top to bottom and write down the letters (the case is important) that are after the word 'debug' or 'DEBUG' (in the example below, there are a 'DEBUGA and a' 'DEBUGB' a so write down A and B). Again, this is not available in all SQR Report. The SQR Report must have been explicitly written by the developers to include trace code. If the SQR Report does not have trace code, the ‘–debug’ flag will not provide any tracing information.

201509_SQRTrace01.png

4. Sign in the PIA.

5. Navigate to the ‘Processes’ component and select the SQR Report that you would like to get a trace on. Be careful because there’s also a Process Type called ‘SQR Process’. What you need is the ‘SQR Report’ Process Type.

6. Go to the ‘Override Options’ tab, set the ‘Parameter List’ option to ‘Append’, add the SQR flags in the text box, and save.  -debugXYZ -S

201509_SQRTrace02.png

    • XYZ should be replaced by the letters you found at step 3. (the letter case is important).

    • Each SQR flag is separated by a blank space.

    • -S shows SQL cursors.

    The letter F is often used for program flows, D for data, and T for timing information. Other letters such A or B are used for additional information.

7. Go ahead and run the SQR that you would like to get a trace on. Get the trace file in the ‘Process Requests’ component, click on the ‘Details’ hyperlink for your Process Instance.

8. Do not forget to turn tracing off by setting the ‘Parameter List’ option to ‘None’ in the ‘Process Definitions’ component – ‘Override Options’ tab and saving.

 

Integration Broker - Subscription Trace

 

This type of trace is used in conjunction with PC and SQL trace to debug the handlers written for service operation. This may require help of your technical team as there are few code lines that need to be added to the handler App Package.  Code lines marked in red are added to the method of the Application Class for setting up trace values.

201509_IBTrace01.png

The generated trace files can be located under PS_HOME/appserv/<DBNAME>/Logs/ directory of the application.

 

Note :  At the end of trace generation, turn off the App Package trace setting (by removing the 4 lines Marked in Red.)

 

COBOL Trace


1) If the COBOL process is going to be run on a Windows scheduler:

    a) Open the appropriate  Process Type Definition, for example;

 

          Process Type: COBOL SQL

          Operating System: Windows

          Database Type: Oracle

 

    b) Copy the whole parameter list line into your clipboard.

          %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    c) Open the Process Definition for the particular COBOL Process that needs to be traced e.g PTPDBTST, go to the Override Options Tab, and on the Parameter List line, select          Override from the drop down.

    d) In the Parameters edit box, paste the whole parameter list from the Process Type Definition retrieved earlier.

          %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    e) Notice at the end of the line after the %%INSTANCE%% and before the %%DBFLAGS%% there are 2 forward slashes //

        Insert the desired bit map number inbetween the slashes.  Choose the bitmap number desired ( e.g 255 ) for the trace, and put it between the slashes per the following.

        %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%/255/%%DBFLAG%%

    f) Save the Process Definition. Launch the COBOL program through a PSNT scheduler.

    g) Navigate to the Process Monitor, Details, Parameter List, and you should see the expanded command line with the trace value inserted.

          Command Line:

          C:\BLD\G\H910\ORA\H910GXBU\CBLBINU\PTPDBTST.EXE ORACLE/H910GXBU/PS/OPRPSWD/1/5057/255/0

          Working Dir:

          C:\apps\db\ora\64bit\BIN

 

2) If the COBOL process is going to be run on a UNIX/Linux scheduler:

    a) Open the appropriate Process Type Definition, for example;

 

          Process Type: COBOL SQL

          Operating System: Unix

          Database Type: Oracle

 

    b) Copy the whole parameter list line into your clipboard.

          %%PRCSNAME%% %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    c) Open the Process Definition for the particular COBOL Process that needs to be traced e.g PTPDBTST, go to the Override Options Tab, and on the Parameter List line, select          Override from the drop down.

    d) In the Parameters edit box, paste the whole parameter list from the Process Type Definition retrieved earlier.

          %%PRCSNAME%% %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%//%%DBFLAG%%

    e) Notice at the end of the line after the %%INSTANCE%% and before the %%DBFLAGS%% there are 2 forward slashes //

          Insert the desired bit map number inbetween the slashes.  Choose the bitmap number desired ( e.g 255 ) for the trace, and put it between the slashes per the following.

          %%PRCSNAME%% %%DBTYPE%%/%%DBNAME%%/%%OPRID%%/%%OPRPSWD%%/%%RUNCNTLID%%/%%INSTANCE%%/255/%%DBFLAG%%

    f) Save the Process Definition. Launch the COBOL program through a PSUNX scheduler.

    g) Navigate to the Process Monitor, Details, Parameter List, and you should see the expanded command line with the trace value inserted.

          Command Line:

          PSRUN PTPDBTST ORACLE/E91DMO/VP1/%OPRPSWD%/1/475/255/%DBFLAG%

          Every time the program runs, it will be traced.

 

PS/nVision Trace

 

By default, PS/nVision does not generate trace files because extensive tracing can affect system performance. You can enable tracing and determine the tracing level when you need debugging. You configure PS/nVision tracing on the web using the Trace Level setting in the PeopleSoft Process Scheduler configuration file's nVision section. The default value is 0.

 

PS/nVision supports five tracing levels: 0, 1, 2, 3, and 4. The following table shows the level of tracing for each value.

201509_NVisionTrace01Y.png

Viewing the Trace Files for PS/nVision on Windows-

In Microsoft Windows PS/nVision, the trace file is generated in your system temporary directory; for example c:\temp\psnvs_123.nvt.

 

Viewing the Trace Files on the Web-

On the web, because PeopleSoft Process Scheduler initiates all PS/nVision processes, it is also responsible for displaying PS/nVision trace information in the Process Monitor after PS/nVision reports are run to completion. The PS/nVision trace files are independent of the Process Scheduler's status of the report running, and are always posted regardless of your output types or formats. Trace files are secured by the same user list as the report, so only the same set of users can view them.

PS/nVision trace files are automatically purged when the reports are purged in the time frame that you have set from the Process Scheduler System Purge Option. You can view trace files from the View Trace/Log page in Process Monitor for your completed process instance.

To view a trace file:

1. Select select PeopleTools, then select Process Scheduler, then select Process Monitor.

2. Find the process instance that runs your nVision report, and then click the Details link to access the Process Details page.

3. Click the View/Trace Log link to access the Message Log page.

4. Click the nVision Trace link to view the trace file.

If Process Scheduler has restarted your nVision report running process, this procedure generates multiple nVision trace files (one for each retry).

PeopleTools Service Operation Tester 

 

Mohit Jain [FMS EX Team]

 

Service Operations and similar IB related objects used for integration need to be tested carefully before deployment as they are real time interfaces for data communication. Creating service operations and their stable deployment is one such big task that is achieved via several rounds of testing for configuration and message triggering.

 

The Service Operation Tester utility enables you test service operations and invoke the following service operation types using the utility:

  • Asynchronous One-Way.
  • Asynchronous Request/Response.
  • Asynchronous-to-Synchronous.
  • Synchronous.

 

You can use the utility to populate messages contained within a service operation.

 

We can simulate an inbound message and test the subscription of that message using the Service Operation Tester. So instead of integrating two environments to test a message and its setup, you can use the Service Operation Tester to test the integration.

 

We performed a simple test for a service operation to test this utility. For steps please refer the attached document. I've also attached a sample XML which I used for testing this utility for COUNTRY_SYNC service operation. 

 

This utility can be setup at the following navigation:
• PeopleTools > Integration Broker > Service Utilities > Service Operation Tester.

 

For more detailed information please read this PeopleBooks Chapter: Understanding the Service Operation Tester Utility

 

Similarly, PeopleTools have various other utilities for testing IB related objects. Handler Tester, Schema Tester, Transformation Test etc. are some of the examples. Please post your comments on this EX Community Thread if you are need more information on any of these utilities.

PeopleTools Introspection and Deployment Utility 

 

Mohit Jain [FMS EX Team]


  • Service Operations not configured properly?
  • Remote Node Objects not setup?
  • Routing doesn’t exist?

 

And many more such scenarios where it is a time taking task to verify the configuration on your local system and this becomes more compound when dealing with Integration Network which involves a remote PeopleSoft Node. PeopleTools has delivered a very handy and easy to use Introspection and Deployment Utility which can be used for checking basic IB configuration on your PeopleSoft systems.

 

This utility has a step by step select procedure and is very easy to use. The entire basic configuration can be checked and verified at a single place.

Using this you can verify whether:

  • Service operation is active
  • Routing exists
  • Handler exists
  • Service operation permissions exist
  • Alias names match
  • Sending and receiving nodes match
  • No multiple target aliases exist (Synchronous service operations only)

 

We performed a test on how to use this functionality. For details, refer the attached screenshot document.

 

This utility can be found at the following navigation:

  • PeopleTools > Integration Broker > Integration Network WorkCenter >  Administration >  Introspection and Deployment or at
  • PeopleTools > Integration Broker > Integration Network > Introspection and Deployment

 

For more detailed information please read this PeopleBooks Chapter: Introspecting and Deploying Network Integrations  

Simple Post Utility - Integrating with Third Party Systems

 

Yash Watarkar [FMS EX Team]

 

The Simple Post utility enables you to post XML messages to PeopleSoft Systems from third-party systems using shell scripts or a Java API. The utility wraps the incoming messages in the PeopleSoft XML wrapper format and posts them to the HTTP listening connector.This then creates a Integration Broker ( IB ) message for the relevant Service Operation.

 

The utility helps you when you have one system (HCM/FSCM) using a Third Party software but want the information to be synchronized to a PeopleSoft system.

For ex. if you are managing you HR Data in a third party system but you are using PeopleSoft Financials and want the data to be synchronized, then you can write a java program which can convert you HR Data to PeopleSoft readable XML messages and use this utility to post the XML data to the PeopleSoft system. 

 

The utility is very helpful as you can create your own Java Programs based on the requirement or you can create a batch file which can be called to load the data as needed.

Pre-requisites to use this utility (basic IB setup):

 

  • Gateway is active
  • Service operation/queue is active
  • Routing exists
  • Handler exists
  • Sending and receiving nodes match

 

For more detailed information please read this PeopleBooks Chapter: Understanding the Simple Post Utility

 

We performed a test on how to use this functionality. For details, refer the attached screenshot document. Also attached is the sample XML to be used. The Java program template or sample command line script are specified in the PeopleBooks link mentioned above.

Asset Management Purchasing and Payables Integration

Raul Cocias


PeopleSoft Purchasing sends receipts to Asset Management as either capitalized or non-capitalized assets. If non-capitalized assets are created from PeopleSoft Purchasing, these assets can be capitalized when the voucher information is received from Payables. Asset Management automatically capitalizes assets created from Payables as long as the associated asset profile is enabled for capitalization.

 

Asset Management, Purchasing, and Payables Transaction Flow: This diagram shows the integration flow for creating transactions between Asset Management and PeopleSoft Purchasing/Payables.

 

29072015_v5 PO AP AM flow .png

 

PeopleSoft In-Memory Financial Close Analyzer

 

FCA PPT 01.png

PeopleSoft introduces In-Memory Financial Close Analyzer, delivered in FSCM 9.2.013 image in July 2015, a product that allows you to use the current production multi-currency and year end closing rules to model and compare multiple alternate closing scenarios. Select the most favorable scenario(s) to deploy in production. The impact of complex multi-currency and year end closing rules can be easily determined as the business need arises. Model complex scenarios and run multiple PeopleSoft processes, using your reporting tools and the Configurable Analysis Framework (CAF) to analyze the results at various intermediate checkpoints.

 

You can create multiple models of the full close with visibility into effects of business reorganizations, material activity, and simulate period end exchange rates that can impact the financial close position. The office of the CFO can simulate the financial close cycle in advance of the close, in order to make valuable and effective decisions on a timely basis.

 

PeopleSoft In-Memory Financial Close Analyzer is a robust solution that allows you to simulate period-end financial flow leading to a real-time view of your financial position with provisional statements. The process provides material activity projections all the way to period close.

  • You copy production rules and can modify them for allocations, multi-currency and period close to model various assumptions. This creates multiple scenarios from which to run iterations of the posting, allocation, multi-currency, and year-end close processes.
  • You then view scenario results in real-time to determine what your financial position would be if you were to close your books today. Results can be reviewed using financial reports that are familiar to you such as the trial balance and nVision reports.
  • If not satisfied with the results, you can modify processing rules for allocations, multi-currency, and closing and reprocess a scenario as many times as necessary until you are satisfied with your results. When this occurs, you can deploy the processing rule changes to your production system.

 

FCA PPT 02.png

SUMMARY

Business Drivers

  • Effect of foreign exchange rate fluctuations
  • Effect of implementation of acquisition or merger in current period on profitability & balance sheet
  • Effect of potential reorganization of businesses, regions, products, projects
  • Run full close to reduce period end financial surprises

Financial Simulation

  • Preview Financial Close
  • Iterative processing of close
  • Support for business decisions impacting the close

Simulations

  • Simulate new or changed Revaluation configuration
  • Simulate new or changed Translation configuration
  • Simulate new or changed Closing configuration
  • Simulate financial configuration (COA, BU, Trees)
  • Incremental update to Ledger
References
  • PeopleSoft General Ledger, In-Memory Real Time Bottom Line, and FSCM Application Fundamentals Documentation Update for Update Image 13 (FMS/ESA Update Image 13) (Doc ID 2019370.1)
  • PeopleSoft FSCM 9.2: Update Image Documentation (Doc ID 1923479.2)
  • PeopleSoft Financials/Supply Chain Management 9.2 In-Memory Real-Time Bottom Line Installation (through Update Image 13) Home Page (Doc ID 1607095.1)

Mohit Jain [FMS EX Team]

 

Alerts and Notifications via Email, Worklist etc., are common in PeopleSoft Systems. Automating Alerts for some custom actions/criteria has always been a need of Organizations. Some fabricate bolt on Processes, some achieve it via SQR’s and some even use Reporting Tools to accomplish this. PeopleSoft Enterprise Suite has delivered an Events and Notifications Framework that can be configured and automated for such highly desired functionality. The outputs can be in form of an Email Notifications, Worklist & Push Notifications and even XML Notifications to other systems.

 

There are three ways to use notifications:

  • Use pre-defined notifications
  • Define new notifications for a PeopleSoft process (Requires technical help of IT team)
  • Use PeopleSoft Query


We took up the following problem statement and setup notifications with the help of PS Query: Employees in an Organization who have unapplied Cash Advance (CA) pending in their queues are to be notified. They have to apply such CAs in their Expense Report to clear of the CA balance. A PS Query was created to pickup such transactions and using the Events and Notifications Framework Emails and Worklist reminders were sent. This utility can be setup at the following navigation:

  • Main Menu >> Enterprise Components >> Events & Notifications >> Notifications Framework >> Notifications Registry
  • Main Menu >> Enterprise Components >> Events & Notifications >> Alerts >> Alert Definition


The process to run the Alerts can be found at the following navigation:

  • Main Menu >> Enterprise Components >> Events & Notifications >> Alerts >> Run Alert
  • It is a Run Control page where the Query Options are given for Alert Generation. The process EOEN_ALERT picks up the inputs and performs the Alert action.

 

Information on how this use case was setup can be found in the screenshot document attached. Some of the additional features in this framework are -

  • The ability to override the setup at System and Business Unit levels.
  • Pre-Processing Exit: A preprocessing user exit tells the system to run another process before it determines who to notify.
  • Customizable Actions: Use this option if you have written your own application class for a customized action that can be taken when the alert condition is met.


  For more detailed information please read this PeopleBooks Chapter

Raul Cocias


[AM] How to Add Bonus Depreciation Retroactively for an Asset

 

Create asset with in service date / accounting date between 1.1.2012 si 31.12.2012  without applying bonus depreciation. Now I want to apply retroactively bonus of %50 which will delete the old depreciation from the depreciation table and create a new one : This is done launching process AMSEC101 with Run mode: Prepare For depreciation. It will perform a reset:

  • Delete depreciation table
  • Add Bonus percent 50, and bonus sw at 9 on book table
  • Calc type changed to L on book table
  • Update Open trans depreciation to P pending
  • -Update if needed, Begin depreciation date … etc.

 

Launch depreciation for asset to recreate depreciation according to bonus. You may also like to play a recording of the TTQ above.

Welcome to the My Oracle Support Community! We highly encourage you to personalize your community display name to make your activity more memorable. Please see https://community.oracle.com/docs/DOC-1022508 for instructions.