We'd love to hear from you! Provide  feedback  to earn a badge today. Take our quick survey
You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

BUI Extension Intermittently Refuses to Load

Accepted answer
13
Views
4
Comments
edited Sep 13, 2018 9:53PM in Agent Desktop 4 comments

Content

I have a real-world, multi-file BUI workspace extension that's not loading for me. In Chrome's developer tools, under the Application tab → Cache Storage → OSVC-Extension-Cache, all I see is my index.html file loading, and nothing else. If I click on the index.html file, all I see in the preview window is:

<script src="https://xyz.custhelp.com/AgentWeb/api/agentbrowserui/v.31809060018/module/extensibility/js/client/core/extension_loader.js?v=31809060018"></script&gt;

Which is an automatically-injected line. I see zero lines of index.html. There are no errors showing in the dev tools console, and nothing looks particularly useful in the verbose section either. I've seen this a few different times, but I have no idea what causes it and it brings work to a screeching halt. The permissions all check out, the workspace is properly configured, I've done all the troubleshooting I can think of. What's more, it was working fine a few hours ago.

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!