Register today for Oracle CloudWorld. October 17th - 20th, Las Vegas

Register now

Hillel Cooperman, Senior VP of User Experience Design, has a message for you on Oracle CloudWorld

Watch now
Issue with Authenticating OCI REST API calls. — Cloud Customer Connect
You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Issue with Authenticating OCI REST API calls.

Received Response
11
Views
2
Comments
edited Aug 17, 2022 8:00PM in API Management 2 comments

Summary:

We're using PHP to call the Oracle cloud REST APIs for some DNS configuration. However, the code we are trying to use is only getting back 401 Authentication Errors.

Content (required):

What we know so far:

  1. Direct CLI works. So, the user config information we are trying to reuse in code is correct.
  2. Also tried creating new keypairs and using them in code to sign the request.
  3. System clock is only varying by approx 1 min, so that isn't the problem.

Have also tried a bunch of changes within the code like lowercase signing url, url encoding it, without host in it, trying single quote '\n' etc. All of them are returning a 401. I'm sure it's something simple that's missing here, so any help from experts here would be awesome!

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!