You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Things needs to be considered for TLS 1.0 upgrade for programs using SOAP via Java

Received Response
8
Views
3
Comments
edited Oct 11, 2016 1:48PM in Integrations and APIs 3 comments

Content

Our integration is written using java (version "1.7.0_79") and hosted on RHEL(Red hat enterprise linux) machine(Distributor ID: OracleServer, Release:6.7). I assume by default java 1.7 version will support TLS 1.1 and TLS 1.2 ,but when i run the log analyse i am getting failure in SOAP api calls. Could you please help us in conveying what needs done from java code side or in RHEL?

Tried below things:-
--------------------
1) Added -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 in the cron program scheduled in linux machine 
eg) * * * * * java -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 -jar /MyProgram.java
Result - again log analyser shows TLS v1.0 Traffic found 

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!