Running older versions of javaws

Version 1

    Some systems I have worked on (Dell KVMs) use a jnlp file that works in java 1.6.0 but not in java 1.8.0. In windows I installed java 1.6.0 and copied all the files from C:\Program Files\java\jre1.6.0_45 to my C drive then uninstalled version 6. Then I reinstalled java version 8.

    I created a script that sets the PATH variable to point to 1.6's java version and then calls javaws on the older version and this works good for the jnlp files under windows. I'm trying to do the same under linux but am running into an issue that the version of java being run depends on what is in the users ~/.java environment. I would like to change this with variables or maybe a re-homed approach does anyone have an idea of what I can pass to javaws to re-home it or to get it to use a specific version of java?


    In windows I used


    rem javaws.bat wrapper file to user version 1.6

    set "Path=c:\java1.6.0_45\bin;%PATH%

    c:\java1.6.0_45\bin\javaws.exe %1


    and that works for me in windows


    In linux I tried


    #!/bin/bash

    # ~/javaws wrapper file to use version 1.6

    export PATH=/usr/java/jre1.6.0_45/bin:${PATH}

    /usr/java/jre1.6.0_45/bin/javaws -verbose  $@


    but see that it is using version 1.8 of java

    I moved ~/.java out of the way like so

    mv ~/.java ~/.v8.java

    and then the script worked however I have some other applications namely cisco's ASDM that need the security settings I had set in the ~/.java directory

    It would be nice to use them at the same time.