5 Replies Latest reply: Nov 15, 2012 7:09 AM by ancientDX RSS

    ASM Lib rpms

    866787
      Hi gurus,

      I am trying store database in ASM Lib. for this trying to install grid infrastructure 11gr2 on 32 bit oel 5.5 kernel version is 2.6.18-194.el5.

      Now trying to install oracle asm lib rpms. the rpms trying to install are

      oracleasm-2.6.18-194.el5-2.0.5-1.el5.i686
      oracleasm-2.6.18-194.el5debug-2.0.5-1.el5.i686
      oracleasm-2.6.18-194.el5-debuginfo-2.0.5-1.el5.i686
      oracleasm-2.6.18-194.el5PAE-2.0.5-1.el5.i686
      oracleasm-2.6.18-194.el5PAE-2.0.5-1.el5.i686

      among all these oracleasm-2.6.18-194.el5-debuginfo-2.0.5-1.el5.i686 rpm only installed. others are not installing.

      giving error: faild dependies oracleasm support => 2.0.0 is needed by oracleasm

      now tried to download this rpm but i didn't from any where.

      please helpme to overcome this issue.

      Thanks a lot...
        • 1. Re: ASM Lib rpms
          Azar
          from here ,you can get it

          If you want to download Oracleasm support driver, you can see on top of the box which you're chooses kernel version "Library and Tools"

          http://www.oracle.com/technetwork/server-storage/linux/downloads/rhel5-084877.html
          • 2. Re: ASM Lib rpms
            866787
            yeah there only i searched for rpms.

            can please help me which rpm has to download and install for oel 5.5 version. for i3 intel processor. kernel version is 2.6.18-194.el5
            • 3. Re: ASM Lib rpms
              Azar
              Intel IA32 (x86) Architecture subcategory...
              • 4. Re: ASM Lib rpms
                892953
                The best way for you to find out is using the Installer. Once you launch the GUI, the Oracle Installer will fail on the packages. You can take those packages and do a yum install rpmname.rpm (Which automatically downloads all the packages online).
                Also you can look at the oracle Documentation for your exact platform.

                Thanks,
                Ab Syed
                • 5. Re: ASM Lib rpms
                  ancientDX
                  Although this VM is a Centos build I configured earlier for Oracle, I never put the ASM libraries needed on, just the database required rpm’s. So to use ASM 11g and the raw disks, install ASMLib from ASMLib. Pick the right versions based on your kernel. As I am running 2.6.18-194.3.1.el5 I installed:



                  oracleasm-support-2.1.3-1.el5.i386.rpm
                  oracleasmlib-2.0.4-1.el5.i386.rpm
                  oracleasm-2.6.18-194.3.1.el5-2.0.5-1.el5.i686.rpm
                  oracleasm-2.6.18-194.3.1.el5-debuginfo-2.0.5-1.el5.i686.rpm
                  oracleasm-2.6.18-194.3.1.el5PAE-2.0.5-1.el5.i686.rpm
                  oracleasm-2.6.18-194.3.1.el5debug-2.0.5-1.el5.i686.rpm
                  oracleasm-2.6.18-194.3.1.el5xen-2.0.5-1.el5.i686.rpm

                  I probably didn’t need the last one, but got a bit carried away! Also no oracle user or dba group so quickly:



                  Thanks,
                  haseeb