This discussion is archived
3 Replies Latest reply: Dec 6, 2011 2:36 AM by 903807 RSS

Size option for /dev/shm in fstab is being ignored in 6.1

903807 Newbie
Currently Being Moderated
Hello everybody, I met this strange behavior. I need to increase shm for larger memory target (dynamically re-sizing server memory) and I am able to achieve it only with manual remount.
Oracle docs recommends the usual way: to put shmfs /dev/shm tmpfs size=8g 0 0 to fstab. But such value is ignored and I always receive 50% of RAM. I have to init 1, remount with mount -t tmpfs shmfs -o size=8g /dev/shm and init 3 again. Why is it so?
  • 1. Re: Size option for /dev/shm in fstab is being ignored in 6.1
    Avi Miller Guru
    Currently Being Moderated
    900804 wrote:
    Hello everybody, I met this strange behavior. I need to increase shm for larger memory target (dynamically re-sizing server memory) and I am able to achieve it only with manual remount.
    This is a bug in Red Hat Enterprise Linux and Oracle Linux. You can fix it manually following the instructions here: https://www.redhat.com/archives/rhelv6-list/2011-February/msg00081.html
    Oracle docs recommends the usual way: to put shmfs /dev/shm tmpfs size=8g 0 0 to fstab. But such value is ignored and I always receive 50% of RAM. I have to init 1, remount with mount -t tmpfs shmfs -o size=8g /dev/shm and init 3 again. Why is it so?
    You do not need to change into single-user mode to change this. Just issue a remount command:
     # mount -o remount,size=8G /dev/shm 
    Note however that Oracle Database is not yet certified to run on Oracle Linux 6, so things like this are not part of the standard QA testing. You are better off running database on Oracle Linux 5 Update 7, which is a certified platform and doesn't have this problem.
  • 2. Re: Size option for /dev/shm in fstab is being ignored in 6.1
    Dude! Guru
    Currently Being Moderated
    The following should fix it:
    sudo cp /etc/rc.d/rc.sysinit /etc/rc.d/rc.sysinit.bck
    sudo sed -i 's/-f \/dev\/shm/\/dev\/shm/g' /etc/rc.d/rc.sysinit
    It simply removes the -f parameter when mounting /dev/shm in rc.sysinit. Then after a reboot /dev/shm should be sized according to /etc/fstab and you don't have to remount it.
  • 3. Re: Size option for /dev/shm in fstab is being ignored in 6.1
    903807 Newbie
    Currently Being Moderated
    Awesome, works like a charm, thank you, good people.:-)

    I know such setup is not certified but it's the lab and 6.1 is the point. That's why I came on forum and not to My support.
    I had to switch to single-user because shm was always in use.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points