12 Replies Latest reply: Jul 24, 2012 11:42 AM by 951446 RSS

    vktm time drift detected.

    jgarry
      11g production, I've been getting lots of "Time drift detected. Please check VKTM trace file for more details." in the alert file. Trace files have lots of:
      kstmchkdrift (kstmhighrestimecntkeeper:lowres): Time stalled at 1317984832
      kstmchkdrift (kstmhighrestimecntkeeper:lowres): Stall, backward drift ended at 1317984834 drift: 2
      kstmchkdrift (kstmhighrestimecntkeeper:lowres): Time stalled at 1317987868
      I've seen bug 9843304, which is for rac and has a fix in 11.2.0.2. Is that 10795 event appropriate for this issue on XE, or is there some windows or oracle setting I should be concerned about? Increasing memory from .5G to 2G and changing time synchronization from 'host' to 'domain' made no difference. I don't see this on my box. Both boxes are XP Pro 2002 SP3, but mine is my heavily used desktop and the one with the problem is a lightly used server (physically distant from me).
        • 1. Re: vktm time drift detected.
          clcarter
          Those trace messages can be turned off with a trace level setting, the fix is supposed to be in 11.2.0.2 but not enabled.

          Are you using time.windows.com for "internet time"? (Control panel/Date and time/Internet Time tab). Last time I looked that one was broken, since the 2005 DST updates. Really.

          And the weekly "internet time" update schedule was not very well thought out for Windows, IMHO. Try using the ntp.org servers, at least they work.
          • 2. Re: vktm time drift detected.
            jgarry
            clcarter wrote:
            Those trace messages can be turned off with a trace level setting, the fix is supposed to be in 11.2.0.2 but not enabled.
            Yeah, I saw that, I'm just wondering if anyone can clarify what is really happening. I also later saw some more things on MOS like "it is still happening in 11.2.0.2 with the event set," so I was hoping to elicit more info from someone with a non-XE that could maybe shed more light.

            >
            Are you using time.windows.com for "internet time"? (Control panel/Date and time/Internet Time tab). Last time I looked that one was broken, since the 2005 DST updates. Really.
            lol there is no Internet Time tab, I presume the admins have a site master clock of some sort, is there any magic words I should ask them? They're smart people, I don't know much about windows. I do communicate better with them if I have some clue about their terminology before I ask. Since I do have privileged access greater than my knowledge, I'm real careful not to work at cross-purposes administrivially.

            >
            And the weekly "internet time" update schedule was not very well thought out for Windows, IMHO. Try using the ntp.org servers, at least they work.
            I am innocent of all network topological knowledge. There's a whole team for that.
            • 3. Re: vktm time drift detected.
              clcarter
              lol there is no Internet Time tab
              Whoops, I only saw "XP", didn't see the "2002" bit. Sorry, was on a bit of a tangent since it kind of sounds like a timer or time sync error, something similar, thinking it might have something to do with NTP.

              Yeah, apparently the event just turns off the errors, or is supposed to. We've only got a small handful of 11.2.0.2 instances but that error is a new one to me, but we're not using any RDBMS hosts on windows at all, just *nix.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
              • 4. Re: vktm time drift detected.
                jgarry
                OK, well, I'll leave this open in case someone else has more info about vktm or also seen it, and give the event a try. This has the feel of a simple goof leaving some debug info on, but I'd rather be sure, since I and obviously many others don't see it elsewhere. Where's BAAG when you need them?
                • 5. Re: vktm time drift detected.
                  laurent
                  vktm is a new 11g process <bla bla>

                  Edited by: laurent on Dec 15, 2011 1:53 PM
                  • 6. Re: vktm time drift detected.
                    orafad
                    Was that post perhaps meant for another thread?

                    I'm sure XE does not exist for AIX platform.
                    • 7. Re: vktm time drift detected.
                      laurent
                      sorry, I thought it could relate to the same "vktm time drift detected" error, apologize for the confusion
                      • 8. Re: vktm time drift detected.
                        orafad
                        Maybe. But I don't see from your post that the same error occurred. If it did, please adjust your post, adding the left out info and clarification.
                        • 10. Re: vktm time drift detected.
                          jgarry
                          lol, I noticed it there before I noticed this comment here.

                          Edit: And I've only just found out it is actually a VM. Marking answered, assuming it has something to do with VM time drift.

                          Edited by: jgarry on Dec 15, 2011 11:38 AM
                          • 11. Re: vktm time drift detected.
                            Frederic Eveilleau
                            I encountred same problem on physical server with Oracle 11.2.0.3.
                            It's not a VM issue.
                            • 12. Re: vktm time drift detected.
                              951446
                              It is not just VMWare issue.
                              I encountered it on both physical machine (M4000, Solaris 10 U10, Oracle DB Ent. 11.2.0.3), and on T4 partitioned by OracleVM for SPARC 2.2 (Solaris 10 U10, Oracle DB 11.2.0.3)

                              On physical machine I had:

                              kstmchkdrift (kstmhighrestimecntkeeper:lowres): Stall, backward drift ended at 1340583976 drift: 1
                              kstmchkdrift (kstmhighrestimecntkeeper:lowres): Time stalled at 1340772250

                              In LDOM:
                              *** 2012-07-23 20:31:15.437
                              kstmchkdrift (kstmhighrestimecntkeeper:highres): Time jumped forward by (1341033)usec at (618783244703) whereas (1000000) is allowed

                              In addition to this, on T4, database startup time was around 4 minutes.


                              Both issues were solved by disabling AMM (automatic memory management) - I just added pga_aggregate_target and sga_target instead of memory_target. Database startup time improved to 15sec and no more time drift warnings.