This discussion is archived
0 Replies Latest reply: Dec 18, 2011 5:46 PM by 904993 RSS

startup error, weblogic.application.ModuleException

904993 Newbie
Currently Being Moderated
startup error, weblogic.application.ModuleException

I got a error when I startup my server. Here is the trace."workspace " is my application.
<Warning> <Deployer> <BEA-149004> <Failures were detected while initiating distribute task for application 'workspace'.>
<Warning> <Deployer> <BEA-149078> <Stack trace for message 149004
weblogic.application.ModuleException:
at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:295)
at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176)
at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:93)
at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:360)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
Truncated. see log file for complete stacktrace
java.lang.ClassCastException: com.ctc.wstx.stax.WstxInputFactory
at javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:136)
at weblogic.servlet.internal.WebAppHelper.addListenerElements(WebAppHelper.java:244)
at weblogic.servlet.internal.WebAppHelper$IOHelperImpl.parseXML(WebAppHelper.java:224)
at weblogic.descriptor.DescriptorCache.parseXML(DescriptorCache.java:324)
at weblogic.servlet.internal.WebAppHelper.registerTagLibListeners(WebAppHelper.java:174)
Truncated. see log file for complete stacktrace

Here is the weblogic.xml in my application.

<?xml version="1.0" encoding="UTF-8"?>
<weblogic-web-app xmlns="http://www.bea.com/ns/weblogic/90"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.bea.com/ns/weblogic/90 http://www.bea.com/ns/weblogic/90/weblogic-web-app.xsd">
<context-root>/workspace</context-root>
<container-descriptor>
<prefer-web-inf-classes>true</prefer-web-inf-classes>
</container-descriptor>
</weblogic-web-app>

I have two ways to deploy my application,using installer or deploying it manually.
Using installer is ok,but I deployed it by myself,the problem came up.That's odd
I need the weblogic.xml to resovle another problem.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points