This discussion is archived
2 Replies Latest reply: Dec 23, 2011 7:28 AM by 907090 RSS

Can't connect oci8 with my oracle 10g database

907090 Newbie
Currently Being Moderated
Hello, this topic isn't new, i've been tried a lots of way to get ride this machine, but that doesn't go well, i need some help.


this is what i do:


install an oracle-xe-universal-10-2-1.deb , sudo dpkg -i oracle-xe-universal-10-2-1.deb

the result throws me all ok.
after doing that i install oci8.

sudo pecl install oci8

when it ask me for the libraries i set :

/usr/lib/oracle/xe/app/oracle/product/10.2.0/server

and the outcome it's fine... all ok, then i set the oci8.so extension to php.ini , the i restart apache2 and look into a phpinfo() page if it loading my oci8
everythink it's ok

but when i try to connect my web system it fail.

this is the error on my /var/log/apache2/error.log

oci_connect(): OCIEnvNlsCreate() failed. There is something wrong with your
system - please check that ORACLE_HOME and LD_LIBRARY_PATH are set and point to
the right directories


can someone help me please???

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points