1 Reply Latest reply on Feb 21, 2012 10:34 AM by 918901

    Performance Issues with OpenSSO Apache Module

      I will apologize in advance as I am not the deep technical expert in this area. We are working with a client and trying to integrate their OpenSSO version 3.0 with our product which runs on Apache 2.2.17. The client does have the Apache module installed

      The use case is that when you go through the login page, it will authenticate against the client's servers and once authenticated, the SSO module will add a few headers to the request. Our app then intercepts those headers and logs you in.

      We are able to make that handshake but the problem is that every time a new Apache process starts up, there is a 7 second delay before it can start serving requests. The snippet from the log where this delay occurs is below

      +547 2011-12-18 12:13:59.500 Debug 4254:1ed9090 Agent Profile Service: parseAgentResponse() returning with status success.+
      +548 2011-12-18 12:13:59.500 Info 4254:1ed9090 all: fetchAndUpdateAgentConfigCache():Repository type property is set to local in agent profile, vendor-apache-opensso-agent.+
      +549 2011-12-18 12:14:04.418 Info 4257:1ed9090 all: dsame_check_access(): Locked initialization section.+

      We are seeing this 5 second delay consistently. The client has exhausted all of their OpenSSO knowledge, have no other in house applications using Apache, and have worked through their Oracle Support process with no progress.

      Oracle's recommendation right now is to put Oracle Web Server in place but we are hosting this application for the client and it is not in our standard architecture.

      Any help or ideas on where I can have the team look are greatly appreciated.
        • 1. Re: Performance Issues with OpenSSO Apache Module

          I believe we have exactly the same 7 second issue as your good self. We have tried upgrading everything that isn't nailed down to latest versions with no success (Apache, Apache policy ggent, Open SSO). Next we plan to try tweaking the SSO policy caching settings to see what that does if anything, but we have had this issue for yonks and it causes havoc with our load balancing keepalives, had to disable them :-(

          Have you had any joy?


          Andy :-)