9 Replies Latest reply: Jan 8, 2012 3:31 AM by muneer.ngha.ksa RSS

    R12 Database Cloning with error AC-00423 / RC-50014

    muneer.ngha.ksa
      Hi Friends.

      We have an R12.1.3 Application with 11gR2 database on a Sun Sparc solaris 10 machine.

      From production cold backups, we are trying to clone a new test instance. The cloning is failing while configuring Oracle Home in DB Tier.

      in the logs it shows:

      ####################################################################################


      instantiate file:

      source : /devnew/dbexec/fintestdb/11.2.0/appsutil/template/adcrdb.sh

      dest : /devnew/dbexec/fintestdb/11.2.0/appsutil/install/FINTEST_riysverp-004/adcrdb.sh

      backup : /devnew/dbexec/fintestdb/11.2.0/appsutil/install/FINTEST_riysverp-004/adcrdb.sh to /devnew/dbexec/fintestdb/11.2.0/appsutil/out/FINTEST_riysverp-004/01041024/adcrdb.sh

      setting permissions: 700

      setting ownership: devnewd:devnew



      **********



      AC-00423: Template file: /devnew/dbexec/fintestdb/11.2.0/appsutil/template/adcrdb.sh missing from file system.

      Raised by oracle.apps.ad.autoconfig.InstantiateProcess



      **********



      [AutoConfig Error Report]

      The following report lists errors AutoConfig encountered during each

      phase of its execution. Errors are grouped by directory and phase.

      The report format is:

      <filename> <phase> <return code where appropriate>



      [INSTANTIATE PHASE]

      AutoConfig could not successfully instantiate the following files:

      Directory: /devnew/dbexec/fintestdb/11.2.0/appsutil/install/FINTEST_riysverp-004

      adcrdb.sh INSTE8


      AutoConfig is exiting with status 1



      RC-50014: Fatal: Execution of AutoConfig was failed

      Raised by oracle.apps.ad.clone.ApplyDatabase





      StackTrace:

      java.lang.Exception: RC-50014: Fatal: Execution of AutoConfig was failed

      at oracle.apps.ad.clone.ApplyDatabase.checkAutoConfigErr(ApplyDatabase.java:3192)

      at oracle.apps.ad.clone.ApplyDatabase.runAutoConfig(ApplyDatabase.java:2985)

      at oracle.apps.ad.clone.ApplyDatabase.doConf(ApplyDatabase.java:522)

      at oracle.apps.ad.clone.ApplyDatabase.doApply(ApplyDatabase.java:473)

      at oracle.apps.ad.clone.ApplyDatabase.<init>(ApplyDatabase.java:366)

      at oracle.apps.ad.clone.ApplyDBTier.<init>(ApplyDBTier.java:110)

      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)

      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)

      at java.lang.reflect.Constructor.newInstance(Constructor.java:494)

      at oracle.apps.ad.clone.util.CloneProcessor.run(CloneProcessor.java:67)

      at java.lang.Thread.run(Thread.java:595)



      ############################################################################################


      As you can see in the log messages, it complains that the “adcrdb.sh” file is missing from the system.

      As per note 549872.1 this error could be resolved by copying the missing “adcrdb.sh” file from the source environment. However, we tried it and it’s not working for us. The copied file gets deleted somewhere during the cloning process and it again fails complaining that the “adcrdb.sh” file is missing

      Please help us in resolving this as its a bit urgent.

      Thanks.