6 Replies Latest reply: Aug 29, 2012 7:41 AM by user3528246 RSS

    PeopleTools 8.52 upgrade

    Honza
      Hello,

      I have upgraded my PeopleTools from 8.50 to 8.52.04 (FIN/SCM MP1 Demo) and just as the end of the Change Assistant job is approaching, a curious error popped up.

      I log on to the application and go for Process Scheduler and Define Request. Now in the search page, both the Search button and Add New tab don't appear to be working.
      An error occured on the page with the following:
      Object Expected
      REPORT_BOOKS.NVS_REPORT_REQUEST.GBL line 76
      'ptCommonObj' not defined.
      REPORT_BOOKS.NVS_REPORT_REQUEST.GBL line 155, character 1, code 0

      If I try any PeopleSoft page, the same thing happends, each time 'ptComminObj' not defined, except the object it expects is a different piece depending on the component ...

      Any comments and input is greatly appreciated!
      Thank you.
        • 1. Re: PeopleTools 8.52 upgrade
          Honza
          Small update,

          looking through the web server cache directory, there are only 2 files that contain this ptCommonObj reference:
          PT_CTXMENU_win0_1.js
          PT_CTXMENU_win0_1_NS.js
          (and of course duplicite entries ...)

          All other files have a simialr reference, ptCommonObj2.
          Since its only these two files, I thought it might be worth a shot editing them manually, where can I find the definitions which are used to generate these JavaScript files? Can someone please provide insight?
          • 2. Re: PeopleTools 8.52 upgrade
            Honza
            Solved by reinstalling Peopletools 8.52 and 8.52.04 update on the web server + redeploy.
            • 3. Re: PeopleTools 8.52 upgrade
              Tmolina-Oracle
              Hi,

              I had the same issue and the problem was that I hadn't applied properly the patch to go to 8.52.07.

              Edited by: user806435 on Apr 30, 2012 6:33 PM
              • 4. Re: PeopleTools 8.52 upgrade
                MarianinaBoss
                Where did you have the problem with the peopletools patch? On the application server?
                • 5. Re: PeopleTools 8.52 upgrade
                  MarianinaBoss
                  An update. We had a similar problem. In our case the message:
                  Message: 'ptCommonObj2' is undefined

                  Was popping up on the web page of the application after we thought we'd completed the upgrade. (Not from the change assistant)

                  The issue was that in the change assistant, when editing the name of the peopletools patch project, we used the wrong name. (PATCH851 vs PATCH852) . The upshot is that we had not loaded the peopletools patch into the database. This took a long time to find, and thank you to the previous poster who mentioned incorrectly applying the tools patch.

                  Why didn't we see a message when starting the application server? I don't know but because we didn't, we focused too long on the web server, which was not the problem. I hope this helps someone else!

                  Edited by: user12002059 on May 1, 2012 10:43 AM
                  • 6. Re: PeopleTools 8.52 upgrade
                    user3528246
                    Hello,
                    I am running into a similar issue on my copy of production.
                    I am upgrading from PT 8.49.30 to PT 8.52.09 and HCM 9.0 to HCM 9.1.

                    The demo db HCM 9.1 is already on PT 8.52.09 and I can login and use the application without any issues.

                    I upgraded my copy of production to PT 8.52.09. I am at the point where it asks to configure the app server and the process scheduler. I did that successfully. I also created a web server.
                    Whenever I try to view a page I get the error Message: 'ptCommonObj2' is undefined' I did redeploy the web server. But still getting the same error. I know the patch 8.52.09 has been installed properly on the application/web server because I can use the demo db ok.