This discussion is archived
5 Replies Latest reply: Jan 25, 2012 9:54 AM by 913199 RSS

Solaris 11 x86 installer hangs on boot

901330 Newbie
Currently Being Moderated
I've downloaded both sol-11-1111-live-x86.iso and sol-11-1111-text-x86.iso, they both launch grub successfully, but thereafter they hang almost instantly.

This is a photo of my monitor when the installer has died:
[http://dl.dropbox.com/u/5487392/IMAG0073.jpg]

I've installed ubunut and windows successfully on the machine, so the hardware should be ok.

Is there some way I can launch the installer in verbose mode or something to more accurately pinpoint what fails during the boot?
Any other suggestions that can get me closer to installing solaris are welcome as well.
  • 1. Re: Solaris 11 x86 installer hangs on boot
    902279 Newbie
    Currently Being Moderated
    I have the exact same problem.

    I am trying the install on HP proliant DL320 G5 server.
  • 2. Re: Solaris 11 x86 installer hangs on boot
    903751 Newbie
    Currently Being Moderated
    My Solaris 11 Installation also does not work. I get an APIC Error, because 1=4 or something like that.

    I just would have to start the Installation with APIC an ACPI disabled, but the old commands don't work anymore.

    What do I have to put in the command line at boot??? noacpi is not recognizes and the stuff for Solaris 10 also not.
  • 3. Re: Solaris 11 x86 installer hangs on boot
    913199 Newbie
    Currently Being Moderated
    I am getting this on a Dell SC440.

    I thought it might be my lowly E2160 CPU, but I've just put in an Intel Q6600 (Core 2 Quad 2.4 GHz) and it still happens.
    The server previously had Red Hat Linux 6 on it (actually I reinstalled it today to test it), but I booted from a DOS USB stick and used fdisk to remove all partitions, so that the 3x 80 GB SATA disks I have in there are all blank.
    When I boot it goes through the initial screen with dots printing across and then displays a text line "Solaris Release 5.11 Version snv_151a 64-bit" then a copyright line and then it hangs.

    I've tried both the live and text install media, with the same result.

    I have used the same Solaris media to install onto another machine (an AMD powered Dell C521), and it is fine.

    Any ideas/pointers?
  • 4. Re: Solaris 11 x86 installer hangs on boot
    913199 Newbie
    Currently Being Moderated
    Well, I got a newer release (1111), and also added in a "-v" to the boot command string.

    The machine lists a lot of items and hangs after it prints:

    pseudo-device: 11c10
  • 5. Re: Solaris 11 x86 installer hangs on boot
    913199 Newbie
    Currently Being Moderated
    And I somehow got it to install - I tunrned off the extra drives in the server (in the BIOS) and also turned on VT.
    It booted and looked like it had hung, but I pressed the off button on the front and it said it was powering off, but didn't, and completed the install.
    However, the OS is rather clunky: it doesn't recognize the (onboard) graphics card properly (Solaris 10 did), and it doesn't power off on shutdown, nor will it reboot.
    I'm starting to think that Solaris 11 may not be a general-purpose OS release...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points