2 Replies Latest reply: Feb 6, 2012 7:55 PM by ryan_21 RSS

    Add host back into OEM12c

    ryan_21
      I had an issue with my OMS12c host and had to reinstall.

      The good thing is all of my agents are still running but not of them are being discovered in the Hosts section.

      The agents showed up in the Auto Discovery Results after I stopped the agent and resecured it and started it again.

      How can I add the host back or do I need to uninstall the agent and reinstall it?

      Thanks !
        • 1. Re: Add host back into OEM12c
          Nilesh Agrawal-Oracle
          when you are doing re-install of 12c OMS and pointing your existing 12c agents to it, it is equivalent of re-pointing 12c agents to other 12c oms.

          we can not point 12c agent to different OMS then the one it was originally pointed to. this is documented in MoS note 1390717.1. you need to re-install your 12c agents
          • 2. Re: Add host back into OEM12c
            ryan_21
            I was actually able to reconnect all of my agents without doing a re-installation.

            I followed these steps and had no issues:
            1. Promote the host agent through the Non-Host Targets under the Auto Discovery Results
            2. Shutdown the agent (./emctl stop agent)
            3. Secure the agent (./emctl secure agent)
            4. Start the agent (./emctl start agent)
            5. Ping the OMS to make sure it is connected (./emctl pingOMS)
            6. Re-associate the agent (./emctl config agent addcentralagent)
            7. Check the Hosts target section and the host I was readding was now showing up with a pending status
            8. Go to the Agents setup screen, click on the agent
            9. Click on the drop down once in the Agent Status screen and click on Resyncronization
            10. After the job completed everything was fine, just promote the targets that are to be monitored

            Ryan