0 Replies Latest reply: Feb 13, 2012 4:13 AM by 690485 RSS

    Could not browse pages from IIS after re-installation of Oracle client

      Hi all,

      Unfortunately, I hit a issue today in the morning. I could not browse pages from IIS after I re-installed my oracle client on my machine. Below is the error massage from browser.

      Configuration Error
      Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

      Parser Error Message: Could not load file or assembly 'Oracle.Web, Version=, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified.

      Source Error:

      Line 174: <healthMonitoring>
      Line 175: <providers>
      Line 176: <add name="OracleWebEventProvider" type="Oracle.Web.Management.OracleWebEventProvider, Oracle.Web, Version=, Culture=neutral, PublicKeyToken=89b483f429c47342" connectionStringName="OraAspNetConString" buffer="true" bufferMode="OracleNotification" />
      Line 177: </providers>
      Line 178: </healthMonitoring>

      Source File: c:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Config\machine.config Line: 176

      Assembly Load Trace: The following information can be helpful to determine why the assembly 'Oracle.Web, Version=, Culture=neutral, PublicKeyToken=89b483f429c47342' could not be loaded.

      WRN: Assembly binding logging is turned OFF.
      To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
      Note: There is some performance penalty associated with assembly bind failure logging.
      To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


      When I comment a line for OracleWebEventProvider in health monitoring providers in machine.config, it works fine for me. But, Im wondering what went wrong during re-installation and how do I rectify this issue with out a temporary workaround.

      Please let me know your suggestions in this regards and thanks for the help in advance.