3 Replies Latest reply: Feb 13, 2012 1:20 PM by mdrake-Oracle RSS

    ORA-31000: Resource 'example_name.xsd' is not an XDB schema document

    jjmdb
      Morning,

      I'm running 11gr2 on OEL 5. I recently joined a project where a lot of work has already been done by a previous dba and xmldb is fairly new to me. I'm trying to register a new xml schema but keep getting the above error. The error is referencing a resource that I'm not even declaring in my statement. See statement below.

      BEGIN
      DBMS_XMLSCHEMA.registerSchema(
      SCHEMAURL => 'http://localhost/xsd/test/collection_test.xsd',
      SCHEMADOC => bfilename('XSD_TEST','collection_test.xsd'),
      CSID => nls_charset_id('AL32UTF8'));
      END;
      /

      I've used the FORCE=True option which has worked but then the error shows up again when trying to create a table. I queried the schema url and found that nothing was mapped to it so I deleted it as so:

      DBMS_XMLSCHEMA.DELETESCHEMA('http://localhost/xsd/test/collection_test.xsd', DBMS_XMLSCHEMA.DELETE_CASCADE_FORCE);

      This worked just fine. Problem now is, I'm still getting the same error when registering schema or creating a table. I thought maybe I could purge t he schema from the database now but I can't query the schema ID to do so. I feel I am stuck now. I've tried to look up solutions online for a day now to no avail. All help is GREATLY appreciated (and rewarded). Thanks!!