1 Reply Latest reply: Feb 18, 2012 2:16 PM by BryanWood RSS

    Cannot install Solaris 10 to M3000 SPARC via jumpstart - Network Installation failing @ bpgetfile

    918105
      Hi,
      I am facing an issue while doing jumpstart on M3000 Server. logs is given below;
      1000 Mbps full duplex Link up
      Timed out waiting for BOOTP/DHCP reply
      1000 Mbps full duplex Link up

      SunOS Release 5.10 Version Generic_141444-09 64-bit
      Copyright 1983-2009 Sun Microsystems, Inc. All rights reserved.
      Use is subject to license terms.
      strplumb: unable to get device info for /pci@0,600000/pci@0/pci@1/network@0
      strplumb: resolve_netdrv: 6
      Configuring devices.
      NOTICE: nxge0: xcvr addr:0x0d - link is up 1000 Mbps full duplex
      NOTICE: nxge0: xcvr addr:0x0d - link is up 1000 Mbps full duplex
      NOTICE: nxge1: xcvr addr:0x0c - link is down
      NOTICE: nxge2: xcvr addr:0x0b - link is down
      WARNING: get_netif_name: no driver bound to '/pci@0,600000/pci@0/pci@1/network@0:dhcp'

      WARNING: get_netif_name: no driver bound to '/pci@0,600000/pci@0/pci@1/network@0:dhcp'

      WARNING: get_netif_name: no driver bound to '/pci@0,600000/pci@0/pci@1/network@0:dhcp'

      WARNING: get_netif_name: no driver bound to '/pci@0,600000/pci@0/pci@1/network@0:dhcp'

      Using RPC Bootparams for network configuration information.
      Attempting to configure interface nxge3...
      NOTICE: nxge2: xcvr addr:0x0b - link is down
      NOTICE: nxge0: xcvr addr:0x0d - link is up 1000 Mbps full duplex
      NOTICE: nxge3: xcvr addr:0x0a - link is down
      NOTICE: nxge1: xcvr addr:0x0c - link is down
      Skipped interface nxge3
      Attempting to configure interface nxge2...
      Skipped interface nxge2
      Attempting to configure interface nxge1...
      Skipped interface nxge1
      Attempting to configure interface nxge0...
      Skipped interface nxge0
      ERROR: bpgetfile unable to access network
      /sbin/install-discovery: information: not found


      and cursor keep moving on #prompt.
      i am unable to understand what to do? can anyone help me to get rid of from this issue?

      i tried by typing exit here, its going ahead but for manual installation...! this is not a solution for me. I need to install the system by jumpstart!
      please let me know if there is any way to bypass or solve this below error,
      "ERROR: bpgetfile unable to access network
      /sbin/install-discovery: information: not found"

      Edited by: user13511709 on Feb 16, 2012 1:25 PM
        • 1. Re: Cannot install Solaris 10 to M3000 SPARC via jumpstart - Network Installation failing @ bpgetfile
          BryanWood
          The default netmask being used by the boot image does not match your classless network subnet mask.

          - Ensure your sysidcfg file lists the correct netmask

          - Add an explicit entry into the boot image netmasks file (replace the below example network and netmask with your values):
          root# cat <your_solaris_boot_image>/Tools/Boot/.tmp_proto/root/etc/inet/netmasks
          192.168.0.0   255.255.240.0
          - Edit the rcS script in your boot image to have the bootp client apply the netmask given in the netmasks above (which it will find at /etc/inet/netmasks):
          root# vi <your_solaris_boot_image>/Tools/Boot/sbin/rcS
            [..]
          
             195                  /sbin/ifconfig $i auto-revarp -trailers >/tmp/dev.$$ 2>&1
          
                                  /sbin/ifconfig $i netmask  + > /tmp/dev.$$  2>&1      ## <<-- add this line here
          
             196                  ipaddr=`/sbin/ifconfig $i |grep inet |awk '{print $2;}'`
             197                  if [ "X$ipaddr" != "X0.0.0.0" ] ; then
             198                          # The interface configured itself correctly
             199                          echo "Configured interface $i"
             200                          /sbin/ifconfig $i up
             201                  else
             202                          echo "Skipping interface $i"
             203                  fi
            [..]
          Running "netmask +" reassigns the netmask based on the default IP address class, or from /etc/inet/netmask if an explicit subnet mask was placed therein. Note that for Solaris 10, there may already be an entry in the file that performs this action. Be sure to review the file to ensure the proper netmask is given.

          - Add in an explicit entry in the jumpstart server's /etc/inet/netmasks file:
          root# cat /etc/inet/netmasks
           [..]
          192.168.0.0   255.255.240.0
           [..]
          If the error still occurs, run "ifconfig -a" and "netstat -rn" from the client's root prompt to triple check the netmask is what you expect, and what matches your jumpstart server. You can also manually re-run bpgetfile to reproduce the error interactively. First have a look at the rcS file again:
             215                  #
             216                  # Look for the root boot parameter;
             217                  # bpgetfile returns $1 = server name, $2 = server IP addr, $3 = path
             218                  #
             219                  set -- ""
             220                  set -- `/sbin/bpgetfile`                              <------
             221                  SERVER_IPADDR=$2
             222                  echo "/sbin/bpgetfile got $1 $2 $3"
             223                  if [ $2"x" != "x" ]; then
             224                          Rootfs=$1:$3
             225                          echo "${Rootfs} - / ${Roottype} - no ro" >> /etc/vfstab
             226                  else
             227                          echo "ERROR: bpgetfile unable to access network information"
             228                          exec /sbin/sh
             229                  fi
          so merely re-running "bpgetfile" should produce the output: $1 = server name, $2 = server IP addr, $3 = path. You can fix the netmask manually by hand, and confirm that bpgetfile indeed runs correctly afterward.