4 Replies Latest reply: Feb 21, 2012 4:40 AM by Udo RSS

    Database Configuration failed. - Fedora 15-64bit on ORACLE VM...

    Adam M
      I'm trying to get ORACLE 11g Express going on a Fedora VM and after running the configuration (/etc/init.d/oracle-xe configure
      ) I am getting the following error:

      *********************

      begin
      ***
      ERROR at line 1:
      ORA-01034: ORACLE not available
      Process ID: 0
      Session ID: 0 Serial number: 0



      File created.

      ORA-01034: ORACLE not available
      ORA-27101: shared memory realm does not exist
      Linux-x86_64 Error: 2: No such file or directory
      ORA-00119: invalid specification for system parameter LOCAL_LISTENER
      ORA-00130: invalid listener address '(ADDRESS=(PROTOCOL=TCP)(HOST=dvrfc.localdomain)(PORT=1521))'
      select 'utl_recomp_begin: ' || to_char(sysdate, 'HH:MI:SS') from dual
      ***
      ERROR at line 1:
      ORA-01034: ORACLE not available
      Process ID: 0
      Session ID: 0 Serial number: 0


      BEGIN utl_recomp.recomp_serial(); END;

      ***
      ERROR at line 1:
      ORA-01034: ORACLE not available
      Process ID: 0
      Session ID: 0 Serial number: 0


      select 'utl_recomp_end: ' || to_char(sysdate, 'HH:MI:SS') from dual
      ***
      ERROR at line 1:
      ORA-01034: ORACLE not available
      Process ID: 0
      Session ID: 0 Serial number: 0

      ****************

      I've manually edited both the listner.ora and tnsnames.ora to specifically point to an IP but yet it's still trying to use a FQDN, I'm a little confused at that...???

      *# listener.ora Network Configuration File:*

      SID_LIST_LISTENER =
      *(SID_LIST =*
      *(SID_DESC =*
      *(SID_NAME = PLSExtProc)*
      *(ORACLE_HOME = /u01/app/oracle/product/11.2.0/xe)*
      *(PROGRAM = extproc)*
      *)*
      *)*

      LISTENER =
      *(DESCRIPTION_LIST =*
      *(DESCRIPTION =*
      *(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE))*
      *(ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.3.202)(PORT = 1521))*
      *)*
      *)*

      DEFAULT_SERVICE_LISTENER = (XE)


      # tnsnames.ora Network Configuration File:

      XE =
      (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.3.202)(PORT = 1521))
      (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = XE)
      )
      )

      EXTPROC_CONNECTION_DATA =
      (DESCRIPTION =
      (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE))
      )
      (CONNECT_DATA =
      (SID = PLSExtProc)
      (PRESENTATION = RO)
      )
      )

      *********************



      This is on a fresh install on the VM so maybe I missed the obvious???

      Anyway, I'm pretty green with the ORACLE install and could use some help.
        • 1. Re: Database Configuration failed. - Fedora 15-64bit on ORACLE VM...
          NikolayIvankin
          login under oracle owner, set $ORACLE_SID, $ORACLE_HOME, run:
          sqlplus / as sysdba
          SQL>startup
          • 2. Re: Database Configuration failed. - Fedora 15-64bit on ORACLE VM...
            Udo
            Hello Adam,

            as you receive this error from "configure", the problem probably doesn't sit in the files you've edited, as they are supposed to be (re)created in that step.
            My guess would be you have some problem in your network setup. Probably your primary network interface has your FQDN assigned.
            You could try to modify your +/etc/hosts+ such that the first hit on your host isn't the FQDN but just the hostname. This value will be taken by the configure script, no matter what kind of value you've edited manually to the ora-files.
            Another option would be not to run "configure" again, but just start the database, either manually as Nikolay suggested, or using the init script
            /etc/init.d/oracle-xe start
            If you want to try the manual approach, the environment variables would be set as follows
            export ORACLE_SID=XE
            export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe
            Usually there is a script for that: +/u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh+ . But possibly this hasn't been generated on your system properly, as your "configure" didn't work as expected.

            So my recommendation would be to fix it from there, i.e., to fix the problems that block the success of "configure".

            -Udo
            • 3. Re: Database Configuration failed. - Fedora 15-64bit on ORACLE VM...
              Adam M
              Thanks for the prompt reply's.

              Well as usual I feel like an idiot..!

              The problem wasn't with the ORACLE script it was with the initial set up of the VM and the hostname that it was resolving to or that I originally used.

              Even though I was modifying the */etc/hostname* for the correct name I wasn't modifying the */etc/sysconfig/network* file and it still had the original name dvrfc.localdomain

              So, for anyone in the future who runs into a similar problem change the entry's in */etc/hosts* and */etc/sysconfig/network* to the correct hostname and this will correct the problem, then restart the network services.

              After which I was able to run the configure script and it finished successfully: */etc/init.d/oracle-xe configure*

              Adam,
              • 4. Re: Database Configuration failed. - Fedora 15-64bit on ORACLE VM...
                Udo
                Well as usual I feel like an idiot..!
                This probably happens to everyone of us now and then.
                What actually counts is that you've got your XE up and running.

                Have fun!
                [...]I wasn't modifying the /etc/sysconfig/network file
                Right, I forgot that the RedHat-derivates have that as well. My Ubuntu/Debian doesn't have this extra...


                -Udo

                P.S.: If you think any post was helpful, please mark it accordingly, so other users searching the forum for similar issues can spot relevant posts easily. Thanks!