This discussion is archived
2 Replies Latest reply: Feb 28, 2012 7:06 AM by sb92075 RSS

TNS:12535 while connecting a 10g database to 8i

tarunsh Newbie
Currently Being Moderated
HI,

I'm planning to create a db link in oracle 10.2.0 database (running on Linux) to an Oracle 8.1.7 database (running on Windows 2000 server).
Firewall is opened. I can ping successfully ping -p 1521 <windowsserver> from linux box.
But when I'm trying to do tnsping to the dataabse I'm getting TNS:12535 error.
The entry in tnsnames.ora is copied from another system where it is working successfully.
Any idea, what could be wrong and how to resolve the issue?

Thanks
Tarun
  • 1. Re: TNS:12535 while connecting a 10g database to 8i
    orafad Oracle ACE
    Currently Being Moderated
    12535 Operation timed out - could be an indication of server/listener trying to redirect the client to connect to a different remote port than listening one (1521) and fails because other ports are blocked/not open.

    To verify, if feasible, temporarily disable firewall and retry connection. Perhaps a better way to verify is to use sqlplus and netstat and look for new tcp connections to server host with different port and syn sent or similar status.

    For resolution, use search facilities and documentation available as this surely must be a Faq.

    Also, you've posted in wrong forum as topic clearly is nowhere near SQL or PL/SQL.

    Edited by: orafad on Feb 28, 2012 4:03 PM

    Edited by: orafad on Feb 28, 2012 4:05 PM

    Edited by: orafad on Feb 28, 2012 4:08 PM
  • 2. Re: TNS:12535 while connecting a 10g database to 8i
    sb92075 Guru
    Currently Being Moderated
    tarunsh wrote:
    HI,

    I'm planning to create a db link in oracle 10.2.0 database (running on Linux) to an Oracle 8.1.7 database (running on Windows 2000 server).
    Firewall is opened. I can ping successfully ping -p 1521 <windowsserver> from linux box.
    But when I'm trying to do tnsping to the dataabse I'm getting TNS:12535 error.
    The entry in tnsnames.ora is copied from another system where it is working successfully.
    Any idea, what could be wrong and how to resolve the issue?

    Thanks
    Tarun
    contrary to previously posted details, I STRONGLY suspect Firewall issue.

    does sqlnet.log file on V8 show the connection request got that far?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points