14 Replies Latest reply: Feb 29, 2012 12:48 AM by Nandinho RSS

    How to change default MTU size

    Nandinho
      Hi All

      I currently have a solaris 10 blade running on MTU= 1500, and I want to enable jumbo frames, so I want to change MTU to 8192 Bytes.

      so for now I have:

      ifconfig -a
      lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
      inet 127.0.0.1 netmask ff000000
      e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
      inet 10.100.48.73 netmask ffffff00 broadcast 10.100.48.255
      ether 0:c0:dd:1c:11:78

      I saw on a blog that I need to edit "/kernel/drv/e1000g.conf" this file and change the "MaxFrameSize" parameter and reboot, but did not work.
      Can you help?

      Nandinho
        • 1. Re: How to change default MTU size
          Nik
          Hi.

          Read http://docs.oracle.com/cd/E19248-01/819-7573-13/5_LP_driverparams.html

          You need change e1000g.conf and use ifconfig ( modify /etc/hostname.e1000g0 ) for realy set required MTU.

          Regards.
          • 2. Re: How to change default MTU size
            Nandinho
            Hi

            The file /etc/hostname.e1000g0 only contains the hostname on it. Do I have to add anything? I have already change the "MaxFrameSize" parameter in the file "/kernel/drv/e1000g.conf" to set the MTU to 8192 bytes, then rebooted, but mtu still 1500.

            regards
            • 3. Re: How to change default MTU size
              Nik
              Hi.


              For test:

              ifconfig e1000g0 mtu 8192
              ifconfig -a

              For make this changes permanent, edit /etc/hostname.e1000g0 :

              <hostname> mtu 8192 netmask + broadcast + up


              Regards.
              • 4. Re: How to change default MTU size
                Nandinho
                I have now follow your advice, but I do not access to the system anymore, but I can still ping it, and also login from another server on the same subnet,
                So to get to the original configuration I had to set mtu again to 1500, and reboot the system.


                regards
                • 5. Re: How to change default MTU size
                  Nik
                  Hi.
                  It's not good idia change network settings remotely.

                  You not tire what exactly you do.
                  Are you check network settings ( ifconfig -a ) before reboot ?

                  What reason to change MTU for this server ?
                  Do you have any other server with enabled Jumbo Frames ?

                  but I do not access to the system anymore, but I can still ping it
                  What protocol you use for connect to system ? ( ssh; telnet .... )



                  Regards.
                  • 6. Re: How to change default MTU size
                    Nandinho
                    Hi

                    The application vendor for this server and two other servers REQUIRE me to change the MTU to 8192.

                    the output of ifconfig -a before the reboot was:
                    ifconfig -a
                    lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
                    inet 127.0.0.1 netmask ff000000
                    e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
                    inet 10.100.48.73 netmask ffffff00 broadcast 10.100.48.255
                    ether 0:c0:dd:1c:11:78

                    I could not access the system frommy pc, but I logged in on another server in the same subnet, and managed to loggin into the server 73 using ssh. then to be able to acess the server again from my pc, I had to run the follwing on the server:

                    ifconfig e1000g0 10.100.48.73 mtu 1500

                    So everything went back to normal.


                    regards
                    • 7. Re: How to change default MTU size
                      Nik
                      Hi.
                      I read all you post.

                      All output that you show always:

                      e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
                      inet 10.100.48.73 netmask ffffff00 broadcast 10.100.48.255
                      ether 0:c0:dd:1c:11:78

                      But some times it work, some times not. Are you sure that you post true ?
                      • 8. Re: How to change default MTU size
                        Nandinho
                        I did copy and paste...

                        I will keep on investigating..

                        regards
                        • 9. Re: How to change default MTU size
                          Nik
                          Please, show what you change at e1000g.conf; what commands you do and result.
                          • 10. Re: How to change default MTU size
                            Nandinho
                            Hi


                            In the file "/kernel/drv/e1000g.conf", I have changed the second digit from 0 to 2 in the parameter "MaxFrameSize=0,2,0,0,0,0,0,0,0,0,0,0,0,0,0,0;"


                            regards
                            • 11. Re: How to change default MTU size
                              Nik
                              Hi.
                              Read https://blogs.oracle.com/taylor22/entry/configuring_jumbo_frames_on_the

                              Correct:

                              MaxFrameSize=2,2,2,2,0,0,0,0,0,0,0,0,0,0,0,0;


                              Regards
                              • 12. Re: How to change default MTU size
                                Nandinho
                                Hi !

                                Its now fine with your tip, but the MTU is not actually 8192, but 8106:

                                # ifconfig -a
                                lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
                                inet 127.0.0.1 netmask ff000000
                                e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 8106 index 2
                                inet 10.100.48.73 netmask ffffff00 broadcast 10.100.48.255
                                ether 0:c0:dd:1c:11:78
                                #



                                Is that fine?


                                regards
                                • 13. Re: How to change default MTU size
                                  Nik
                                  Please, read documentation.

                                  Link above or man e1000g

                                  ................
                                  MaxFrameSize

                                  Upper limit on the maximum MTU size the driver allows. All Intel gigabit adapters (except the 82542-based Intel PRO/1000 adapter) allow the configuration of jumbo frames.

                                  For an Intel PRO/1000 adapter that is later than 82571, (including 82571), the maximum MTU accepted by the MAC is 9216. For others, the maximum MTU accepted by the MAC is 16128. Use ifconfig(1M) to configure jumbo frames. Use ifconfig with the adapter instance and the mtu argument (ifconfig e1000g0 mtu 9216) to configure adapter e1000g0 for the maximum allowable jumbo frame size.

                                  Allowed values are:

                                  0 Standard ethernet frames with a MTU equal to 1500. Default.
                                  1 Jumbo frames with a maximum MTU of 4010.
                                  2 Jumbo frames with a maximum MTU of 8106.
                                  3 Jumbo frames with a maximum MTU of 16298.

                                  ..........................

                                  So 8106 - it is normal.
                                  • 14. Re: How to change default MTU size
                                    Nandinho
                                    Hi

                                    Thanks a lot for the information.

                                    regards