This discussion is archived
2 Replies Latest reply: Mar 1, 2012 1:35 PM by 920956 RSS

Will Patchset 11.1.1.6.0 be certified with JDK 6?

920956 Newbie
Currently Being Moderated
1. FMW Portal Forms Reports and Discoverer 11.1.1.6.0 patchset was just released. According to the FMW certification matrix, the only certified JDK is 1.7.0_2+. Is this correct?

Reference: http://www.oracle.com/technetwork/middleware/downloads/fmw-11gr1certmatrix.xls

2. Will JDK 1.6.x ever be certified with this patchset release? If so, which JDK version does Oracle recommend to use with patchset 11.1.1.6.0 (for a new installation) JDK 6 or JDK 7?
..note.. since we are using the generic WLS installer, we must choose the JDK we will use. Hence the question above.

3. What client JRE and Browser is recommended for use with FMW 11.1.1.6.0 (Forms, Reports, Discoverer, etc.)?

Thank you.
greg
  • 1. Re: Will Patchset 11.1.1.6.0 be certified with JDK 6?
    Michael Ferrante (Oracle) Guru Moderator
    Currently Being Moderated
    My answers/comments in red below. I will answer assuming you are asking about Forms specifically.

    1. FMW Portal Forms Reports and Discoverer 11.1.1.6.0 patchset was just released. According to the FMW certification matrix, the only certified JDK is 1.7.0_2+. Is this correct?

    Reference: http://www.oracle.com/technetwork/middleware/downloads/fmw-11gr1certmatrix.xls

    <font color="red">I think you may be misreading something. For the server side, JDK 1.6 is supported for 11.1.1.1 - 11.1.1.6 (also true for 11.1.2.0). JDK 1.7 was certifeid only for 11.1.1.6 when also using WLS 10.3.6</font><br>

    2. Will JDK 1.6.x ever be certified with this patchset release? If so, which JDK version does Oracle recommend to use with patchset 11.1.1.6.0 (for a new installation) JDK 6 or JDK 7?
    ..note.. since we are using the generic WLS installer, we must choose the JDK we will use. Hence the question above.

    <font color="red">Refer to answer #1.</font><br>

    3. What client JRE and Browser is recommended for use with FMW 11.1.1.6.0 (Forms, Reports, Discoverer, etc.)?

    <font color="red">Which browser you use is your choice. Currently, I believe Forms has the tightest restrictions on what was certified. IE and Firefox tend to be the most popular. As for the JRE, Forms 11.1.x is only certified with 1.6.0_10 and newer, not to include 1.7. No Forms version is currently certified with JRE 7 at this time. So, given that, I would always recommend the latest JRE supported for the client side. In this case the current supported JRE for Forms is 1.6.0_31</font><br>
  • 2. Re: Will Patchset 11.1.1.6.0 be certified with JDK 6?
    920956 Newbie
    Currently Being Moderated
    Thanks Michael. On the systems tab of the certification matrix excel file, if you filter the version column to show 11.1.1.6.0 only, this is where i was only seeing the JDK 7 certification for 11.1.1.6.0. But now that you mention it, I guess what it really means is JDK 7 is only certified with 11.1.1.6.0. But JDK 6 is still certified with all 11.1.1.x versions. Do I have that right then? Thanks for clarifying.

    greg

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points