14 Replies Latest reply: Mar 8, 2012 10:59 AM by the_assface RSS

    Unable to start nodemanager

    the_assface
      I am attempting to start or connect to my nodemanager via the WLST rather than the service and get the following error....by the way, I can log into the admin console just fine with these credentials. The dumpStack just reiterates this same error. I get the same error whether the nodemanager service is up and running or not. Any ideas?

      wls:/offline> nmConnect('beaadmin','xxxqa11','localhost','5556','QA11','c:/
      Oracle/Middleware/user_projects/domains/QA11','ssl')
      Connecting to Node Manager ...
      Traceback (innermost last):
      File "<console>", line 1, in ?
      File "<iostream>", line 123, in nmConnect
      File "<iostream>", line 618, in raiseWLSTException
      WLSTException: Error occured while performing nmConnect : Cannot connect to Node
      Manager. : Connection refused: connect. Could not connect to NodeManager. Check
      that it is running at localhost:5,556.
      Use dumpStack() to view the full stacktrace
      wls:/offline> nmConnect('beaadmin','beaaxxx','10.5.110.227','5556','QA11','
      c:/Oracle/Middleware/user_projects/domains/QA11','ssl')
      Connecting to Node Manager ...
      Traceback (innermost last):
      File "<console>", line 1, in ?
      File "<iostream>", line 123, in nmConnect
      File "<iostream>", line 618, in raiseWLSTException
      WLSTException: Error occured while performing nmConnect : Cannot connect to Node
      Manager. : Access to domain 'QA11' for user 'beaadmin' denied
      Use dumpStack() to view the full stacktrace
      wls:/offline>

      Edited by: the_assface on Feb 29, 2012 9:33 AM
        • 1. Re: Unable to start nodemanager
          René van Wijk
          Did you configure the domain in production mode?

          In this case a random node manager username and password are created.

          To change this open the admin console and Click domain_name, security, advanced link and edit the following parameters:
          - NodeManager Username, NodeManager Password, Confirm NodeManager Password and set these to known values.

          More information can be found here: http://middlewaremagic.com/weblogic/?p=7819
          • 2. Re: Unable to start nodemanager
            the_assface
            Thanks Rene'....I also just found this post, which has been quite helpful. This post was similar to yours but suggested enrolling the nodemanager to the domain again. I did that and now getting an error that suggests a nodemanager certificate issue. Since the nodemanager is not a server and simply represents servers then where would this need to be corrected? I already have my admin server set to NONE on the hostname verification.Thanks for the assistance!

            Any ideas why some boxes/domains would get "access denied" on nmConnect?


            wls:/SIT11/serverConfig> nmConnect('beaadmin','beaadminxxx','localhost','5556'
            ,'SIT11','c:/Oracle/Middleware/user_projects/domains/SIT11','SSL')
            Connecting to Node Manager ...
            <Feb 29, 2012 9:57:34 AM CST> <Notice> <Security> <BEA-090898> <Ignoring the tru
            sted CA certificate "CN=T-TeleSec GlobalRoot Class 3,OU=T-Systems Trust Center,O
            =T-Systems Enterprise Services GmbH,C=DE". The loading of the trusted certificat
            e list raised a certificate parsing exception PKIX: Unsupported OID in the Algor
            ithmIdentifier object: 1.2.840.113549.1.1.11.>
            <Feb 29, 2012 9:57:34 AM CST> <Notice> <Security> <BEA-090898> <Ignoring the tru
            sted CA certificate "CN=T-TeleSec GlobalRoot Class 2,OU=T-Systems Trust Center,O
            =T-Systems Enterprise Services GmbH,C=DE". The loading of the trusted certificat
            e list raised a certificate parsing exception PKIX: Unsupported OID in the Algor
            ithmIdentifier object: 1.2.840.113549.1.1.11.>
            <Feb 29, 2012 9:57:34 AM CST> <Notice> <Security> <BEA-090898> <Ignoring the tru
            sted CA certificate "CN=KEYNECTIS ROOT CA,OU=ROOT,O=KEYNECTIS,C=FR". The loading
            of the trusted certificate list raised a certificate parsing exception PKIX: Un
            supported OID in the AlgorithmIdentifier object: 1.2.840.113549.1.1.11.>
            <Feb 29, 2012 9:57:34 AM CST> <Warning> <Security> <BEA-090542> <Certificate cha
            in received from localhost - 127.0.0.1 was not trusted causing SSL handshake fai
            lure. Check the certificate chain to determine if it should be trusted or not. I
            f it should be trusted, then update the client trusted CA configuration to trust
            the CA certificate that signed the peer certificate chain. If you are connectin
            g to a WLS server that is using demo certificates (the default WLS server behavi
            or), and you want this client to trust demo certificates, then specify -Dweblogi
            c.security.TrustKeyStore=DemoTrust on the command line for this client.>
            Traceback (innermost last):
            File "<console>", line 1, in ?
            File "<iostream>", line 1409, in nmConnect
            File "<iostream>", line 1744, in raiseWLSTException
            WLSTException: Error occured while performing nmConnect : Cannot connect to Node
            Manager. : [Security:090542]Certificate chain received from localhost - 127.0.0
            .1 was not trusted causing SSL handshake failure. Check the certificate chain to
            determine if it should be trusted or not. If it should be trusted, then update
            the client trusted CA configuration to trust the CA certificate that signed the
            peer certificate chain. If you are connecting to a WLS server that is using demo
            certificates (the default WLS server behavior), and you want this client to tru
            st demo certificates, then specify -Dweblogic.security.TrustKeyStore=DemoTrust o
            n the command line for this client.

            Edited by: the_assface on Mar 8, 2012 8:33 AM
            • 3. Re: Unable to start nodemanager
              the_assface
              Okay, I toggled the SSL on the 'machine' from SSL to plain and then restarted my admin service and nodemanger. I thought it was odd that the error message with certs was still the same so I reset it back to SSL and restarted again. No one was more surprised than me that it actually connected to the node manager this time. So I attempted to start a managed server and it works. Very excited as this us much better than writing non-nodemanager custom start scripts for each of my machines. Much thanks to Rene' and Jay for the assistance and suggestions.
              • 4. Re: Unable to start nodemanager
                the_assface
                Crap....when I go back to it now it gets the certificate error again. Toggling the SSL to plain is no fix. it's not even a good work around as the idea is that the admin is not available when I have to start these servers from WLST NM commands. Any ideas on long term fix?
                • 5. Re: Unable to start nodemanager
                  René van Wijk
                  You marked this post as answered but from your last question 'Any ideas on long term fix?' I suggest it is not.

                  When you set-up your domain, please do not use nmenroll, a better way to replicate the security data from the admin server to the node manager
                  is to just plainly use the start scripts (startWebLogic and startNodeManager).

                  When you set-up your domain you can follow these steps:
                  - install the software on the machines you wish to use the WebLogic server
                  - configure your domain
                  - use pack and unpack when you have multiple machines to copy the necessary domain files to other machine than the admin machine.
                  - now we need to test the set-up, start the admin server by using startWebLogic (located in the ${DOMAIN_HOME} directory)
                  - start the node manager on all the machine (also by using the default startNodeManager script (located in the ${WL_HOME}/server/bin directory)
                  this makes sure the node manager are registered (security wise) correctly with the admin server.
                  - next use the admin console to start the managed servers in the domain, when everything is working stop all the servers and node managers.

                  The steps are described in detail in the post: http://middlewaremagic.com/weblogic/?p=7819 in the section 'test the environment'.
                  Another post that the describes the steps can be found here: http://middlewaremagic.com/weblogic/?p=7795 (which only uses WebLogic)

                  Now, we are in the position to create start and stop WLST script for the environment. When using WLST and the domain was created in production
                  mode you need to adjust the nodemanager username and password as these generated randomly. You can leave the node manager set to SSL. When
                  you want to use plain, you have to configure it in the admin console (the machine to which the node manager is associated). You also have to
                  set the secureListener attribute in the nodemanager.properties to false.

                  The section 'Start and stop scripts' presented here: http://middlewaremagic.com/weblogic/?p=7795 shows an example of how to create start and stop scripts.
                  It shows an example how to set-up the node manager a as service on Linux as well, is I recall correctly you are on Windows an example can be found
                  here: Re: Installing Weblogic Admin Server as service -  service won't start
                  • 6. Re: Unable to start nodemanager
                    the_assface
                    Yes, I had it working and this post marked as answered but for some reason now I am getting the message below when starting nodemanager from WLST.I apologize if I didn't make it clear but my domains are already setup and functioning fine. I am just trying to create a disaster recovery plan considering our current configuration in the event our admin server goes down. Since we are on Windows we have never setup scripts or started servers that way. We used nodemanager service and admin services to start and then the admin console to stop and start servers. And at this point it sounds like using WLST to connect to nodemanager is much easier than writing custom script as it uses the startup properties. In retrospect I would build my next domains more in line with what you are suggesting. But for now if I could just get the WLST connection working consistently to connect to nodemanager then life would be good.

                    wls:/offline> nmConnect('beaadmin','beaadminxxx','localhost','5556','SIT11','c
                    :/Oracle/Middleware/user_projects/domains/SIT11','SSL')
                    Connecting to Node Manager ...
                    <Mar 1, 2012 8:58:33 AM CST> <Notice> <Security> <BEA-090898> <Ignoring the trus
                    ted CA certificate "CN=T-TeleSec GlobalRoot Class 3,OU=T-Systems Trust Center,O=
                    T-Systems Enterprise Services GmbH,C=DE". The loading of the trusted certificate
                    list raised a certificate parsing exception PKIX: Unsupported OID in the Algori
                    thmIdentifier object: 1.2.840.113549.1.1.11.>
                    <Mar 1, 2012 8:58:33 AM CST> <Notice> <Security> <BEA-090898> <Ignoring the trus
                    ted CA certificate "CN=T-TeleSec GlobalRoot Class 2,OU=T-Systems Trust Center,O=
                    T-Systems Enterprise Services GmbH,C=DE". The loading of the trusted certificate
                    list raised a certificate parsing exception PKIX: Unsupported OID in the Algori
                    thmIdentifier object: 1.2.840.113549.1.1.11.>
                    <Mar 1, 2012 8:58:33 AM CST> <Notice> <Security> <BEA-090898> <Ignoring the trus
                    ted CA certificate "CN=KEYNECTIS ROOT CA,OU=ROOT,O=KEYNECTIS,C=FR". The loading
                    of the trusted certificate list raised a certificate parsing exception PKIX: Uns
                    upported OID in the AlgorithmIdentifier object: 1.2.840.113549.1.1.11.>
                    Traceback (innermost last):
                    File "<console>", line 1, in ?
                    File "<iostream>", line 123, in nmConnect
                    File "<iostream>", line 618, in raiseWLSTException
                    WLSTException: Error occured while performing nmConnect : Cannot connect to Node
                    Manager. : Connection refused: connect. Could not connect to NodeManager. Check
                    that it is running at localhost:5,556.
                    Use dumpStack() to view the full stacktrace
                    wls:/offline>

                    Edited by: the_assface on Mar 8, 2012 8:33 AM
                    • 7. Re: Unable to start nodemanager
                      René van Wijk
                      The error is saying: "Connection refused: connect. Could not connect to NodeManager. Check that it is running at localhost:5,556"

                      Did you define a different hostname to be used for the nodemanager than localhost? For example, in your configuration (${DOMAIN_HOME}/config/config.xml)
                      do you have something like:
                      <machine xsi:type="unix-machineType">
                          <name>Machine1</name>
                          <node-manager>
                            <listen-address>axis-into-ict.nl</listen-address>
                          </node-manager>
                          <post-bind-uid-enabled>true</post-bind-uid-enabled>
                          <post-bind-uid>oracle</post-bind-uid>
                          <post-bind-gid-enabled>true</post-bind-gid-enabled>
                          <post-bind-gid>oracle</post-bind-gid>
                        </machine>
                      that is defined a listen-address for the node manager different than localhost?

                      Another thing to note is the path definition in the nmconnect command: nmConnect('beaadmin','beaadminsit11','localhost','5556','SIT11','c:/Oracle/Middleware/user_projects/domains/SIT11','SSL')
                      Here you use forward slashes, maybe on Windows it can be handled in this manner, but to be on the save side it is better to use double backslashes.

                      The following gives an example script, to start the node manager and connect to the node manager.
                      beahome = 'c:\\Oracle\\Middleware';
                      pathseparator = '\\';
                      
                      adminusername = 'beadmin';
                      adminpassword = 'beaadminsit11';
                      domainname = 'SIT11';
                      node_manager_listen_port=5556
                      node_manager_listen_address=axis-into-ict.nl
                      
                      domainlocation = beahome + pathseparator + 'user_projects' + pathseparator + 'domains' + pathseparator + domainname;
                      nodemanagerhomelocation = beahome + pathseparator + 'wlserver_10.3' + pathseparator + 'common' + pathseparator + 'nodemanager';
                      
                      print 'START NODE MANAGER';
                      startNodeManager(verbose='true', NodeManagerHome=nodemanagerhomelocation, ListenPort=node_manager_listen_port, ListenAddress=node_manager_listen_address);
                      
                      print 'CONNECT TO NODE MANAGER';
                      nmConnect(adminusername, adminpassword, node_manager_listen_address, node_manager_listen_port, domainname, domainlocation, 'ssl');
                      You only have to use startnodemanager command when it is not running, otherwise it can be left out. You can run the script by using: wlst.cmd c:\location\scriptname.py.
                      The wlst.cmd script can be found in the ${WL_HOME}/common/bin directory.
                      • 8. Re: Unable to start nodemanager
                        the_assface
                        No, here is the config.xml section for that. I tried the same parameters in the config.xml and instead of localhost I used 'SITMachine1' but I get the same exact error message as before.

                        I also tried your suggestion in the connect string (below) but same error.

                        nmConnect('beaadmin','beaadminXXX','localhost','5556','SIT11','c:\\Oracle\\Middleware\\user_project\\domain\\SIT11','SSL')

                        Then I tried making the Python script as follows:

                        beahome = 'c:\\Oracle\\Middleware';
                        pathseparator = '\\';

                        adminusername = 'beadmin';
                        adminpassword = 'beaadminsit11';
                        domainname = 'SIT11';
                        node_manager_listen_port=5556
                        node_manager_listen_address=10.5.110.129

                        domainlocation = beahome + pathseparator + 'user_projects' + pathseparator + 'domains' + pathseparator + domainname;
                        nodemanagerhomelocation = beahome + pathseparator + 'wlserver_10.3' + pathseparator + 'common' + pathseparator + 'nodemanager';

                        print 'CONNECT TO NODE MANAGER';
                        nmConnect(adminusername, adminpassword, node_manager_listen_address, node_manager_listen_port, domainname, domainlocation, 'ssl');

                        I cut out the start section for the nodemanager since I use a service to start it and that works with no issues and I can start it remotely. I DID change the listen address to the machine IP as it is configured in the console but when I try to run this script from the offline WLST command I simply get a syntax error, seen here....

                        wls:/offline> c:\Oracle\Middleware\user_projects\domains\SIT11\config\startup\nm
                        _connect.py
                        Traceback (innermost last):
                        (no code object) at line 0
                        File "<console>", line 1
                        c:\Oracle\Middleware\user_projects\domains\SIT11\config\startup\nm_conne
                        ct.py
                        ^
                        SyntaxError: invalid syntax
                        wls:/offline> c:\Oracle\Middleware\user_projects\domains\SIT11\config\startup\nm
                        _connect.py
                        Traceback (innermost last):
                        (no code object) at line 0
                        File "<console>", line 1
                        c:\Oracle\Middleware\user_projects\domains\SIT11\config\startup\nm_conne
                        ct.py
                        ^
                        SyntaxError: invalid syntax
                        wls:/offline>

                        Ideas? Thansk!
                        • 9. Re: Unable to start nodemanager
                          René van Wijk
                          When you want to run the script in the WLST console you have to use execfile(filename.py), for example,
                          wls:/offline> execfile(c:\Oracle\Middleware\user_projects\domains\SIT11\config\startup\nm_connect.py)
                          Can also check the nodemanager.log file to which hostname/IP-address it is listening. Look for an entry like:
                          "Secure socket listener started on port 5556, host axis-into-ict.nl/192.168.1.66". By default, the log file
                          can be found in ${MIDDLEWARE_HOME}/wlserver_10.3/common/nodemanager. You have to use the
                          hostname or IP-address in the nmconnect command.
                          • 10. Re: Unable to start nodemanager
                            the_assface
                            I see both of these entries in the nm.log....

                            <Mar 9, 2010 10:17:42 AM> <INFO> <Secure socket listener started on port 5,556>
                            <Mar 9, 2010 10:23:33 AM> <INFO> <Secure socket listener started on port 5,556, host /10.5.110.129>

                            I have tried it with the / and same error, which is now back to the security error (below)....I have the script at least failing the same way, no syntax errors. Turns out this needed the port and listen address in the script with quotes around the values.

                            wls:/offline> execfile('c:\\Oracle\\Middleware\\user_projects\\domains\\SIT11\\c
                            onfig\\startup\\nm_connect.py')
                            CONNECT TO NODE MANAGER
                            Connecting to Node Manager ...
                            <Mar 7, 2012 4:18:21 PM CST> <Warning> <Security> <BEA-090542> <Certificate chai
                            n received from sitportal1.fcdev.com - 10.5.110.129 was not trusted causing SSL
                            handshake failure. Check the certificate chain to determine if it should be trus
                            ted or not. If it should be trusted, then update the client trusted CA configura
                            tion to trust the CA certificate that signed the peer certificate chain. If you
                            are connecting to a WLS server that is using demo certificates (the default WLS
                            server behavior), and you want this client to trust demo certificates, then spec
                            ify -Dweblogic.security.TrustKeyStore=DemoTrust on the command line for this cli
                            ent.>
                            Traceback (innermost last):
                            File "<console>", line 1, in ?
                            File "c:\Oracle\Middleware\user_projects\domains\SIT11\config\startup\nm_conne
                            ct.py", line 14, in ?
                            File "<iostream>", line 123, in nmConnect
                            File "<iostream>", line 618, in raiseWLSTException
                            WLSTException: Error occured while performing nmConnect : Cannot connect to Node
                            Manager. : [Security:090542]Certificate chain received from sitportal1.fcdev.co
                            m - 10.5.110.129 was not trusted causing SSL handshake failure. Check the certif
                            icate chain to determine if it should be trusted or not. If it should be trusted
                            , then update the client trusted CA configuration to trust the CA certificate th
                            at signed the peer certificate chain. If you are connecting to a WLS server that
                            is using demo certificates (the default WLS server behavior), and you want this
                            client to trust demo certificates, then specify -Dweblogic.security.TrustKeySto
                            re=DemoTrust on the command line for this client.
                            Use dumpStack() to view the full stacktrace
                            wls:/offline>
                            • 11. Re: Unable to start nodemanager
                              René van Wijk
                              In the logging there is a suggestion to add -Dweblogic.security.TrustKeyStore=DemoTrust to the node manager that is running as a service.
                              In this case you have to create the service again.

                              Just to test if the set-up is working without the service, can you stop the service and start the node manager through WLST. To
                              see if it is possible to start and connect to the node manager. The WLST command to start the node manager is presented above.
                              • 12. Re: Unable to start nodemanager
                                the_assface
                                I was able to start the nodemanager from WLST, however, I still cannot connect to it (or start managed servers) due to the cert issue. It displays a bit more info (below)now though. When you suggest to add those new arguments and reinstall the service where are you talking about adding it to? Is this added to the installNodeManager.cmd? If so, where? I apologize but not familiar with this...thanks again!

                                wls:/offline> nmConnect('beaadmin','beaadminsit111','10.5.110.129','5556','SIT11
                                ','c:/Oracle/Middleware/user_projects/domains/SIT11','SSL')
                                Connecting to Node Manager ...
                                <Mar 8, 2012 7:47:55 AM CST> <Warning> <Security> <BEA-090542> <Certificate chai
                                n received from sitportal1.fcdev.com - 10.5.110.129 was not trusted causing SSL
                                handshake failure. Check the certificate chain to determine if it should be trus
                                ted or not. If it should be trusted, then update the client trusted CA configura
                                tion to trust the CA certificate that signed the peer certificate chain. If you
                                are connecting to a WLS server that is using demo certificates (the default WLS
                                server behavior), and you want this client to trust demo certificates, then spec
                                ify -Dweblogic.security.TrustKeyStore=DemoTrust on the command line for this cli
                                ent.>
                                Traceback (innermost last):
                                File "<console>", line 1, in ?
                                File "<iostream>", line 123, in nmConnect
                                File "<iostream>", line 618, in raiseWLSTException
                                WLSTException: Error occured while performing nmConnect : Cannot connect to Node
                                Manager. : [Security:090542]Certificate chain received from sitportal1.fcdev.co
                                m - 10.5.110.129 was not trusted causing SSL handshake failure. Check the certif
                                icate chain to determine if it should be trusted or not. If it should be trusted
                                , then update the client trusted CA configuration to trust the CA certificate th
                                at signed the peer certificate chain. If you are connecting to a WLS server that
                                is using demo certificates (the default WLS server behavior), and you want this
                                client to trust demo certificates, then specify -Dweblogic.security.TrustKeySto
                                re=DemoTrust on the command line for this client.
                                Use dumpStack() to view the full stacktrace
                                wls:/offline> NMProcess: <Mar 8, 2012 7:47:56 AM CST> <Warning> <Security> <BEA-
                                090482> <BAD_CERTIFICATE alert was received from sitportal1.fcdev.com - 10.5.110
                                .129. Check the peer to determine why it rejected the certificate chain (trusted
                                CA configuration, hostname verification). SSL debug tracing may be required to
                                determine the exact reason the certificate was rejected.>
                                NMProcess: Mar 8, 2012 7:47:56 AM weblogic.nodemanager.server.Handler run
                                NMProcess: WARNING: Uncaught exception in server handlerjavax.net.ssl.SSLKeyExce
                                ption: [Security:090482]BAD_CERTIFICATE alert was received from sitportal1.fcdev
                                .com - 10.5.110.129. Check the peer to determine why it rejected the certificate
                                chain (trusted CA configuration, hostname verification). SSL debug tracing may
                                be required to determine the exact reason the certificate was rejected.
                                NMProcess: javax.net.ssl.SSLKeyException: [Security:090482]BAD_CERTIFICATE alert
                                was received from sitportal1.fcdev.com - 10.5.110.129. Check the peer to determ
                                ine why it rejected the certificate chain (trusted CA configuration, hostname ve
                                rification). SSL debug tracing may be required to determine the exact reason the
                                certificate was rejected.
                                NMProcess: at com.certicom.tls.interfaceimpl.TLSConnectionImpl.fireExceptio
                                n(Unknown Source)
                                NMProcess: at com.certicom.tls.interfaceimpl.TLSConnectionImpl.fireAlertRec
                                eived(Unknown Source)
                                NMProcess: at com.certicom.tls.record.alert.AlertHandler.handle(Unknown Sou
                                rce)
                                NMProcess: at com.certicom.tls.record.alert.AlertHandler.handleAlertMessage
                                s(Unknown Source)
                                NMProcess: at com.certicom.tls.record.MessageInterpreter.interpretContent(U
                                nknown Source)
                                NMProcess: at com.certicom.tls.record.MessageInterpreter.decryptMessage(Unk
                                nown Source)
                                NMProcess: at com.certicom.tls.record.ReadHandler.processRecord(Unknown Sou
                                rce)
                                NMProcess: at com.certicom.tls.record.ReadHandler.readRecord(Unknown Source
                                )
                                NMProcess: at com.certicom.tls.record.ReadHandler.readUntilHandshakeComplet
                                e(Unknown Source)
                                NMProcess: at com.certicom.tls.interfaceimpl.TLSConnectionImpl.completeHand
                                shake(Unknown Source)
                                NMProcess: at com.certicom.tls.record.ReadHandler.read(Unknown Source)
                                NMProcess: at com.certicom.io.InputSSLIOStreamWrapper.read(Unknown Source)
                                NMProcess: at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:264)
                                NMProcess: at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:306)
                                NMProcess: at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:158)
                                NMProcess: at java.io.InputStreamReader.read(InputStreamReader.java:167)
                                NMProcess: at java.io.BufferedReader.fill(BufferedReader.java:136)
                                NMProcess: at java.io.BufferedReader.readLine(BufferedReader.java:299)
                                NMProcess: at java.io.BufferedReader.readLine(BufferedReader.java:362)
                                NMProcess: at weblogic.nodemanager.server.Handler.run(Handler.java:70)
                                NMProcess: at java.lang.Thread.run(Thread.java:619)
                                • 13. Re: Unable to start nodemanager
                                  René van Wijk
                                  I think the certificate issue has to do with the nmEnroll, not sure. But I have seen it used once before and all things went to smithereens as well.

                                  Unfortunately, I do not have a Windows install at hand. But when you look here (Re: Installing Weblogic Admin Server as service -  service won't start
                                  there must be some MEM_ARGS argument present, to which you can add the -Dweblogic.security.TrustKeyStore=DemoTrust.

                                  Before you do this can you start WLST by using this:
                                  java -Dweblogic.security.TrustKeyStore=DemoTrust -Dssl.debug=true -Dweblogic.security.SSL.ignoreHostnameVerification=true weblogic.WLST
                                  and then try to connect to see what happens. Note that it also enables SSL debugging as well.
                                  • 14. Re: Unable to start nodemanager
                                    the_assface
                                    That fixed it! Here are my steps (in the event someone else needs the help)

                                    1) Go to command line to Oracle|home\wlserver_10.3\server\bin and run setWLSenv.cmd

                                    2) Open WLST by running this command from the previous command line java -Dweblogic.security.TrustKeyStore=DemoTrust -Dssl.debug=true -Dweblogic.security.SSL.ignoreHostnameVerification=true weblogic.WLST

                                    3) IF you need to start the nodemanager then type startNodeManager() (this apparently used my nodemanager.properties as I never passed parameters to it, you may need to pass the parameters though)

                                    4)Connect to nodemanager by running nmConnect('username','password',','listen port','domain name','domain path,'SSL' or 'plain'')

                                    5) start managed servers by command nmStart('name of managed server')

                                    6) stop managed servers by command nmKill ('name of managed server')


                                    The only caveat to worry about here and what caused a lot of my frustration was that I have a nodemanager folder under \wlserver_10.3\common where we have all of our nodemanager.properties, nodemanager.logs, etc....

                                    What I also found was that under \wlserver_10.3\common\BIN there were also these same files (by default via the WL install I assume) and because the properties were not the same I was having issues. I assume this is where WLST was reading them from. Bottom line is that I copied and replaced all of my correct NM files from \common to \common\bin and all the above steps worked fine.

                                    Much thanks to Rene' and his incredible patience for helping me resolve this. You sir are why community forums like this work....

                                    Edited by: the_assface on Mar 8, 2012 10:59 AM