5 Replies Latest reply: Mar 2, 2012 2:34 PM by EdStevens RSS

    Oracle Database 10g: Unable to get oracle client

    565677
      Dear all,


      please I need your help in this issue:

      I have a CRM application running on Oracle Database 10g but when I try to access this application, the following error messsages always appear:

      "UNABLE TO GET ORACLE CLIENT"
      "ORA-12154:TNS: COULD NOT RESOLVE THE CONNECT IDENTIFIER SPECIFIED"

      I have added the database entry in all the files tnsnames.ora , I can access the database from SQL PLUS but I can't from the CRM application,

      any suggestions please

      Thanks
        • 1. Re: Oracle Database 10g: Unable to get oracle client
          sb92075
          user562674 wrote:
          Dear all,


          please I need your help in this issue:

          I have a CRM application running on Oracle Database 10g but when I try to access this application, the following error messsages always appear:

          "UNABLE TO GET ORACLE CLIENT"
          "ORA-12154:TNS: COULD NOT RESOLVE THE CONNECT IDENTIFIER SPECIFIED"

          I have added the database entry in all the files tnsnames.ora , I can access the database from SQL PLUS but I can't from the CRM application,

          any suggestions please

          Thanks
          ORA-12154 ALWAYS only occurs on SQL Client & no SQL*Net packets ever leave client system
          ORA-12154 occurs when client requests a connection to some DB server system using some connection string.
          The lookup operation fails because the name provided can NOT be resolved to any remote DB.
          The analogous operation would be when you wanted to call somebody, but could not find their name in any phonebook.
          The most frequent cause for the ORA-12154 error is when the connection alias can not be found in tnsnames.ora.
          The lookup operation of the alias can be impacted by the contents of the sqlnet.ora file; specifically DOMAIN entry.
          TROUBLESHOOTING GUIDE: ORA-12154 & TNS-12154 TNS:could not resolve service name [ID 114085.1]
          http://edstevensdba.wordpress.com/2011/02/26/ora-12154tns-03505/
          • 2. Re: Oracle Database 10g: Unable to get oracle client
            Mark D Powell
            To add to what sb wrote:

            What platform is the cleint on?
            What version of the Oracle client is installed? What bitmode?
            Who is the vendor and what is the version of the CRM product?
            What is the version of the target database?

            HTH -- Mark D Powell --
            • 3. Re: Oracle Database 10g: Unable to get oracle client
              565677
              plaform windows
              oracle database 10.2.0.4
              • 4. Re: Oracle Database 10g: Unable to get oracle client
                Mark D Powell
                We have had to install 32 bit mode Oracle clients on Windows 7 / 2008 64 bit boxes due to the software requiring the 32 bit version of the Oracle cleint routines. To identify if you could have this type of issue the answers to the rest of my questions would have been helpful. Ater all Windows 2003 is not the same as Windows 2008. There are various compatiability issues to be considered. The bitmode of the various components can be an issue.

                You also did not identify the product.

                HTH -- Mark D Powell --
                • 5. Re: Oracle Database 10g: Unable to get oracle client
                  EdStevens
                  user562674 wrote:
                  Dear all,


                  please I need your help in this issue:

                  I have a CRM application running on Oracle Database 10g but when I try to access this application, the following error messsages always appear:

                  "UNABLE TO GET ORACLE CLIENT"
                  "ORA-12154:TNS: COULD NOT RESOLVE THE CONNECT IDENTIFIER SPECIFIED"

                  I have added the database entry in all the files tnsnames.ora , I can access the database from SQL PLUS but I can't from the CRM application,

                  any suggestions please

                  Thanks
                  What is your "CRM application"? How do you configure it to know what tns entry to use? Are you sure you didn't mis-specify it there?