2 Replies Latest reply: Mar 4, 2012 5:30 AM by 897866 RSS

    Version conflict - OIM/SOA/OWSM

    user602387
      This should hopefully be a quick problem to resolve...

      I tried to install OIM 11.1.1.5. As per the documentation I grabbed the latest version of SOA, which was 11.1.1.6 along with the 11.1.1.6 RCU. Everything went pretty smoothly, but when I tried to create the WLS domain it failed one of the DB checks because the following query returned no rows:

      select 1
      from schema_version_registry
      where
      owner=(select user from dual) and mr_type='MDS' and
      version='11.1.1.5.0'

      The reason this failed is because the OWSM version is actually 11.1.1.6. Why is it looking for the 11.1.1.5 schema? Is it because OIM is version 11.1.1.5? Do OIM, SOA and the RCU all have to be at the exact same patch level? Can I just bypass the check because I have a higher version than its looking for or do I need to get SOA 11.1.1.5 instead?

      Thanks!
        • 1. Re: Version conflict - OIM/SOA/OWSM
          Le�ncio-Oracle
          yes, if you have


          User=SB_SOAINFRA
          SQL Test=select 1 from schema_version_registry where owner=(select user from dual) and mr_type='SOAINFRA' and version='11.1.1.5.0'

          User=SB_MDS
          SQL Test=select 1 from schema_version_registry where owner=(select user from dual) and mr_type='MDS' and version='11.1.1.5.0'

          User=SB_OIM
          SQL Test=select 1 from schema_version_registry where owner=(select user from dual) and mr_type='OIM' and version='11.1.1.5.0'


          your RCU version 11.1.1.5 is required to install OIM 11.1.1.5.


          I hope this helps,
          Thiago Leoncio
          • 2. Re: Version conflict - OIM/SOA/OWSM
            897866
            WebLogic should be 10.3.5 , IDAM, SOA and RCU must all be 11.1.1.5



            Atul Kumar