3 Replies Latest reply on Nov 5, 2012 8:57 AM by 970647

    Shared Components -> Files -> CSS not being deleted

      I have a CSS file that I store in the Shared Components -> Files -> CSS section of a workspace. I frequently update the CSS file by deleting the CSS file and re-uploading it to the workspace. Recently, instead of deleting and re-uploading, I edited the CSS file inline. When I applied the inline changes, the changes weren't reflected on the pages that utilize the CSS file (even after clearing the cache, restarting the browser, etc.). Even stranger, I deleted the CSS file altogether (without uploading a new one), and the pages that utilize the deleted file were still rendering using the old CSS file, almost as if the file was never really deleted. The only way I was able to apply the new CSS file and realize all the changes was to change the name of the file and upload it again. Any thoughts on why the old CSS file remains even after deleting?
        • 1. Re: Shared Components -> Files -> CSS not being deleted
          I don't see any responses to this question, but wanted to add that I am also having the same issue. When deleting the current CSS file and uploading a new file, the page is reverting back to a much older version of the stylesheet (even if a new file has not been uploaded, i.e. there is NO stylesheet.) I have also tried to edit the spreadsheet directly using the textbox feature that shows the static file details. The changes are reflected in Application Express when viewing the file, but fail to be applied when the web page is viewed in the browser, even after clearing the cache.

          Renaming the file works, but is extremely cumbersome as I could go through hundreds of changes in a single sitting. This is not a feasible fix.

          My success ratio is about 25% success to 75% failure for getting the correct files to load.

          Does anyone have any thoughts or similar experiences?
          • 2. Re: Shared Components -> Files -> CSS not being deleted
            I am getting the same issue.

            Have tried clearing my browser cache and forcing reload of the css files, but it is still loading an old version.

            My guess is that the css file is caching somewhere else.
            • 3. Re: Shared Components -> Files -> CSS not being deleted
              The CSS file gets cached on the client machine so isn't fetched by the browser each time, UNLESS IT HAS BEEN CHANGED. I believe it to be a bug in APEX that when the file is modified inline, the timestamp on file that is returned through wwv_flow_file_mgr.get_file does not have its timestamp updated.

              If you delete your temporary internet files then you should find the page no longer works.