This discussion is archived
0 Replies Latest reply: Mar 9, 2012 9:21 AM by 922416 RSS

Unable to run weblogic after -Xmanagement in setDomainEnv.sh-Sparc-Unix?

922416 Newbie
Currently Being Moderated
Hi ,
This a basic question related to Jrockit configuration in Weblogic server in Unix OS(Sun sparc).
I apply the following Jrockit parameter for remote discovery of the server attributes in the 'setDomainEnv.sh' file .

JROCKIT_ARGS="-Xmanagement:ssl=false,authenticate=false,autodiscovery=true"
export JROCKIT_ARGS

However , I get the following error during server startup which shuts down my managed server.

------------------------------------------Error :----------------------------------------------------------------------------

###<09-Mar-2012 16:19:28 o'clock GMT> <Warning> <NodeManager> <ira92717> <excsvr01> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1331309968933> <BEA-300043> <Node manager native library not found - server process id not saved.>

####<09-Mar-2012 16:19:29 o'clock GMT> <Error> <Socket> <ira92717> <excsvr01> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1331309969999> <BEA-000438> <Unable to load performance pack. Using Java I/O instead. Please ensure that a native performance library is in: '/opt/app/bea/jrockit5.0/R27.5.0_1.5.0_14/jre/lib/sparcv9/jrockit:/opt/app/bea/jrockit5.0/R27.5.0_1.5.0_14/jre/lib/sparcv9:/opt/app/bea/jrockit5.0/R27.5.0_1.5.0_14/jre/../lib/sparcv9::/opt/app/bea/weblogic10.0mp1/weblogic100/server/native/solaris/sparc:/opt/app/bea/weblogic10.0mp1/weblogic100/server/native/solaris/sparc/oci920_8:/usr/lib'
------------------------------------------Error :----------------------------------------------------------------------------

Can somebody kindly provide me pointers on what configuration parameters they use for Jrockit in unix OS for remote discovery ?

regards,
DRaj

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points