This discussion is archived
1 Reply Latest reply: Mar 9, 2012 1:52 PM by Sergiusz Wolicki (Oracle) RSS

Error while migrating charecter set using CSALTER from WE8MSWIN1252 to UTF8

922823 Newbie
Currently Being Moderated
Hi.
I tried to migrate with my database. I did backup, started in restricted mode the database.
when I run csalter.plb script I got:
SQL> @@csalter.plb
0 rows created.
Function created.
Function created.
Procedure created.
This script will update the content of the Oracle Data Dictionary.
Please ensure you have a full backup before initiating this procedure.
Would you like to proceed ?(Y/N)?Y
old 5: if (UPPER('&conf') 'Y') then
new 5: if (UPPER('Y') 'Y') then
Enter value for 1: UTF8
old 8: param1 := '&1';
new 8: param1 := UTF8';
Checking data validility...
TOCHAR is not superset of FROMCHAR
PL/SQL procedure successfully completed.
0 rows deleted.
Alter database character set....
Checking or Converting phrase did not finish successfully
No database (national) character set will be altered
PL/SQL procedure successfully completed.
SQL>

What should I type where I got "Enter value for 1:" ??

I have already done this with ANOTHER DATABASE with same Oracle version(10.1.0.2.0) and now application working fine, but now i am getting this problem.

How to correct my mistake ?? and what should i do to do it successfully

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points