This discussion is archived
4 Replies Latest reply: Jan 8, 2013 12:43 PM by user496899 RSS

ORACLE_BASE is not set..

user2017273 Newbie
Currently Being Moderated
Hi

oracle_base is not setting while changing database using oraenv

[oracle@test1 ~]$ . oraenv
ORACLE_SID = [rman] ? samp
The /u01/app/oracle/product/10.2.0.4/bin/orabase binary does not exist
You can set ORACLE_BASE manually if it is required.



How to fix that
  • 1. Re: ORACLE_BASE is not set..
    912595 Expert
    Currently Being Moderated
    user2017273 wrote:
    Hi

    oracle_base is not setting while changing database using oraenv

    [oracle@test1 ~]$ . oraenv
    ORACLE_SID = [rman] ? samp
    The /u01/app/oracle/product/10.2.0.4/bin/orabase binary does not exist
    You can set ORACLE_BASE manually if it is required.



    How to fix that
    well the answer is already hidden here '/u01/app/oracle/product/10.2.0.4/bin/orabase binary does not exist' . So check if this file exist there or not.
    If yes check its permission and ownership. If it doesn't exist copy this file from other same system may help ;)
  • 2. Re: ORACLE_BASE is not set..
    user2017273 Newbie
    Currently Being Moderated
    Hi,

    i copied orabase file from 11g ORACLE_HOME. STILL NOT WORKING

    [oracle@test1 bin]$ . oraenv
    ORACLE_SID = [rman] ? samp
    In line 12 of oraclehomeproperties.xml:
    LPX-00245: extra data after end of document
    The Oracle base has been set to Parse failed, error 245

    tHANKS
  • 3. Re: ORACLE_BASE is not set..
    CKPT Guru
    Currently Being Moderated
    oracle_base is not setting while changing database using oraenv

    [oracle@test1 ~]$ . oraenv
    ORACLE_SID = [rman] ? samp
    The /u01/app/oracle/product/10.2.0.4/bin/orabase binary does not exist
    You can set ORACLE_BASE manually if it is required.
    Post the results of
    $ls -ltr /u01/app/oracle/product/10.2.0.4/bin/orabase
  • 4. Re: ORACLE_BASE is not set..
    user496899 Newbie
    Currently Being Moderated
    To the best of my knowledge this is a known bug with a patch.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points