4 Replies Latest reply: Mar 21, 2012 12:42 PM by 925215 RSS

    Agent is not running on Windows Server 2008 R2

    925215
      Hello sorry for my English, but I'm trying to start the enterprise manager and when I write emctl start agent tells me that this up but when I write emcl agent status says "Agent is not running", I think that's the reason which I can not Initiate EM, thank you very much for your help.
        • 1. Re: Agent is not running on Windows Server 2008 R2
          Think_dba
          user13472578 wrote:
          Hello sorry for my English, but I'm trying to start the enterprise manager and when I write emctl start agent tells me that this up but when I write emcl agent status says "Agent is not running", I think that's the reason which I can not Initiate EM, thank you very much for your help.
          Is your Dbconsole services is showing "started" in services.msc?
          • 2. Re: Agent is not running on Windows Server 2008 R2
            Helios-GunesEROL
            Hi;

            1. Check your service start or not
            2. If its not start check log file

            Regard
            Helios
            • 3. Re: Agent is not running on Windows Server 2008 R2
              925215
              Hi thanks for your answers, dbconsole is started in services.msc and also Agent, but goes on to say that the agent is not running.

              In sysman log shows this,
              "03/20/2012 13:38:54,553 [MetricCollector: HOMETAB_THREAD600: 60] ERROR rt.DbMetricCollectorTarget _getAllData.328 - oracle.sysman.emSDK.emd.comm.CommException: Exception in sending Request :: null
              oracle.sysman.emSDK.emd.comm.CommException: Exception in sending Request :: null
              at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest_ (EMDClient.java: 1330)
              at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest (EMDClient.java: 1223)
              at oracle.sysman.emSDK.emd.comm.EMDClient.getMetrics (EMDClient.java: 640)
              at oracle.sysman.emo.perf.metric.rt.DbHomeTab._getAllData (DbHomeTab.java: 324)
              at oracle.sysman.emo.perf.metric.rt.DbHomeTab.getData (DbHomeTab.java: 139)
              at oracle.sysman.emo.perf.metric.eng.MetricCached.collectCachedData (MetricCached.java: 402)
              at
              at oracle.sysman.emo.perf.metric.eng.MetricCollectorThread.run (MetricCollectorThread.java: 320)
              at java.lang.Thread.run (Thread.java: 595)
              20/03/2012 22:00:03,335 [JobWorker 772: Thread-13] ERROR em.jobs executeCommand.161 - UpdateARUTables: Oracle MetaLink credentials are incorrect or missing. Click Patching Setup parameters required to September."

              In event viewer shows this,
              "Agent process exited abnormally DURING initialization." but this message appears a few hours after having started the service.

              I am using the Administrator account
              • 4. Re: Agent is not running on Windows Server 2008 R2
                925215
                Finally I could fix the problem by following the advice in this post OEM 10g... with 10g Release 2

                You have to locate the file <ORACLE_HOME> / <host name _SID> \ sysman \ config \ emd.properties

                and replace agentTZRegion = America / Buenos_Aires (in my case)

                Then restart the agent and dbconsole service, but still had problems with java, so here reboot the server and went perfect.

                Great forum, thanks!