3 Replies Latest reply: Mar 21, 2012 5:20 PM by Mark Kelly-Oracle RSS

    oracle data miner error

      AA. i have a problem in oracle data miner when i tried to start it with my connection ,the following error msg appeared :

      Listener refused the connection with the following error:
      ORA-12528, TNS:listener: all appropriate instances are blocking new connections
      The connection descriptor used by the client was :localhost: 1521:orcl

      please help me if u can.
        • 1. Re: oracle data miner error
          Mark Kelly-Oracle
          Hi Hager,
          It could be that the db is in a restricted state.
          You could try the following using sql worksheet on a sysdba connection:

          alter system disable restricted session;

          If this solves the problem, great, but then the question is, why is it in a restricted state.
          Data Miner, during upgrade or when a repository is dropped, puts the db into restricted mode.
          If there is a failure during one of these processes, then it could be possible that the db was left in a restricted mode.
          This generally should not happen when using Data Miner to perform these administrative actions, but could come up when running the scripts manually.

          Thanks, Mark

          Here are some other links that may help.
          There are a lot of results that come up when you google for this error.



          ORA-12528: TNS:listener: all approriate instances are blocking new connecti
          • 2. Re: oracle data miner error
            i am still facing the same problem , but when i tried to shutdown and startup oracle instance this msg appeared:

            SQL> shutdown
            ORA-01507: database not mounted

            ORACLE instance shut down.
            SQL> startup
            ORACLE instance started.

            Total System Global Area __________ bytes
            Fixed Size _______ bytes
            Variable Size _______ bytes
            Database Buffers _______ bytes
            Redo Buffers ________ bytes

            ORA-00204: error in reading <block 3, #block8> of control file
            ORA-00202: control file :'D:\APP\ENGHAGAR\ORADATA\ORCL\CONTROL03.CTL'
            ORA-27070: async read/write failed
            OSD-04006: ReadFile<> failure, unable to read from file
            O/S-error: <OS 1117> The request could not be performed because of an I/O device error.

            another small question is how can i take print screen from sqlplus 11g window? the prt sc keyboard button did not work on this oracle forum window.
            thanks a lot.
            • 3. Re: oracle data miner error
              Mark Kelly-Oracle
              This is certainly looking like a file corruption issue on your machine.
              I can't really offer you any advice on that type of issue in this forum.
              You should try the db general forum as there will be more expertise in that area.
              Good luck, Mark