0 Replies Latest reply: Apr 4, 2012 6:31 AM by guesXy RSS

    WDB_GATEWAY_LOGOUT issue with EPG

    guesXy
      Sorry guys for slotting this into GENERAL, if its meant to be somewhere else... And sorry if I broke some post submitting policies with this frist question.

      Have an issue with EPG and the WDB_GATEWAY_LOGOUT. I have a quite simple mechanism of sending the WDB_GATEWAY_LOGOUT cookie, which takes place on the client side from a web page:
      1) a JS script does an AJAX request to a package/procedure call for example just call it A.logoff() (where A is the package name);
      2) inside that this is performed:
      -- Open the HTTP header
      OWA_UTIL.mime_header('text/html', FALSE, NULL);

      -- Send a cookie to logout
      OWA_COOKIE.send('WDB_GATEWAY_LOGOUT', 'YES', path=>'/');

      -- Close the HTTP header
      OWA_UTIL.http_header_close;

      So i expect the user to be logged out from his session and if he were to access the same page again he would be promted for a username/password.

      Now under Apache this works like a charm and users are repromted. But running the same code under EPG this is not consistent, the form might come up, but on reply I get:
      Bad Request
      The HTTP client sent a request that this server could not understand.

      Now sorry this lacks details or any EPG/Apache lgos for comparison. But maybe this is a known issue for some of the forum residents that they can advise on? If needed I can try and get extra info if needed.