1 Reply Latest reply on Apr 11, 2012 10:30 AM by user7757478

    Login to VM Manager console fails: OVMAPI_6000E Internal Error: Connection

    user7757478
      Hi community,

      since today I cant login to my VM Manager console (3.0.3, fresh install) anymore, its throwing 'OVMAPI_6000E Internal Error: Connection refused'.
      Of course I looked into other threads and checked the following:
      - DB is running and OVM account is open;
      - the AdminServer.log (during login attempt)
      ...
      ####<Apr 11, 2012 11:26:31 AM CEST> <Info> <ServletContext-/ovm/console> <bdtzlp99> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <d810774247131511:-a37ce8c:136a0b273a7:-8000-0000000000000021> <1334136391276> <BEA-000000> <JspServlet: param superclass initialized to null>
      ####<Apr 11, 2012 11:26:31 AM CEST> <Info> <ServletContext-/ovm/console> <bdtzlp99> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <d810774247131511:-a37ce8c:136a0b273a7:-8000-0000000000000021> <1334136391276> <BEA-000000> <JspServlet: param workingDir initialized to: /u01/app/oracle/ovm-manager-3/machine1/base_adf_domain/servers/AdminServer/tmp/_WL_user/ovm_console/i75mdc>
      ####<Apr 11, 2012 11:26:31 AM CEST> <Info> <ServletContext-/ovm/console> <bdtzlp99> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <d810774247131511:-a37ce8c:136a0b273a7:-8000-0000000000000021> <1334136391277> <BEA-000000> <JspServlet: initialization complete>
      ####<Apr 11, 2012 11:29:00 AM CEST> <Info> <Health> <bdtzlp99> <AdminServer> <weblogic.GCMonitor> <<anonymous>> <> <d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000000e> <1334136540918> <WL-310002> <54% of the total memory in the server is free>

      - the AdminServer-diagnostic.log
      ...
      [2012-04-11T11:26:30.340+02:00] [AdminServer] [NOTIFICATION] [] [oracle.jbo.uicli.mom.CpxUtils$Visitor] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000001f,0] [APP: ovm_console] zip:/u01/app/oracle/ovm-manager-3/machine1/base_adf_domain/servers/AdminServer/tmp/_WL_user/ovm_console/i75mdc/war/WEB-INF/lib/_wl_cls_gen.jar!/com/oracle/ovm/mgr/faces/DataBindings.cpx
      [2012-04-11T11:26:30.493+02:00] [AdminServer] [NOTIFICATION] [] [oracle.security.oes.util.logging.Log4jConfigurator] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000001f,0] Could not find log4j configuration for MicroSM.
      [2012-04-11T11:26:30.632+02:00] [AdminServer] [NOTIFICATION] [JPS-03258] [oracle.jps.authorization.provider] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000001f,0] Initializing UserUtils; mbean: com.bea.security.providers.authorization.asi.ASIAuthorizationProviderMBeanImpl@f6467a1e([ASI Authorization Provider]), instance: null
      [2012-04-11T11:26:30.633+02:00] [AdminServer] [NOTIFICATION] [JPS-03258] [oracle.jps.authorization.provider] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000001f,0] Initializing UserUtils; using directory: RootOrg!AdminDir, anonymous user: anonymous
      [2012-04-11T11:26:30.849+02:00] [AdminServer] [NOTIFICATION] [ADFC-54008] [oracle.adfinternal.controller.faces.lifecycle.JSFLifecycleImpl] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000001f,0] [APP: ovm_console] ADFc: Initializing ADF Page Lifecycle for the JSF environment, LifecycleContextBuilder is 'oracle.adfinternal.controller.application.model.JSFDataBindingLifecycleContextBuilder'.
      [2012-04-11T11:33:47.053+02:00] [AdminServer] [ERROR] [] [com.oracle.ovm.mgr.faces.backing.Login] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: d810774247131511:-a37ce8c:136a0b273a7:-8000-000000000000006f,0] [APP: ovm_console] Unexpected error during login (com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_6000E Internal Error: Connection refused Connection refused[[
      Wed Apr 11 11:33:47 CEST 2012), please consult logs for details. OVMAPI_6000E Internal Error: Connection refused Connection refused

      I stopped and started the VM manager (via /etc/init.d/ovmm) but it returns with "Time out ..." after 150s because port 54321 is not active. Is this an issue?
      What else could cause the problem?

      Thanks & regards
      Axel D.