4 Replies Latest reply on Apr 13, 2012 3:07 PM by veejai24

    Application Server connection from 10g jdev failing

    user5149250
      Hi All,

      We are not able to setup Application Server connection from local jdev windows install to the 10g Server

      Run Time Port details mentioned below :

      Application Server Name = hostname.hstname1
      host = hstname1

      OPMN
      Local 6100 6100
      Remote 6200 6200
      Request 6003 6003

      OC4J : home
      HTTP 8890

      we are able to connect to the frontend url : http://hstname1:8890/em successfully
      but when trying to setup the Application Server connection in 10.1.3.3 jdev with below details it is faling

      Connection Type : Oracle Application Server 10g 10.1.3
      Connect to : Single Instance
      Hostname : hstname1
      OPMN Port : 6003
      OC4J Instance Name : home

      Now we test connection we get below mentioned error message

      **************
      Error getting OC4J Process for: opmn-home+oc4j-hstname1-6003-default: Timed out (15000 ms) connecting to OPMN

      **************

      1.have gone through the thread mentioned here but not working still
      JDeveloper Application Server connectivity

      2.Also verified the below command :

      $ netstat -an | grep 6003
      tcp4 0 0 127.0.0.1.6003 *.* LISTEN
      tcp4 0 0 10.81.52.102.6003 *.* LISTEN

      Here the ip address which we have in our local windows machines(hosts file at etc/hosts) is natted from the
      actual client ip address 10.81.52.102

      host entry :
      172.22.85.185 hstname1

      telnet connectivity :

      telnet hstname1 -- work fine
      telnet 172.22.85.185 -- works fine

      3.have made ssl enabled=false in the opmn.xml file

      Could someone please suggest as to what could be causing this issue..it would be very helpfull as we are currently stuck with this issue and not able to proceed further

      Thanks
        • 1. Re: Application Server connection from 10g jdev failing
          Arik
          Can you try increase the OPMN timeout period?
          The file located on: $ORACLE_HOME/opmn/conf/opmn.xml
          Change the line: <start timeout="300" retry="3"/>
          Stop and restart OPMN. See if something change
          • 2. Re: Application Server connection from 10g jdev failing
            veejai24
            Can you try with request port number - 6200

            Thanks,
            Vijay
            • 3. Re: Application Server connection from 10g jdev failing
              user5149250
              Hi,

              Yes tried with 6200 port still getting the same error message

              Error getting OC4J Process for: opmn-home+oc4j-ios0103e.idc.ikon.org-6200-default:
              Timed out (15000 ms) connecting to OPMN

              2.also have posted below the current opmn.xml settings

              <ias-component id="default_group">
              <process-type id="home" module-id="OC4J" status="enabled">
              <module-data>
              <category id="start-parameters">
              <data id="java-options" value="-Xms2048M -mx2048M -XX:MaxPermSize=256M -XX:AppendRatio=3 -Dstdstream.filesize=10 -Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false -Dclass.transfer=delegate -Doraesb.home=/opt01/app/EINTD/oracle/eintd10gR3iAS/SOA10gR3/integration/esb -Dhttp.proxySet=false -Doc4j.userThreads=true -Doracle.mdb.fastUndeploy=60 -Dorabpel.home=/opt01/app/EINTD/oracle/eintd10gR3iAS/SOA10gR3/bpel -Xbootclasspath^/p:/opt01/app/EINTD/oracle/eintd10gR3iAS/SOA10gR3/bpel/lib/orabpel-boot.jar -Doracle.security.jazn.config=/opt01/app/EINTD/oracle/eintd10gR3iAS/SOA10gR3/j2ee/home/config/jazn.xml -Dhttp.proxySet=false"/>
              <data id="oc4j-options" value="-out $ORACLE_HOME/opmn/logs/mylog.out -err $ORACLE_HOME/opmn/logs/mylog.err"/>
              </category>
              <category id="stop-parameters">
              <data id="java-options" value="-Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false"/>
              </category>
              </module-data>
              <start timeout="600" retry="2"/>
              <stop timeout="120"/>
              <restart timeout="720" retry="2"/>
              <port id="default-web-site" range="8890" protocol="http"/>
              <port id="rmi" range="12401-12500"/>
              <port id="rmis" range="12701-12800"/>
              <port id="jms" range="12601-12700"/>
              <process-set id="default_group" numprocs="1"/>
              </process-type>
              </ias-component>

              3. Is there anything else which could be checked..or any way in the jdev to see the exact log/error message or if need to enable debug log or trace on the server/opmn side...



              thanks
              • 4. Re: Application Server connection from 10g jdev failing
                veejai24
                Try this,

                http://veejai24.blogspot.co.uk/2008/03/how-to-get-soa-port-numbers-after.html

                Thanks,
                Vijay