1 2 Previous Next 20 Replies Latest reply: Apr 19, 2012 3:49 PM by Jeff E Go to original post RSS
      • 15. Re: Invalid login credentials for APEX though I can connect with SQL PLUS
        872796
        Sivio,

        Thanks for responding but I am still stuck.
        I hate to ask but could you in a sense spell it out for me?
        If you look earlier in the thread you can see the exact code I used to create the user ADMINUSERS with one change sa mentioned earlier - the WHERE clause was finding no data as worded so I changed it to read "WHERE WORKSPACE = 'BOB' and this was accepted.

        At the APEX login screen (I have already logged into oracle as "System" and then I click the Application Express button and I enter the following:
        Workspace: ADMINUSERS
        Username : ADMINUSERS
        Password: ADMIN

        and it gives me "invalid logon credentials.

        Maybe I am entering the wrong value for Workspace?
        As you can see the code to create the user did not specify to create a workspace or what value to use so I assumed it was the same as the username...is that right?

        I also tried using 'BOB' as the workspace name because that is the workspace I used in the WHERE clause to populate the variable n_security_group.

        This is not accepted either. Am I missing something obvious to everyone but me? Can you determine what value I should enter for Workspace on the login screen?

        Thank you.
        Steve
        • 16. Re: Invalid login credentials for APEX though I can connect with SQL PLUS
          872796
          I made some PROGRESS, but still stuck.

          Earlier in this thread I told how I changed the where clause because it found no data for "STEVE" and it finally dawned on me - I had been running this from within the APEX environment and maybe I need to run it from SQLPLUS - true or false?

          I did not want to have to type all that code into the SQL Comand line and it is like a DOS window so I could not paste into it, but I released I could save it with Notepad as a text file, then run it from the SQL command line with "@ myfilename" and it ran ok - said "SQL Procedure successfully completed".

          So this told me that "STEVE" was found in apex_workspaces table.

          So 1 step forward, but after that I went back into Oracle as syste using the menu for "Get Started" which opens my web browser at 127.0.0.1 ... etc and I log in as SYSTEM.
          It takes me to the first screen where I can create a new user but I chose the "Already have an account" button and still cannot log into that page using ADMINUSERS as bith the workspace and username and ADMIN for the password.

          So this is the same result I was having and I am still not sure if it makes any difference if the SQL with the APEX_UTIL.CREATE_USER is run from SQLPLUS or from the webpage? The only difference is that in SQLPLUS it was able to find the workspace = 'STEVE'

          Please advise, thank you.
          Steve
          • 17. Re: Invalid login credentials for APEX though I can connect with SQL PLUS
            872796
            I got it to work !!!
            I changed the workplace for ADMINUSERS to STEVE, which should have obvious to me ..... Duhhhhhhh

            I will mark this as answered later - if anyone can answer my 3 quick remaining questions:
            1. does it matter if I run the script to create ADMINUSERS from sqlplus or from within the SQL worksop in APEX?
            2. I have no idea how this happened - can anyone make a wild guess on how or why my original STEVE User got wiped out in APEX? I still cannot use that userid but the big thing is that when I login as ADMINUSERS and go to SQL commands, all 40 or so SQL programs I have under Steve are now there as I hoped.
            3. When I log in as System to the database and instead of going into APEx I try to go into Workspace Administration I can never login no matter which user ID I use, whether system, sys, ADMINUSERS, Steve - I get invalid login credentials. Not that I need to do this now, but I may need it some time, and still do not know how to get in, even though I give valid database or valid APEX userid and password.

            Thank you all who have responded to me.
            • 18. Re: Invalid login credentials for APEX though I can connect with SQL PLUS
              872796
              A few informational questions are listed in my previous post, but the problem has been resolved so I am making this question as answered
              • 20. Re: Invalid login credentials for APEX though I can connect with SQL PLUS
                Jeff E
                1-- Run from SQLPlus as an system user otherwise the first query may not get the full list workspaces.

                2-- Too many guesses to choose from. When you log into the workspace go to the Workspace Administration pages and see if the original user is still there and reset the password or unlock if needed.

                3-- If you are referring to the APEX Workspace Administration login then the username is usually "admin" and the password is the password you used when installing the database. (if workspace is being asked for it is "INTERNAL").
                1 2 Previous Next