10 Replies Latest reply: Oct 24, 2012 3:38 AM by Greig RSS

    Install UPK 11.1 fails

    FrankieM
      Hi,

      My fresh install of UPK 11.1 Prof is failing. The database is running fine on OEL 5U7 64 bits. The application is on W2K8 R2 SP1. Both OS's are default made in virtualbox.
      The database connection seems to work fine. The wizard has installed all the database objects.
      The W2K8 server has the roles "File Services" and "Web Server (IIS)". An application pool (ODDevAppPool) and site (ODSContent) is made.

      It fails after that. The logfiles are below, first Install20120413.log then LibraryLoader20120413.log.
      Does anybody have the same experience and hopefully the solution ? I aleady tried the solution in note 1446303.1 by enabling 32 bits for the application pool with no succes.

      Regards,

      Frank


      Install20120413.log :

      Installation Starts

      Microsoft .NET Framework 4.0: already installed

      Windows Installer 3.1: already installed

      Windows Process Activation Service (WAS): already enabled

      World Wide Web Publishing: already enabled

      Call:[GetWinAcctInfo]
      Call:[CheckFolderPermission]
      Call:[CheckFolderPermission]
      Call:[CheckLocalGroupsForUser]
      Call:[CheckLocalGroupsForUser]
      Call:[CheckLocalGroupsForUser]
      Call:[CheckLocalGroupsForUser]
      Call:[CheckLocalGroupsForUser]
      Call:[CheckLocalGroupsForUser]
      C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll: enabled successfully

      ODSContent: configured successfully

      ODSContent: default documents applied successfully

      ODSContent: authentication applied successfully

      Encountered a problem while populating the library. Error code: 1.
      Installation Complete

      LibraryLoader20120413.log :

      2012-04-13 08:14:05 INFO Application started
      2012-04-13 08:14:05 INFO Command line: C:\app\oracle\upk\LibraryLoader.exe C:\app\upk-install\UPK_Pro_v11.1.0 "/librarylocation:http://w1001:80/ODSContent" /language:EN /producttier:Server /branding:UPK /overwrite:no /update:no /authenticationtype:standard /username:"admin" /password:***
      2012-04-13 08:14:05 INFO Source path: C:\app\upk-install\UPK_Pro_v11.1.0
      2012-04-13 08:14:05 INFO Library location: http://w1001:80/ODSContent
      2012-04-13 08:14:05 INFO Language: EN
      2012-04-13 08:14:05 INFO Product tier: Server
      2012-04-13 08:14:05 INFO Branding: UPK
      2012-04-13 08:14:05 INFO Overwrite: False
      2012-04-13 08:14:05 INFO English only: False
      2012-04-13 08:14:05 INFO Options:
      2012-04-13 08:14:05 INFO Import system documents: True
      2012-04-13 08:14:05 INFO Copy files: True
      2012-04-13 08:14:05 INFO Authenticate only: False
      2012-04-13 08:14:05 INFO Authentication type: standard
      2012-04-13 08:14:05 INFO User name: admin
      2012-04-13 08:14:05 INFO Password: ***
      2012-04-13 08:14:05 INFO Update: False
      2012-04-13 08:14:09 INFO Loading documents in Server - Client environment
      2012-04-13 08:14:09 INFO Authenticate by standard authentication
      2012-04-13 08:14:12 ERROR Gkn.OnDemand.Library.OfflineException:
      at Gkn.OnDemand.Library.LibraryComponent.AuthenticateProfile(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 388 at Gkn.OnDemand.Library.LibraryComponent.Run(String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 309 at Gkn.OnDemand.ComponentModel.ApplicationCore.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\AppCore.cs:line 154 at Gkn.OnDemand.ComponentModel.Application.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\Application.cs:line 538
      InnerException:
      Gkn.OnDemand.Library.LibraryConnectionException: There is a problem with the server configuration. See your system administrator with the following information.
      at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 98 at Gkn.OnDemand.Library.LibraryService.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryService.cs:line 290 at Gkn.OnDemand.Login.LoginService.Authenticate(IUserProfile userProfile, Boolean login) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 183
      InnerException:
      Gkn.OnDemand.Library.LibraryConnectionException: There is a problem with the server configuration. See your system administrator with the following information.
      at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetUserSalt(String userName, String libraryLocation) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 157 at Gkn.OnDemand.Library.LibraryService.GetUserSalt(String userName, String libraryLocation) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryService.cs:line 350 at Gkn.OnDemand.Login.LoginService.AssignCredentials[TChannel](ClientBase`1 proxy, IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 408 at Gkn.OnDemand.Login.LoginService.AuthenticateWCF[TChannel](ClientBase`1 proxy, IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 319 at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetProxy(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 46 at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 91
      InnerException:
      System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Exception has been thrown by the target of an invocation.
      Server stack trace: at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter) at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Gkn.OnDemand.Service.Content.RepositoryServiceReference.IRepositoryService.GetUserSalt(String userName) at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetUserSalt(String userName, String libraryLocation) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 153

      2012-04-13 08:15:44 INFO Application started
      2012-04-13 08:15:44 INFO Command line: C:\app\oracle\upk\LibraryLoader.exe C:\app\upk-install\UPK_Pro_v11.1.0 "/librarylocation:http://w1001:80/ODSContent" /language:NL /producttier:Server /branding:UPK /overwrite:no /update:no /authenticationtype:standard /username:"admin" /password:***
      2012-04-13 08:15:44 INFO Source path: C:\app\upk-install\UPK_Pro_v11.1.0
      2012-04-13 08:15:44 INFO Library location: http://w1001:80/ODSContent
      2012-04-13 08:15:44 INFO Language: NL
      2012-04-13 08:15:44 INFO Product tier: Server
      2012-04-13 08:15:44 INFO Branding: UPK
      2012-04-13 08:15:44 INFO Overwrite: False
      2012-04-13 08:15:44 INFO English only: False
      2012-04-13 08:15:44 INFO Options:
      2012-04-13 08:15:44 INFO Import system documents: True
      2012-04-13 08:15:44 INFO Copy files: True
      2012-04-13 08:15:44 INFO Authenticate only: False
      2012-04-13 08:15:44 INFO Authentication type: standard
      2012-04-13 08:15:44 INFO User name: admin
      2012-04-13 08:15:44 INFO Password: ***
      2012-04-13 08:15:44 INFO Update: False
      2012-04-13 08:15:47 INFO Loading documents in Server - Client environment
      2012-04-13 08:15:47 INFO Authenticate by standard authentication
      2012-04-13 08:15:51 ERROR Gkn.OnDemand.Library.OfflineException:
      at Gkn.OnDemand.Library.LibraryComponent.AuthenticateProfile(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 388 at Gkn.OnDemand.Library.LibraryComponent.Run(String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 309 at Gkn.OnDemand.ComponentModel.ApplicationCore.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\AppCore.cs:line 154 at Gkn.OnDemand.ComponentModel.Application.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\Application.cs:line 538
      InnerException:
      Gkn.OnDemand.Library.LibraryConnectionException: There is a problem with the server configuration. See your system administrator with the following information.
      at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 98 at Gkn.OnDemand.Library.LibraryService.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryService.cs:line 290 at Gkn.OnDemand.Login.LoginService.Authenticate(IUserProfile userProfile, Boolean login) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 183
      InnerException:
      Gkn.OnDemand.Library.LibraryConnectionException: There is a problem with the server configuration. See your system administrator with the following information.
      at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetUserSalt(String userName, String libraryLocation) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 157 at Gkn.OnDemand.Library.LibraryService.GetUserSalt(String userName, String libraryLocation) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryService.cs:line 350 at Gkn.OnDemand.Login.LoginService.AssignCredentials[TChannel](ClientBase`1 proxy, IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 408 at Gkn.OnDemand.Login.LoginService.AuthenticateWCF[TChannel](ClientBase`1 proxy, IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 319 at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetProxy(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 46 at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 91
      InnerException:
      System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Exception has been thrown by the target of an invocation.
      Server stack trace: at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter) at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Gkn.OnDemand.Service.Content.RepositoryServiceReference.IRepositoryService.GetUserSalt(String userName) at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetUserSalt(String userName, String libraryLocation) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 153
        • 1. Re: Install UPK 11.1 fails
          Greig
          Hi Frankie,

          Do you have any proxy's running between the two VM's?
          Just test your IIS config, and make sure that you can use it correctly to preview webpages etc. You could use a test.htm file that you create to test IIS and ensure that it is working correctly.

          You need to ensure that you are pointing to the correct web server when testing - if there are proxy's in place, it could cause issues for you if not correctly configured on your UPK environment.

          Thats all I can really find for you - I hope it may help somewhat.

          Regards,
          Greig
          • 2. Re: Install UPK 11.1 fails
            FrankieM
            Hi Greig,

            No i don't have any proxy's running or configured. I have a host only network. Both servers can see each other. Nothing strange.
            I already tested my IIS with a htm and it is working properly.

            Regards Frank
            • 3. Re: Install UPK 11.1 fails
              Greig
              Hi Frank,

              Ok, so you are using Standard Authentication - thats perfect - is your "admin" password definitely 3 characters long? Ensure that it is correct.
              Are you using SQL server or Oracle DB?

              One thing I have noticed - on the first run of errors, the Language is set to EN, and the second run is set to NL - are there any changes you can make to align these?

              regards,
              Greig
              • 4. Re: Install UPK 11.1 fails
                FrankieM
                Hi Greig,

                I used "admin" also as the password (admin/admin) to keep it simple. I is just a test installation. I just tried it with another password. Same result.

                The different languages are correct. I first tried it with Dutch. When that didn't worked, i tried to use English with te same effect. Every attempt, i try to clean my environment.

                Regards,

                Frank
                • 5. Re: Install UPK 11.1 fails
                  FrankieM
                  Hi,

                  I did some more investigation. I wiped my window server, so i had a clean situation. Because i'm running 64 bits W2K8 R2 SP1, i followed note 795602.1 to install both 32 and 64 bits Oracle client. I tested the ODBC and ODP connections (note 760958.1). Everything works fine. I reinstalled the english version of UPK, but the problem still persists.

                  However, if i go http://server/ODSContent, i get the error message HTTP 500.19, "'oracle.dataaccess.client' cannot be read because it is missing a section declaration". It looks like web.config is not configured rightly by the wizard.

                  Any idea's ?

                  Regards,

                  Frank
                  • 6. Re: Install UPK 11.1 fails
                    FrankieM
                    Hi,

                    I'm one step further. I had to set some application defaults in IIS : .Net Framework version -> 4.0 and enable 32 bit applications -> TRUE.
                    Now i have another error message. I'm getting desperate and i'm wondering if somebody did install UPK 11.1 successfully.

                    I'm making a SR. See if they can help me.

                    Frank
                    • 7. Re: Install UPK 11.1 fails
                      Greig
                      Hi Frank,

                      Thanks for the update - I hope that they can sort you out.

                      It seems that .Net Framework 4 seems to be popping up here. As far as I can understand, UPK 11 is only compatible with .Net Framework 3.5, I am not sure if you may find that .Net Framework 4 is to blame... I hope that the SR is able to resolve your issue. I am sorry that I cannot assist further - I do not want to provide you with incorrect information or guesses!

                      Let me know if there is anything else I can assist with.

                      Regards,
                      Greig
                      • 8. Re: Install UPK 11.1 fails
                        FrankieM
                        Hi Greig,

                        The .Net version is confusing. According the prerequisites, it should be 3.5. According the installation wizard and the installation manual it has to be 4.0. It won't work without 4.0. I tried that (.Net 3.5) already. This applies to 11.1. Maybe not to 11.0. So i think, this is a documentation error in the prereqs.

                        Regards,

                        Frank
                        • 9. Re: Install UPK 11.1 fails
                          656825
                          Not a helpful answer but just to throw in my 5 cents: I couldn't install the latest version on Win 7 (which was not certified at the time of trying either).
                          Furthermore (but looking at previous posts it isn't the problem I guess), you must be administrator/root of the machine to install the UPK.
                          • 10. Re: Install UPK 11.1 fails
                            Greig
                            Hi Frankie,

                            I know it has been a while since this thread was replied on, but I came across the exact same issue, but it was withing the developer itself when attempting to add a new profile.
                            The issue was with the connection string within the web.conf file.

                            I had recent move some of my virtual servers to a different subset of ip addresses - and this included my UPK 11.1 database (resides on a different linux vm compared to my UPK server). Not thinking, I assumed the only changes required would be the library location defined in IIS, but I forgot about the web.conf settings (palm-on-face moment for me...)

                            What I did:
                            1. Got error when attempting to add a new profile. Could also not get onto the existing library to access existing content. I got the same error as you.

                            2. I decrypted the "connectionString" tag in the web.conf file (web.conf will be in the Repository.WCF folder under the UPK11Server folder in Program Files x86 - in my case C:\Program Files (x86)\User Productivity Kit\UPK Developer 11_1Server\Repository.WCF). You decrypt the web.conf connectionString tag by running aspnet_regiis (can be located under C:\Windows\Microsoft.NET\Framework\v4.0.30319 - or whatever version of .Net Framework you are using) and do the following:
                            a) Open cmd and navigate to location where aspnet_regiis resides
                            b) Type in the following: aspnet_regiis -pd "connectionStrings" -app "/ODSContent" where /ODSContent is your library location (I used defaults when I did the install).
                            c) You should see a message saying "successful" - if not, check your parameters - you can get more info on this in UPK doco.

                            3. Open web.conf and review the connectionStrings section - my address for the DB was incorrect. I modified the ip address, and then saved the changes.
                            4. Once saved, re-encrypt the web.conf file by executing the following: aspnet_regiis -pe "connectionStrings" -app "/ODSContent"

                            Try connect again and you should be 100% good to go.
                            Hope this helps!

                            Regards,
                            Greig