This discussion is archived
13 Replies Latest reply: Apr 18, 2012 2:30 PM by 931474 RSS

After AppsTier cloning OC4J throwing error during startup

931474 Newbie
Currently Being Moderated
Hi guys,

We completed the post clone process. Then mid tier service throwing error during startup. The error like,

adoacorectl.sh: exiting with status 204
adformsctl.sh: exiting with status 204
adoafmctl.sh: exiting with status 204


Log file for your reference:
=================

--------
12/04/18 04:54:26 Start process
--------
0.576: [GC 16448K->2064K(62848K), 0.0062840 secs]
2012-04-18 04:54:27.115 INFO Debug level set by -Dquest.debug=0
0.983: [GC 18512K->2645K(79296K), 0.0069710 secs]
2012-04-18 04:54:27.518 FATAL Could not load performasure-bootstrap.properties;
Please ensure that the PreInstrumentor has been run on the current Java VM

--------
12/04/18 04:54:28 Start process
--------
0.606: [GC 16448K->2080K(62848K), 0.0056600 secs]
2012-04-18 04:54:28.834 INFO Debug level set by -Dquest.debug=0
0.996: [GC 18528K->2653K(62848K), 0.0065850 secs]
2012-04-18 04:54:29.231 FATAL Could not load performasure-bootstrap.properties;
Please ensure that the PreInstrumentor has been run on the current Java VM

--------
12/04/18 04:54:30 Start process
--------
0.522: [GC 16448K->2080K(62848K), 0.0050740 secs]
2012-04-18 04:54:30.733 INFO Debug level set by -Dquest.debug=0
0.899: [GC 18528K->2669K(62848K), 0.0067450 secs]
2012-04-18 04:54:31.134 FATAL Could not load performasure-bootstrap.properties;
Please ensure that the PreInstrumentor has been run on the current Java VM



Please anybody guide me for solve this issue.


Thanks,
Muthu
  • 1. Re: After AppsTier cloning OC4J throwing error during startup
    Helios-GunesEROL Oracle ACE
    Currently Being Moderated
    Hi;

    Please see:
    adapcctl.sh: exiting with status 204
    adapcctl.sh: exiting with status 204

    Regard
    Helios
  • 2. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi,

    But we didn't get any error in apache service during mid tier startup.





    Thanks,
    Muthu

    Edited by: Muthu_oraapps on Apr 18, 2012 7:04 PM
  • 3. Re: After AppsTier cloning OC4J throwing error during startup
    EBSDBA Expert
    Currently Being Moderated
    Hi,

    Try to stop the application and start again.

    If .lock files exist in the following locations, please remove them

    $INST_TOP/ora/10.1.3/j2ee/forms/persistence/forms_default_group_1/
    $INST_TOP/ora/10.1.3/j2ee/oacorepersistence/oacore_default_group_1/
    $INST_TOP/ora/10.1.3/j2ee/oafm/persistence/oafm_default_group_1/


    Thanks
  • 4. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi,

    Thanks,

    I bounced the mid tier service.

    The " persistence" folder is not there in below mentioned location,

    $INST_TOP/ora/10.1.3/j2ee/forms/
    $INST_TOP/ora/10.1.3/j2ee/oacore/
    $INST_TOP/ora/10.1.3/j2ee/oafm/


    Please guide me...


    Thanks,
    Muthu

    Edited by: Muthu_oraapps on Apr 18, 2012 7:46 PM

    Edited by: Muthu_oraapps on Apr 18, 2012 7:47 PM
  • 5. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi Mate,

    please find the adoacorectl.sh log file below for your reference,

    adoacorectl. txt file contents:

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    opmnctl: starting opmn managed processes...
    ================================================================================
    opmn id=ebs.grup.com:6205
    0 of 1 processes started.

    ias-instance id=eb11_ebs.ebs.grup.com
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    --------------------------------------------------------------------------------
    ias-component/process-type/process-set:
    default_group/oacore/default_group/

    Error
    --> Process (index=1,uid=201070982,pid=7091)
    failed to start a managed process after the maximum retry limit
    Log:
    /eb11/apps/inst/apps/eb11_ebs/logs/ora/10.1.3/opmn/default_group~oacore~default_group~1.log


    default_group~oacore~default_group~1.log file

    12/04/17 22:25:51 WARNING: ApplicationLogManager is not installed, may result in loader leaks. Set -Djava.util.logging.manager=oracle..classloader.util.ApplicationLogManager
    2012-04-17 22:25:51.913 INFO Debug level set by -Dquest.debug=0
    1.054: [GC 32768K->2797K(125632K), 0.0120320 secs]
    2012-04-17 22:25:52.425 FATAL Could not load performasure-bootstrap.properties;
    Please ensure that the PreInstrumentor has been run on the current Java VM


    Thanks,
    Muthu

    Edited by: Muthu_oraapps on Apr 18, 2012 9:04 PM

    Edited by: Muthu_oraapps on Apr 18, 2012 9:39 PM

    Edited by: Muthu on Apr 19, 2012 11:31 AM
  • 6. Re: After AppsTier cloning OC4J throwing error during startup
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    Please post the details of the application release, database version and OS.
    12/04/17 22:25:51 WARNING: ApplicationLogManager is not installed, may result in loader leaks. Set -Djava.util.logging.manager=oracle..classloader.util.ApplicationLogManager
    This can be ignored -- WARNING: ApplicationLogManager is not installed, may result in loader leaks [ID 1297146.1]
    2012-04-17 22:25:52.425 FATAL Could not load performasure-bootstrap.properties;
    Please ensure that the PreInstrumentor has been run on the current Java VM
    Did AutoConfig complete successfully? Can you please upload the postclone log file?

    Thanks,
    Hussein
  • 7. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi Hussein,

    Thanks for metalink note id

    Autoconfig completed successfully in both tiers.

    Could you please explain clearly we didn't understand the post clone log file, You mean ApplyDbstack.log file.



    We have another doubt,

    Actually we took midtier backup in 32 bit OS and then we moved that backup and cloned in 64 bit OS. It was affect anything during clone.

    Kindly please guide me.


    Thanks,
    Muthu

    Edited by: Muthu_oraapps on Apr 18, 2012 9:39 PM

    Edited by: Muthu on Apr 19, 2012 12:38 AM
  • 8. Re: After AppsTier cloning OC4J throwing error during startup
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    Could you please explain clearly we didn't understand the post clone log file, You mean ApplyDbstack.log file.
    The main log file -- Troubleshooting RapidClone issues with Oracle Applications R12 [ID 603104.1] -- Section 6: Configuring the Target System
    Actually we took midtier backup in 32 bit OS and then we moved that backup and cloned in 64 bit OS. It was affect anything during clone.
    No.

    FAQ: Cloning Oracle Applications Release 11i [ID 216664.1] -- 13. Can I clone from one operating system version to another?

    Thanks,
    Hussein
  • 9. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi Hussein,

    Many thanks for your response and metalink note id. I got some ideas from metalink id as you mentioned.

    Now I clearly explain our scenario:

    We took backup in below mentioned sever configuration,

    Source system of Apps Tier is *32 bit*
    Source system of DB Tier is *32 bit*

    We moved backup and cloned in below mentioned server configuration,

    Target system of Apps Tier is *64 bit*
    Target system of DB Tier is *32 bit*


    whether the clone is possible DB tier in 32 bit and Apps Tier in 64 bit from above source..?

    Kindly guide me please.


    Thanks,
    Muthu

    Edited by: Muthu on Apr 19, 2012 1:30 AM

    Edited by: Muthu on Apr 19, 2012 1:31 AM

    Edited by: Muthu on Apr 19, 2012 1:54 AM
  • 10. Re: After AppsTier cloning OC4J throwing error during startup
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    whether the clone is possible DB tier in 32 bit and Apps Tier in 64 bit from above source..?
    It is possible but I would not recommend this configuration as you need more memory for the database (to set SGA for a value greater than 4GB).

    Thanks,
    Hussein
  • 11. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi Hussein,

    Thanks lot for your information,


    Actually we done the cloning in below mentioned manner,

    DB tier in 32 bit OS.
    Apps Tier in 64 bit OS.

    After we brought up the mid service that time we got error like,

    adoacorectl.sh existing with status 240.
    adoafmctl.sh existing with status 240.
    adformsctl.sh existing with status 240.

    Then we got some basic information from metalink note id as you given.


    Now we following 471566.1 metalink document and we are doing Post-Migration steps that is given by 471566.1 note id.

    Could you please given some metalink note id or documents or web link that is related to our issue and kindly confirm me whether we following is a right way or not.


    Thanks,
    Muthu
  • 12. Re: After AppsTier cloning OC4J throwing error during startup
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    After you complete the post migration steps, run AutoConfig and make sure it completes successfully then bring the services up. If you still have an issue, please check the log files for details about the error.

    Thanks,
    Hussein
  • 13. Re: After AppsTier cloning OC4J throwing error during startup
    931474 Newbie
    Currently Being Moderated
    Hi Hussien,

    Sure, If we face any issue during the post migration then we will post that errors and log files for your reference. Kindly guide me.

    Many thanks for your response.


    Thanks,
    Muthu

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points