2 Replies Latest reply: Apr 19, 2012 10:29 PM by 671603 RSS

    SOA 11g B2B - File is not getting Picked up from Input Directory

    671603
      Hi All,

      Greetings to all B2B Gurus.

      We are currently migrating all our EDI customers to SOA 11g and have created the Trading Partner Setups in 11g B2B. While testing the setups, i have placed the input file in the directory but the file is not getting picked up from the Input directory, Please find the setup details and the B2B log details below.

      1. I have created a B2B Setup for Inbound PO and Transport Protocol is using FTP Adapter. I have also created the input directory in SOA B2B instance and it has 777 permission.
      2. Please find the B2B Log details below. I have used Input directory as /opt101/app/SOAD/soa_files/Inbound_Input_Files but the error is showing some other directory which we never used in any of the Trading Partner setups.

      This is the error I am seeing in logs
      "[2012-04-16T00:54:11.219-04:00] [soa_server1] [NOTIFICATION] [] [oracle.soa.b2b.ui] [tid: [ACTIVE].ExecuteThread: '6' for queue: 'weblogic.kernel.Default (se
      lf-tuning)'] [userId: weblogic] [ecid: 000002Sw2C1AxGH_utc9yX01J02q0006J^,0:1] [APP: b2bui] [URI: /b2bconsole/faces/mainSummary.jspx] ### Has Admin Permissio
      n ###
      [2012-04-16T00:54:15.864-04:00] [soa_server1] [NOTIFICATION] [] [oracle.soa.adapter] [tid: weblogic.work.j2ee.J2EEWorkManager$WorkWithListener@61386138] [use
      rId: <anonymous>] [ecid: 0000JQ_KX15AxGH_utc9yX1FXbh^000001,0] [APP: soa-infra] File Adapter ReadCSVTEST Recovery still not possible after 33810 attempts due
      to BINDING.JCA-11001[[
      Invalid Input Directory.
      Invalid Input Directory.
      The value specified for the input (Physical/Logical)Directory activation parameter has an invalid value "/opt101/app/SOAD/soa_files/in".
      Ensure that the following conditions are satisfied for the input directory :
      1) It exists and is a directory (not a file). and
      2) It is readable (file read permissions). and
      3) If activation parameter "DeleteFile" is set to "true" then the directory should also have granted write permissions. and
      4) If using a logical name, then ensure that the mapping from logical name<->physical directory is correctly specified in the deployment descriptor.

      3. Could you please let me know whether we need to enable any Protocol properties in order to pick the file?

      Thanks in Advance for your help.

      Thanks,
      Saravana