2 Replies Latest reply on Apr 24, 2012 7:04 PM by 932121

    can not make integrated weblogic server work

      After installation of Jdeveloper, I ran "Test Connection" for IntegratedWeblogicServer and got the following error. What did I miss? Thanks in advance.

      Testing JSR-160 Runtime ... failed
      Cannot establish connection.
      Testing JSR-160 DomainRuntime ... skipped
      Testing JSR-88 ... skipped
      Testing JSR-88-LOCAL ... skipped
      Testing JNDI ... skipped
      Testing JSR-160 Edit ... skipped
      Testing HTTP ... failed
      Unable to open conection: Connection refused: connect
      Testing Server MBeans Model ... skipped
      Testing App Controller ... success

      1 of 9 tests successful.
        • 1. Re: can not make integrated weblogic server work
          I deleted C:\Documents and Settings\me\Application Data\JDeveloper\system11. and re-ran JDev. I got

          [Waiting for the domain to finish building...]
          [10:08:48 AM] Creating Integrated Weblogic domain...
          [10:09:53 AM] Extending Integrated Weblogic domain...
          [10:10:31 AM] Integrated Weblogic domain processing completed successfully.
          *** Using HTTP port 7101 ***
          *** Using SSL port 7102 ***
          "C:\Documents and Settings\da.huang\Application Data\JDeveloper\system11.\DefaultDomain\bin\startWebLogic.cmd"
          The system cannot find the path specified.
          [waiting for the server to complete its initialization...]
          JAVA Memory arguments:
          WLS Start Mode=Development
          PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Intel\DMIX;C:\Program Files\ATI Technologies\ATI.ACE\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\ActivIdentity\ActivClient\;C:\Program Files\Symantec.cloud\PlatformAgent;C:\Program Files\Symantec.cloud\PlatformAgent\;C:\WINDOWS\system32\WindowsPowerShell\v1.0;
          * To start WebLogic Server, use a username and *
          * password assigned to an admin-level user. For *
          * server administration, use the WebLogic Server *
          * console at http:\\hostname:port\console *
          starting weblogic with Java version:
          The system cannot find the path specified.
          The system cannot find the path specified.
          Starting WLS with line:
          \bin\java -Dweblogic.Name= -Djava.security.policy=\server\lib\weblogic.policy -Djavax.net.ssl.trustStore=C:\DOCUME~1\DAD316~1.HUA\LOCALS~1\Temp\trustStore2899955233655330998.jks -Doracle.jdeveloper.adrs=true -Dweblogic.nodemanager.ServiceEnabled=true
          Process exited.

          It seems to me that Default Domain can not find the path C:\Oracle\Middleware\jdk160_24. But it was set to be defaultDomain's path at installation. Any idea?
          • 2. Re: can not make integrated weblogic server work
            I figured it out.

            In .../DefaultDomain/bin folder, there are two files startWebLogic.cmd and setDomainEnv.cmd containing lines:
            set DOMAIN_HOME=C:\Documents and Settings\user\Application Data\JDeveloper\system11.\DefaultDomain
            for %%i in ("%DOMAIN_HOME%") do set DOMAIN_HOME=%%~fsi
            If you echo %DOMAIN_HOME%, you may find 10 characters added to this path. In this case, you need to add
            set DOMAIN_HOME=%DOMAIN_HOME:~0,-10%
            to remove those meaningless 10 characters out from DOMAIN_HOME. Then select "Start Server Instance (IntegratedWeblogicServer)" to run the server.