This discussion is archived
7 Replies Latest reply: Apr 21, 2012 2:41 AM by 911987 RSS

SqlDeveloper ORA-12705

Rudi Newbie
Currently Being Moderated
Hi
I get ORA-12705 when accessing a 10.2.0.5 database.
When I connect using a Sqlplus client (from the same PC) ,it connects without any issues.
Any ideas what to check?
Thanks,
Rudi
  • 1. Re: SqlDeveloper ORA-12705
    Gary Graham Expert
    Currently Being Moderated
    Hi Rudi,

    If you search the forum, the standard workaround for this seems to be:
    Try to add following lines to %SQL_DEV_HOME%\sqldeveloper\bin\sqldeveloper.conf
    AddVMOption -Duser.language=en
    AddVMOption -Duser.country=US
    You did not say which version of SQL Developer you use, but if it is extremely out-of-date that could also be the issue. Upgrade to latest.

    Regards,
    Gary
    SQL Developer Team
  • 2. Re: SqlDeveloper ORA-12705
    Rudi Newbie
    Currently Being Moderated
    Hi
    Thanks for the reply.
    The SqlDeveloper is 3.1.07.
    Nevertheless,I will try the workaround
    Rudi
  • 3. Re: SqlDeveloper ORA-12705
    Rudi Newbie
    Currently Being Moderated
    Hi Gary
    Your workaround is working.I was wondering if you can suggest a permanent solution
    Thanks a lot,
    Rudi
  • 4. Re: SqlDeveloper ORA-12705
    Gary Graham Expert
    Currently Being Moderated
    Rudi,

    You may want to review the advice in the following non-forum link:
    http://www.dba-oracle.com/t_ora_12705_resolution.htm

    The gist of it: your environment probably contains an NLS_LANG variable value which, relative to the database, contains an invalid language, territory, or character set. The workaround you had success with just overrides any such "invalid" values with values so common that the database installation is almost certain to include them.

    Something similar can happen with timezone settings. Sometimes the database doesn't "know" about all possible timezone values. In both cases, you must either give the database something it understands, or else correct the database installation.

    Cheers,
    Gary
  • 5. Re: SqlDeveloper ORA-12705
    Rudi Newbie
    Currently Being Moderated
    Hi Gary
    We encounter this problem time and time again.Now we hit this with Oracle Jdeveloper 10.3.X
    The workaround which you provided is working fine,but we would like to have a deeper understanding of the problem so maybe we can fix it permanently.
    This is especially critical for us,since we use IW8MSWIN1255 as the db character-set.
    Btw, can this be related to character-set migration which we did on the db?
    Thanks for your help and assistance
    Rudi
  • 6. Re: SqlDeveloper ORA-12705
    Gary Graham Expert
    Currently Being Moderated
    Hi Rudi,

    This is not my area so I will defer to others but, from what I have read, the problem is most likely with your Windows registry settings. Perhaps if you review this link (referenced in the link I provided earlier)...
    http://www.dba-oracle.com/t_ora_12705_error.htm

    and do the suggested comparison of database environment parameters with Windows registry values that will provide more insight.

    Also, user orafad provides some additional information in links referenced in this thread from the Database -> Globalization Support forum, a much better forum on which to ask this type of question:
    Re: Languages supported for IW8ISO8859P8

    Hope this helps,
    Gary
  • 7. this decision works Re: SqlDeveloper ORA-12705
    911987 Newbie
    Currently Being Moderated
    Hello,

    Just have encountered same problem and managed to solve it the way Gary described.

    Platform: Windows 7
    Regional settings: location Russia, language Russian.

    Oracle Database XE 11.2.0 for Win 32
    SQL Developer 3.1 with JDK1.6.0_11

    SQL*Plus works, however SQL Developer does not. While trying to create a new connection or to open an Auto-Generated Local Connection the ORA-12705 error arises.

    After adding in the %SQL_DEV_HOME%\sqldeveloper\bin\sqldeveloper.conf file two lines:
    AddVMOption -Duser.language=en
    AddVMOption -Duser.country=US

    SQL Developer works properly.

    Thanks!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points