This discussion is archived
2 Replies Latest reply: May 7, 2012 12:43 AM by user54461 RSS

no hardware info is available for drive x - device is not in service

user54461 Newbie
Currently Being Moderated
Hi everybody,
I'm new in Oracle secure Backup.
I have configured osb; one Lib with 2 Tape.. and oracle backup with rman.
I don't know why the backup are pending and in device have this error:

ob> lsdev -lg
cLib1:
Device type: library
Model: [none]
Serial number: 00X4U78P2318_LL0
In service: yes
Debug mode: no
Barcode reader: yes
Barcodes required: yes
Auto clean: no
Clean interval: (not set)
Clean using emptiest: no
Unload required: yes
Ejection type: auto
Min writable volumes: 0
UUID: 135995b6-af87-102e-8e55-14feb5d265f9
Attachment 1:
Host: cgtccmgmt.cc.local
Raw device: /dev/sg2
Connection type: SCSI
Inquiry data:
Vendor: IBM
Product: 3573-TL
Firmware: A.50
Serial number: 00X4U78P2318_LL0
Element counts / addresses:
1 mte: 1
45 se : 4096 - 4140
3 iee: 16 - 18
2 dte: 256 - 257
Moves:
From mte, to: mte 0 se 1 iee 1 dte 1
From se, to: mte 0 se 1 iee 1 dte 1
From iee, to: mte 0 se 1 iee 1 dte 1
From dte, to: mte 0 se 1 iee 1 dte 1
Ok_ops: move=1, reserve=1 sense_dev=1, sense_ele=1, unload_any=1, sense_dev_range=1
Device characteristics: two_d=0, is_120=0, fake_mte=1, fake_iee=0, one_target=0
State of barcode reader: present
Display: none
Dte 1: target * lun * name cTape1 (raw device name /dev/sg1)
Dte 2: target * lun * name cTape2 (raw device name /dev/sg3)
Warning: bus info unknown or drive not installed
RGB(0x00,0x00,0x00)
cTape1:
Device type: tape
Model: [none]
Serial number: 1068003728
In service: no (auto)
Not in service reason: Oracle Secure Backup encountered a problem while trying to run
job 1382.1 with this device. Though the job is retryable
immediately, the device has been marked 'not in service'. It will
remain so for 3 minutes or until the operator manually
places it in service.
Auto in service time: 04/23.11:41
Library: cLib1
DTE: 1
Automount: yes
Error rate: 8
Query frequency: [undetermined]
Debug mode: yes
Blocking factor: (default)
Max blocking factor: (default)
Current tape: 30
Use list: all
Drive usage: 26 seconds
Cleaning required: no
UUID: bccd5246-747b-102e-a4b6-14feb5d265f9
Attachment 1:
Host: cgtccmgmt.cc.local
Raw device: /dev/sg1
Connection type: [unknown]
Inquiry data:
Vendor: IBM
Product: ULT3580-HH4
Firmware: B171
Serial number: 1068003728
Hardware compression: not available
Hardware encryption: not available
Warning: no hardware info is available for drive cTape2 - device is not in service
cTape2:
Device type: tape
Model: [none]
Serial number: 1068003531
In service: no (auto)
Not in service reason: Oracle Secure Backup encountered a problem while trying to run
job 1379.1 with this device. Though the job is retryable
immediately, the device has been marked 'not in service'. It will
remain so for 3 minutes or until the operator manually
places it in service.
Auto in service time: 04/23.11:41
Library: cLib1
DTE: 2
Automount: yes
Error rate: 8
Query frequency: [undetermined]
Debug mode: no
Blocking factor: (default)
Max blocking factor: (default)
Current tape: 23
Use list: all
Drive usage: 18 seconds
Cleaning required: no
UUID: 10c988a6-747c-102e-a4b6-14feb5d265f9
Attachment 1:
Host: cgtccmgmt.cc.local
Raw device: /dev/sg3
Connection type: [unknown]
Inquiry data:
Vendor: IBM
Product: ULT3580-HH4
Firmware: B171
Serial number: 1068003531
Hardware compression: not available
Hardware encryption: not available

cTape1:
Device type: tape
Model: [none]
Serial number: 1068003728
In service: no (auto)
Not in service reason: Oracle Secure Backup encountered a problem while trying to run
job 1382.1 with this device. Though the job is retryable
immediately, the device has been marked 'not in service'. It will
remain so for 3 minutes or until the operator manually
places it in service.
Auto in service time: 04/23.11:41
Library: cLib1
DTE: 1
Automount: yes
Error rate: 8
Query frequency: [undetermined]
Debug mode: yes
Blocking factor: (default)
Max blocking factor: (default)
Current tape: 30
Use list: all
Drive usage: 26 seconds
Cleaning required: no
UUID: bccd5246-747b-102e-a4b6-14feb5d265f9
Attachment 1:
Host: cgtccmgmt.cc.local
Raw device: /dev/sg1
Connection type: [unknown]
Inquiry data:
Vendor: IBM
Product: ULT3580-HH4
Firmware: B171
Serial number: 1068003728
Hardware compression: not available
Hardware encryption: not available
Warning: no hardware info is available for drive cTape2 - device is not in service
cTape2:
Device type: tape
Model: [none]
Serial number: 1068003531
In service: no (auto)
Not in service reason: Oracle Secure Backup encountered a problem while trying to run
job 1379.1 with this device. Though the job is retryable
immediately, the device has been marked 'not in service'. It will
remain so for 3 minutes or until the operator manually
places it in service.
Auto in service time: 04/23.11:41
Library: cLib1
DTE: 2
Automount: yes
Error rate: 8
Query frequency: [undetermined]
Debug mode: no
Blocking factor: (default)
Max blocking factor: (default)
Current tape: 23
Use list: all
Drive usage: 18 seconds
Cleaning required: no
UUID: 10c988a6-747c-102e-a4b6-14feb5d265f9
Attachment 1:
Host: cgtccmgmt.cc.local
Raw device: /dev/sg3
Connection type: [unknown]
Inquiry data:
Vendor: IBM
Product: ULT3580-HH4
Firmware: B171
Serial number: 1068003531
Hardware compression: not available
Hardware encryption: not available



-- --------------

[root@cgtccmgmt ~]# sg_scan -x -i
/dev/sg0: scsi0 channel=2 id=0 lun=0 cmd_per_lun=128 queue_depth=128
DELL PERC H700 2.10 [rmb=0 cmdq=1 pqual=0 pdev=0x0] dur=0ms
/dev/sg1: scsi1 channel=0 id=4 lun=0 cmd_per_lun=7 queue_depth=254
IBM ULT3580-HH4 B171 [rmb=1 cmdq=1 pqual=0 pdev=0x1] dur=1ms
/dev/sg2: scsi1 channel=0 id=4 lun=1 cmd_per_lun=7 queue_depth=254
IBM 3573-TL A.50 [rmb=1 cmdq=1 pqual=0 pdev=0x8] dur=1ms
/dev/sg3: scsi1 channel=0 id=5 lun=0 cmd_per_lun=7 queue_depth=254
IBM ULT3580-HH4 B171 [rmb=1 cmdq=1 pqual=0 pdev=0x1] dur=2ms
/dev/sg4: scsi2 channel=0 id=0 lun=0 [em] cmd_per_lun=1 queue_depth=1
TEAC DVD-ROM DV-28SW R.2A [rmb=1 cmdq=0 pqual=0 pdev=0x5] dur=9ms




Thanks in advance
  • 1. Re: no hardware info is available for drive x - device is not in service
    930835 Newbie
    Currently Being Moderated
    HI
    are u able to take file system backup from the same machine ? and check all the files are present on OSB home directory (/usr/local/oracle/backup), and please share the script which u r using to take backup.

    if yes please check the storage selector parameters and media family parameters .
  • 2. Re: no hardware info is available for drive x - device is not in service
    user54461 Newbie
    Currently Being Moderated
    Hi,

    Thanks for your answer.
    In /usr/local/oracle/backup i have this file:

    lrwxrwxrwx 1 root root 11 Jun 9 2011 obscheduled -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obopenssl -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obmediamgr -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obixd -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obhttpd -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obcleanup -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 observiced -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obrobotd -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obproxyd -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obdupvol -> ../.wrapper
    lrwxrwxrwx 1 root root 11 Jun 9 2011 obcopy -> ../.wrapper


    In which file is the configuration backup.

    Thanks in advance.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points