4 Replies Latest reply: Jul 20, 2012 10:04 AM by gimbal2 RSS

    Disable Java updates

      Why is there not an easy way to disable Java updates either while installing or afterwards?
      The only way I have found is to delete the executable files. In older versions this was an invaluable installation option, is there some reason this is so difficult?
        • 1. Re: Disable Java updates
          Unfortunately your question contains the assumption that there is no easy way to disable checking for Java updates.

          This may be the case in your computer. In mine, I open the Java Control Panel (which I can get to from the Windows Control Panel), select the Update panel, and uncheck the "Check for Updates Automatically" checkbox. But perhaps you're using another operating system? Sorry, I don't know how to open the Java Control Panel from any other O/S. Although you used to be able to open it directly from a browser; right now I don't see how to do that either.
          • 2. Re: Disable Java updates
            I guess I didn't clarify my question. I work in IT and have to update Java on ~400 computers and I am having problems disabling the Java update either during the installation or afterwards. I have tried the registry change which doesn't seem to work all the time and I would rather avoid deleting the update executable files.
            There is no way I am gong to manually change the update setting in the control panel for every computer.
            Thanks for trying to help.
            • 3. Re: Disable Java updates
              I have tried, daily, the uncheck updates box. it will be fine the rest of the day. Next time I turn my computer off and on it is back. Due to software limitations we are not able to have anything higher than v6 u19. Not everyone I work with will say no to the update install resulting in helpdesk tickets having to go in uninstall v7 and reinstall v6u19. Talk about a pain.
              • 4. Re: Disable Java updates
                Weird, on my update 33 installation (WindowsXP) the checkbox stays off after rebooting (just tried it, its friday and I don't want to do real work anymore). Did you remember to click apply after you click 'update never' in the nag dialog?

                If so: perhaps it works because I'm a local admin user.