13 Replies Latest reply on Jul 5, 2012 3:46 PM by 947685

    Developer GUI problem on x64 Fedora

      Hi All,

      I'm trying to use sqldeveloper in my job. I can run queries, etc, but GUI has some issues, eg. I can click to the menus, I can't choose option after left click, etc..

      Where can I submit new bug, please ?

      Does anybody eperiencing same issues ?

      Thank you in advance.
        • 1. Re: Developer GUI problem on x64 Fedora
          Brian Jeffries-Oracle
          Hi <insert your name here>-

          When asking a question, please provide all the details that someone would need to answer it. For example we need SQL Developer version, DB version, Java version, and OS as a minimum. A reproducible example is also important, where appropriate.

          That said, this is the right place for SQL Developer issues and if appropriate you may also submit a bug through your database support license.

          AFAIK no else has reported this issue though many weird things happen with java 7 so if that's what you are using, switching to java 6 may help. If not, please supply details so we can make sure we are looking at comparable scenarios.

          As well as the environment info, please specify exactly where this happens. E.g., "Can't select any items from main File, Edit, etc. menus with mouse. Keyboard navigation and accelerators work", "Context (right-click) menu on connection navigator pops up but can't select anything with mouse or keyboard. Result grid context menu works fine." or whatever your case is. The idea being we need to be able to follow the same steps you do.

          Brian Jeffries
          SQL Developer Team
          • 2. Re: Developer GUI problem on x64 Fedora
            Hi Brian, sorry as first I was curious where to submit bug. We have corporate license and really hard to get the number, but I can try.

            System / client details:

            Fedora 16 x86_64
            Oracle various versions, eg. 10,11 , but this is clearly GUI problem
            I have tried bith OpenJDK and Oracle Java 1.6.* to change in cfg as well, as in system by alternatives manager
            $ java -version
            java version "1.6.0_24"

            Behavior examples:
            -> right click on DB connection will open context menu, bu when you are over any field, it highlights field 3 lines below or isn't higligting anything
            -> you can't click anything
            -> "File" menu - same behaviour - you can open the menu, but higlighting or clicking is not working
            -> another stuff - "File" menu is visible only during mouse click holding
            -> etc.

            Thank you.
            • 3. Re: Developer GUI problem on x64 Fedora
              Jim Smith
              Are you using any fancy window managers or window decorators or whatever the current terminology is?

              I haven't seen it for a while, but there used to be a lot of reports of java not being able to cope with compiz for example. it may be worth simplifying your GUI environment to see if it sometjing like that.

              It is also worth checking you are using the jdk you think you are. Look in Help | About | Version.
              • 4. Re: Developer GUI problem on x64 Fedora
                Brian Jeffries-Oracle
                Hi Ivan -

                SQL Developer is not officially certified on Fedora (see Certification) but this is very strange behavior indeed.

                You didn't say specifically how you 'changed' java and SQL Developer remembers which you specified initially so just in case:

                To change which java it uses, edit <SQL Developer install dir>/sqldeveloper/bin/sqldeveloper.conf and change the SetJavaHome directive. For example:
                SetJavaHome /opt/jdk_local/jdk1.6.0_29

                If you've already done that or it doesn't help, please let me know & I'll see if someone on the team has Fedora 16 x86_64 or I can find a VM with it to test on.

                Brian Jeffries
                SQL Developer Team

                P.S.: Jim: Menus aren't working lol. Ivan: If you are still having trouble, let me know if you are using anything besides the default window manager

                Edited by: bjeffrie on Mar 29, 2012 11:45 AM
                • 5. Re: Developer GUI problem on x64 Fedora
                  Hi Jim, thanks for hints. I'm using Gnome shell 3 , which has Compizz built in, so it does make sense to try som manager without compizz. I'll try some other manager tomorrow in the job at will let you know.

                  • 6. Re: Developer GUI problem on x64 Fedora
                    Hi Brian,

                    I have tried changing either sqldeveloper.conf as well as system default java, but it doesn't help. Anyway I'll doublecheck tomorrow in the developer itself, as Jim mentioned, and let you know for sure.

                    Thank you.
                    • 7. Re: Developer GUI problem on x64 Fedora
                      Hi Jim, In fact I can't check version, as drop down menus have exactly same behavior :)
                      • 8. Re: Developer GUI problem on x64 Fedora
                        Finally, I have tried under KDE and developer is working properly ! This really seems to be either java or GNome shell 3 problem :/

                        Do you think, that Java 7 can solve this ?

                        Thank you.
                        • 9. Re: Developer GUI problem on x64 Fedora
                          Brian Jeffries-Oracle
                          Hi Ivan -

                          Full marks to Jim Smith!

                          Java 7 is also not certified and has presented a number of issues for example the ones in Re: SQL Developer 3.0  and Java SE 7?.

                          Searching the web for 'java compiz issue' turns up a lot of contradictory information, some saying issues are fixed with 1.6_20+ (which I notice you are beyond) and others still reporting problems.

                          The cleanest/least disruptive work around appears to be disabling compiz for SQL Developer specifically by adding
                          export AWT_TOOLKIT=MToolkit
                          to your <SQL Developer Install Directory>/sqldeveloper/bin/sqldeveloper start up script.

                          Brian Jeffries
                          SQL Developer Team
                          • 10. Re: Developer GUI problem on x64 Fedora
                            Hi Brian, thank you. I already found this workarrount by Google, but it's just causing some error:

                            $ export AWT_TOOLKIT=MToolkit
                            $ sqldeveloper

                            Oracle SQL Developer
                            Copyright (c) 1997, 2011, Oracle and/or its affiliates. All rights reserved.

                            # A fatal error has been detected by the Java Runtime Environment:
                            # SIGSEGV (0xb) at pc=0x00007f38eaac2b36, pid=4345, tid=139881439180544
                            # JRE version: 6.0_26-b03
                            # Java VM: Java HotSpot(TM) 64-Bit Server VM (20.1-b02 mixed mode linux-amd64 compressed oops)
                            # Problematic frame:
                            # C [libc.so.6+0x34b36] char+0x16
                            # An error report file with more information is saved as:
                            # /tmp/hs_err_pid4345.log
                            # If you would like to submit a bug report, please visit:
                            # http://java.sun.com/webapps/bugreport/crash.jsp
                            # The crash happened outside the Java Virtual Machine in native code.
                            # See problematic frame for where to report the bug.
                            /opt/sqldeveloper/sqldeveloper/bin/../../ide/bin/launcher.sh: riadok 544: 4345 Zrušené ${JAVA} "${APP_VM_OPTS[@]}" ${APP_ENV_VARS} -classpath ${APP_CLASSPATH} ${APP_MAIN_CLASS} "${APP_APP_OPTS[@]}"

                            Seems to be unresolvable yet :) never mind. Have a nie weekend !
                            • 11. Re: Developer GUI problem on x64 Fedora
                              I confirm this behaviour on Ubuntu 11.10 x64 as well.

                              sm0585@nb220:/data/sqldeveloper$ uname -a
                              Linux nb220 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 20:45:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

                              sm0585@nb220:/data/sqldeveloper$ java -version
                              java version "1.6.0_31"
                              Java(TM) SE Runtime Environment (build 1.6.0_31-b04)
                              Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mo

                              Having the export AWT_TOOLKIT=MToolkit line in causes the same exception as mentioned in previous message.

                              However you can use the keyboard shortcut keys on the main menu and context menus to get the desired functionality - you just can't highlight/select the menu item with the mouse!
                              • 12. Re: Developer GUI problem on x64 Fedora
                                Not just highlight, but also left & right click is not working :)
                                • 13. Re: Developer GUI problem on x64 Fedora
                                  I had the same problem with linux mint 13 using cinnamon.

                                  I could solve the problem by replacing the contents of sqldeveloper.sh with

                                  --#cd "`dirname $0`"/sqldeveloper/bin && bash sqldeveloper $*--

                                  export DESKTOP_SESSION=gnome-shell

                                  Do make sure that:
                                  - /opt/sqldeveloper31/sqldeveloper/bin/sqldeveloper is made executable.
                                  - replace /opt/sqldeveloper31 with the location you use.

                                  maybe some other DESKTOP_SESSION values will work as well?