1 Reply Latest reply: Apr 27, 2012 5:37 AM by Frank Nimphius-Oracle RSS

    Auto-Suggest feature in Combo-box LOV is not displaying non-unique values

    915744
      Hi,
      I have an auto-suggest feature implementation on a combo-box lov that displays the name and email-id of a list of people. There are non-unique names in the back-end, for example :
      Abraham Mason Abraham.Mason@oracle.com
      Abraham Mason jabraham@oracle.com
      But when I use the auto-suggest feature and type in, say 'Ab', instead of showing both the Abraham Masons the auto-suggest displays only one of the values.
      As in the example above the email-ids of the two Abraham Masons are different and unique.
      If I use the conventional drop down menu of the combo-box then both the values are visible.
      Is the auto-suggest feature implemented in a manner so as to display only unique values?

      This is the implementation of the auto-suggest feature that I have done -
      <af:column headerText="#{bindings.RqmtAtLevel1.hints.Owner.label}"
      id="c23" sortable="true" filterable="true"
      sortProperty="Owner"
      filterFeatures="caseInsensitive">
      <af:inputComboboxListOfValues id="ownerId"
      popupTitle="#{ResourcesGenBundle['Header.SearchandSelect.Searchandselectanobjectusingad']}: #{bindings.RqmtAtLevel1.hints.Owner.label}"
      value="#{row.bindings.Owner.inputValue}"
      model="#{row.bindings.Owner.listOfValuesModel}"
      required="#{bindings.RqmtAtLevel1.hints.Owner.mandatory}"
      columns="#{bindings.RqmtAtLevel1.hints.Owner.displayWidth}"
      shortDesc="#{bindings.RqmtAtLevel1.hints.Owner.tooltip}"
      autoSubmit="true">
      <f:validator binding="#{row.bindings.Owner.validator}"/>
      <af:autoSuggestBehavior suggestedItems="#{row.bindings.Owner.suggestedItems}"/>
      </af:inputComboboxListOfValues>
      </af:column>

      Thanks,
      Anirudh Acharya
        • 1. Re: Auto-Suggest feature in Combo-box LOV is not displaying non-unique values
          Frank Nimphius-Oracle
          Hi,

          don't find a bug entry about this, so if this indeed is a defect then this has not been filed. Do you have a test case ? If you have please zip it up and send it in a mail to me. My mail address is in my OTN profile (just click on my name until you get to the profile). Pleas rename the "zip" extension to "unzip" and mention the JDeveloper release you work with. The test case should work against the Oracle HR schema.

          If you need to track the issue, I suggest to file a service request with customer support yourself

          Frank