0 Replies Latest reply on Apr 27, 2012 3:34 PM by 933747

    Errors using WLST to create AuditProvider

    933747
      Hello,
      I am working on a WLST script so we have a way to create our domains programmatically. One of our requirements is to have auditing turned on. I used the Record WLST script function to record my steps manually and tried to follow the same steps in my script and I haven't been able to create The AuditProvider yet. I am using Weblogic 10.3.4 in a linux environment.

      The code im running is along these lines

      startEdit()
      cd('/SecurityConfiguration/myDomain/Reams/myrealm')
      cmo.createAuditor('myAuditor','weblogic.security.providers.audit.DefaultAuditor')


      the error I get says "Error: only getter and setter are supported"

      I have tried this before the domain is written as well as afterwards and get the same results. I have also tried replacing the cmo.createAuditor line
      with the following line
      create('myAuditor',''weblogic.security.providers.audit.DefaultAuditor') which yields an exception
      UnSupportedOperationException: Could not create generic operation:'weblogic.security.providers.audit.DefaultAuditor


      Thanks,
      Scott Kimbrell