7 Replies Latest reply: May 3, 2012 2:27 PM by Venkata Thiruveedhi-Oracle RSS

    oem not working

    927318
      hi i have installed oem 12c clould version on 11g and when i check dbconcole status its says repository not found.

      emctl status dbconsole
      OC4J Configuration issue. /u01/app/oracle/product/11.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_hostname_PROD not found.

      i tried to drop repository but it hangs up no response

      when i issue following command
      emca -repos create
      SEVERE: Dbcontrol Repository already exists. Fix the error(s) and run EM Configuration Assistant again in standalone mode.

      and after the following command

      $OMS_HOME/bin/emctl start oms
      Oracle Enterprise Manager Cloud Control 12c Release 12.1.0.1.0
      Copyright (c) 1996, 2012 Oracle Corporation. All rights reserved.
      Starting WebTier...
      WebTier Successfully Started
      Starting Oracle Management Server...
      Oracle Management Server is not functioning because of the following reason:
      Connection to the repository failed. Verify that the repository connection information provided is correct.


      thanks
      gagan
        • 1. Re: oem not working
          Venkata Thiruveedhi-Oracle
          Hi Gagan,

          To Install 12C Cloud Control, you have to first drop the DBControl which comes with the Database installation.

          Then you have to proceed with the Cloud Control installation. So, for Cloud Control installation, DB Control should be cleaned up properly which is the pre-req.

          And regarding the OMS startup, i observe there is some issue with the repository.

          Please verify of the Repository Database & Listener are up & running.

          Best Regards,
          Venkat
          • 2. Re: oem not working
            927318
            i drop and creat repos it went succesfully

            dbconsole status is running
            emctl status dbconsole
            Oracle Enterprise Manager 11g Database Control Release 11.2.0.3.0
            Copyright (c) 1996, 2011 Oracle Corporation. All rights reserved.
            https://hostname:1158/em/console/aboutApplication
            Oracle Enterprise Manager 11g is running.


            now i am facing this problem

            ./emctl status oms
            Oracle Enterprise Manager Cloud Control 12c Release 12.1.0.1.0
            Copyright (c) 1996, 2012 Oracle Corporation. All rights reserved.
            WebTier is Up
            Oracle Management Server is not functioning because of the following reason:
            Oracle Management Server version is not compatible with repository version. Repository needs to be Upgraded.

            also i am able to open https://hostname:1158/em/console/aboutApplication but actual url is https://hostname:1158/em which is not working

            thanks
            gagan
            • 3. Re: oem not working
              Venkata Thiruveedhi-Oracle
              Hi Gagan,

              You can never get it in working status.

              As i said earlier, you can not have DB Control & Cloud Control on the same machine.

              When you tried to drop and create the repos for dbcontrol, you have removed the repository information of the Cloud Control.

              So your Cloud Control will not run.

              NOTE: ONLY ONE REPOSITORY CAN BE RESIDED IN DB IT CAN BE db control OR cloud control.

              Best Regards,
              Venkat
              • 4. Re: oem not working
                927318
                ok venkat

                so what do i need to do ..
                do i need to uninstall oem 12c and drop dbcontrol and then again install 12c????

                if yes then what are the steps to do that.

                thanks
                gagan
                • 5. Re: oem not working
                  927318
                  i ran following command before installing 12c

                  emca -deconfig dbcontrol db -repos drop -SYS_PWD <sys pasword> -SYSMAN_PWD <sysman password>

                  gagan
                  • 6. Re: oem not working
                    Mnazim-Oracle
                    Yes you need to reinstall since you have dropped the 12c repository after installing 12c
                    Please follow the below install doc

                    http://docs.oracle.com/cd/E24628_01/install.121/e22624/toc.htm
                    • 7. Re: oem not working
                      Venkata Thiruveedhi-Oracle
                      Hi Gagan,

                      Yes, you need to go with a fresh install of 12C as the repository was in improper shape now.

                      Best Regards,
                      Venkat