6 Replies Latest reply: Aug 8, 2012 1:34 AM by 953183 RSS

    "Getting Started with Endeca Information Discovery" screencast series

    919610
      Hello,

      If you haven't yet heard the news, Oracle Endeca Information Discovery now has a YouTube channel (http://www.youtube.com/user/OracleEID/)!

      We have released a new screencast series for "Getting Started with Endeca Information Discovery". This screencast series will help users get up to speed quickly on the basics of Endeca Information Discovery. By the end of this screencast series, you should be ready to build your own application. You can find the full outline here: http://www.oracle.com/technetwork/middleware/endeca/learnmore/index.html

      If you haven't yet done it, install v2.3 and the Quick Start application (http://www.oracle.com/technetwork/middleware/endeca/downloads/index.html). Once you have the Quick Start application up and running, you are ready to get started!

      We want to hear from you! This forum thread is intended to gather any feedback you want to share about your experiences with the screencast series.

      Thanks,
      Carrie
        • 1. Re: "Getting Started with Endeca Information Discovery" screencast series
          RLJII
          Here are a few troubleshooting hints based on issues I ran into and mistakes I made when working through the examples.

          When loading data, if your graph says you processed 80, 654 records, check that you configured the correct number for Number of Skipped Records property in the Data Reader component and for the Skip Source Rows property in the Metadata. One should be configured as “1” and the other should be configured as “0”. If both are set to “1”, an extra record will be skipped.

          When creating the Survey Whitelist component, if you get an invalid data error for the .csv file, make sure you have a carriage return at the end of the last record. The record is incomplete without the carriage return. (In other words, your .csv file should end with a blank line.)

          If you get the error “output port 0 is undefined” in the log, you have connected an edge to the wrong output port in the source component. The edge should be connected to the top output port. (Note: This error will be in the log BEFORE the stack trace.)

          If you cannot map the data in the joiner, add an edge from the joiner to a target. An output join is required to map data.
          • 2. Re: "Getting Started with Endeca Information Discovery" screencast series
            919610
            Here's another tip:

            In "Getting Started Part 3.3 - Create Attribute Groups", if you receive this error:

            ERROR [WatchDog] - Node WEB_SERVICE_CLIENT0 finished with status: ERROR caused by: Cannot add nonexistent properties to groups: ProductName, ProductCategoryName, ProductSubcategoryName
            ERROR [WatchDog] - Node WEB_SERVICE_CLIENT0 error details:
            org.apache.axis2.AxisFault: Cannot add nonexistent properties to groups: ProductName, ProductCategoryName, ProductSubcategoryName
            at org.apache.axis2.description.OutInAxisOperationClient$NonBlockingInvocationWorker.run(OutInAxisOperation.java:451)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            at java.lang.Thread.run(Thread.java:619)

            Then it means you did not properly update the attributes in the Product Join and Category Join during Part 2.X - Exercises for the User. The original screencast for 2.X inadvertently left out that step. But, it has now been corrected. So, if you run into this error, re-watch GS2.X here: http://www.youtube.com/watch?v=ntO9M7ozLZ0&list=PLF23635ACA47F1E6D&index=8&feature=plpp_video
            • 3. Re: "Getting Started with Endeca Information Discovery" screencast series
              953183
              Hello,

              I have installed Endeca Information Discovery 2.3 Qucik Start on Windows 2008 x64 on VMware. When I open Integrator and run Baseline.grf I get below error -

              ===========================================================================================================

              ERROR [SocketReader] - Socket timed out while connected to the dgraph: java.net.SocketTimeoutException: Read timed out
              ERROR [SocketReader] - Received abort message from server: Socket timed out while connected to the dgraph: java.net.SocketTimeoutException: Read timed out
              ERROR [Consumer-0] - Error while trying to cancel Bulk Ingest: Read timed out
              java.net.SocketTimeoutException: Read timed out
                   at java.net.SocketInputStream.socketRead0(Native Method)
                   at java.net.SocketInputStream.read(SocketInputStream.java:129)
                   at java.net.SocketInputStream.read(SocketInputStream.java:182)
                   at java.io.DataInputStream.readInt(DataInputStream.java:370)
                   at com.endeca.BulkLoad.BulkIngester.readMessage(BulkIngester.java:312)
                   at com.endeca.BulkLoad.BulkIngester.access$000(BulkIngester.java:45)
                   at com.endeca.BulkLoad.BulkIngester$SocketReader.run(BulkIngester.java:382)
                   at java.lang.Thread.run(Thread.java:619)
              ERROR [WatchDog] - Graph execution finished with error
              ERROR [WatchDog] - Node ENDECA_BULK_ADD_OR_REPLACE_RECORDS1 finished with status: ERROR
              ERROR [WatchDog] - Node ENDECA_BULK_ADD_OR_REPLACE_RECORDS1 error details:
              INFO [WatchDog] - [Clover] Post-execute phase finalization: 0
              INFO [WatchDog] - [Clover] phase: 0 post-execute finalization successfully.
              INFO [WatchDog] - Execution of phase [0] finished with error - elapsed time(sec): 191
              ERROR [WatchDog] - !!! Phase finished with error - stopping graph run !!!

              ===========================================================================================================

              Any help is appreciated...
              • 4. Re: "Getting Started with Endeca Information Discovery" screencast series
                919610
                Can you confirm that you started the Endeca Server (via the Start Menu)? If you just run the InitDataStore.grf graph, does that succeed?
                • 5. Re: "Getting Started with Endeca Information Discovery" screencast series
                  953183
                  Yes, Endeca server is up and running. InitDataStore runs successfully if run by itself.

                  I tried re-installing quickstart, still getting time-out error. Can it be beacuse my PC is slow (I am running on VM ware) and some operation is taking longer than normal?
                  • 6. Re: "Getting Started with Endeca Information Discovery" screencast series
                    953183
                    Its working. My second guess was probably right. I increased memory (RAM) allocation to VM ware to 2 GB and Baseline graph executed successfully.

                    I will need to get an 8 GB machine!!! duh!!!