9 Replies Latest reply: Apr 25, 2013 10:26 AM by asmirnov RSS

    RCU  failed  with ORA-1031

    896410
      HI,
      the repository creation failed with

      ORA-1031
      create_essbase.sql
      create view ess_failover_active_node_view

      TIA
        • 1. Re: RCU  failed  with ORA-1031
          Sher Ullah Baig
          hi
          Can you share some more info?
          like: OS, OBIEE version and error detail??
          • 2. Re: RCU  failed  with ORA-1031
            896410
            obiee 11.1.1 - latest version
            on windows 7 .

            please let me know what i am missing .
            • 3. Re: RCU  failed  with ORA-1031
              Dhar
              Hi TIA,

              "ORA-1031" error refers to "Insufficient Privileges". So, make sure the database ID you are using for RCU, has "SYSDBA" role or equivalent.

              Hope this helps.

              Thank you,
              Dhar
              • 4. Re: RCU  failed  with ORA-1031
                896410
                Hi Dhar,
                I am installing as sys user only .It creates tablespaces without any issue it just fails on registry and portal component otherwise it creates everything else nicely.

                thank you
                kart

                Edited by: user12046749 on May 2, 2012 10:09 PM
                • 5. Re: RCU  failed  with ORA-1031
                  Dhar
                  Hi kart,

                  I checked the repository just now to realize that there are only two views : ESS_FAILOVER_ACTIVE_NODE_VIEW and schema_version_registry.

                  1. Are you running RCU for the first time? If not, I hope you are not using the same "PREFIX" as the old one.

                  2. I am sorry for asking this again, but why does only "view" creation is failing? I hope your ID is still a super user.

                  3. If you have some other instance, I was just thinking if you can create the views yourself.

                  Hope this helps.

                  Thank you,
                  Dhar
                  • 6. Re: RCU  failed  with ORA-1031
                    prophet
                    i have the same error (Registry). it says that it is warning, but the view was not created in scheme, so will be some missing functionality. is that right?

                    my system is:
                    database 11g r2 EE,
                    jdevstudio 11116 with preinstalled weblogic 10.3
                    rcu-win-11.1.1.6.0
                    windows 7 64-bit
                    • 7. Re: RCU  failed  with ORA-1031
                      G. SK
                      Please do the following:

                      1. Uninstall/Clean the existing install and reboot your computer.
                      2. Make sure you have SYS/SYSTEM schema access. I guess you do, so you are fine.
                      3. Run the RCU.bat from BIN folder, when you are at creating schema's option, try checking only these two below. Prefix could be anything like OBI or whatever you want it:
                      a. BIPLATFORM
                      B. MDS

                      These are the only two schema's you really need to install OBIEE 11g. I observed if you select all schemas to install, then depending on the system configuration, the RCU install might fail. Once everything is installed and ready to go, you can then create the other schema's as needed.

                      Try this and let me know.

                      Hope this helps.
                      • 8. Re: RCU  failed  with ORA-1031
                        user5222454
                        Per epmregistry.log, the issue was in creating ESS_FAILOVER_ACTIVE_NODE_VIEW

                        2013-04-17 11:31:13.216 rcu:Extracting Statement from File Name: 'C:\tempsw\OBIEE\rcuHome\\rcu\integration\\epm\registry\scripts\oracle\create_essbase.sql'Line Number: 14
                        2013-04-17 11:31:13.216 rcu:Extracted SQL Statement: [CREATE VIEW "ESS_FAILOVER_ACTIVE_NODE_VIEW" AS SELECT R.CLUSTER_NAME, LEASE.HOST_NAME, LEASE.PORT_NUMBER, LEASE.SECURE_PORT_NUMBER FROM ESS_FAILOVER_RESOURCE R LEFT JOIN ( SELECT LO.PORT_NUMBER, LO.HOST_NAME, LO.SECURE_PORT_NUMBER, L.RESOURCE_ID from ESS_FAILOVER_LEASE_OWNER LO, ESS_FAILOVER_LEASE L WHERE LO.LEASE_OWNER_ID = L.LEASE_OWNER_ID AND SYSTIMESTAMP < L.EXPIRY_TIME ) LEASE ON R.RESOURCE_ID = LEASE.RESOURCE_ID WHERE R.RESOURCE_NAME='essbase.sec'
                        ]
                        2013-04-17 11:31:13.216 rcu:Statement Type: 'DDL Statement'
                        JDBC SQLException - ErrorCode: 1031SQLState:42000 Message: ORA-01031: insufficient privileges

                        JDBC SQLException handled by error handler

                        Fix:
                        - Continue with the install with the "Ignore" button and let the RCU creation complete
                        - After the RCU install run, recreate the ESS_FAILOVER_ACTIVE_NODE_VIEW in DEV_EPM schema (if default)
                        CREATE VIEW "ESS_FAILOVER_ACTIVE_NODE_VIEW" AS SELECT R.CLUSTER_NAME, LEASE.HOST_NAME, LEASE.PORT_NUMBER, LEASE.SECURE_PORT_NUMBER FROM ESS_FAILOVER_RESOURCE R LEFT JOIN ( SELECT LO.PORT_NUMBER, LO.HOST_NAME, LO.SECURE_PORT_NUMBER, L.RESOURCE_ID from ESS_FAILOVER_LEASE_OWNER LO, ESS_FAILOVER_LEASE L WHERE LO.LEASE_OWNER_ID = L.LEASE_OWNER_ID AND SYSTIMESTAMP < L.EXPIRY_TIME ) LEASE ON R.RESOURCE_ID = LEASE.RESOURCE_ID WHERE R.RESOURCE_NAME='essbase.sec'

                        Edited by: user5222454 on Apr 17, 2013 10:30 AM

                        Edited by: user5222454 on Apr 17, 2013 10:32 AM
                        • 9. Re: RCU  failed  with ORA-1031
                          asmirnov
                          Hi,
                          In my case (I have 11.1.1.5) DEV_EPM doesn't have a veiw
                          ESS_FAILOVER_ACTIVE_NODE_VIEW

                          Another schema has this view, schema name is DEV_BIPLATFORM

                          The base TABLE ESS_FAILOVER_LEASE_OWNER
                          does exist in both schemas but does NOT have SECURE_PORT_NUMBE column.

                          Can you please let me know what version are you working with?

                          Thank you